cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
956
Views
0
Helpful
6
Replies

Ibgp session is in Idle state between two Cisco Routers

vijayarampm
Beginner
Beginner

Hi,

 

We have two Cisco 1841 routers and we are running IBGP between these two routers. Two different ISP links are connected in these routers and we are routing particular application traffic via one ISP and rest of the applications traffic via another ISP.

 

Now we are facing IBGP session is in idle state and it is not all establishing. Please help me to close this issue.

 

 

Regards,

Vijay.

6 Replies 6

Julio E. Moisa
VIP Mentor VIP Mentor
VIP Mentor

Hi

Vijay, could you please share the following:

- BGP Configuration

- Show ip bgp summary

- Show ip bgp neighbor x.x.x.x   or    Show bgp ipv4 unicast neighbor <x.x.x.x>

 

It could be generated because something is missed so the BGP session could not be established.. Was it working fine previously or any change between these routers? 

 

Thank you in advance




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

 

We have two routers in same location connected with two different ISP's. These two routers LAN interfaces connected with core switch. PFB required output.

 

Router 1 output

interface FastEthernet0/0
description >>> Connected to LAN <<<
ip address 10.29.1.3 255.255.255.128
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip nbar protocol-discovery
ip flow ingress
ip nat inside
ip virtual-reassembly
no ip mroute-cache
speed 100
full-duplex
no cdp enable
standby 1 ip 10.29.1.1
standby 1 preempt
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description SANMAR_VML-CLOUD_BSNL_MPLS_2Mb_WANS_Se0/0/0_4339/001/71/431#
bandwidth 2048
ip address 172.17.32.85 255.255.255.252
ip access-group ITCM in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
load-interval 30
max-reserved-bandwidth 95
service-policy output BSNL-Airtel_POLICY
!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.29.1.2 remote-as 64513
neighbor 172.17.32.86 remote-as 9829
!
address-family ipv4
neighbor 10.29.1.2 activate
neighbor 10.29.1.2 next-hop-self
neighbor 172.17.32.86 activate
neighbor 172.17.32.86 soft-reconfiguration inbound
neighbor 172.17.32.86 route-map BGP-OUT-BSNL out
no auto-summary
no synchronization
network 10.2.0.0 mask 255.255.0.0
network 10.2.1.11 mask 255.255.255.255
network 10.2.2.51 mask 255.255.255.255
network 10.2.2.52 mask 255.255.255.255
network 10.2.2.241 mask 255.255.255.255
network 10.2.2.242 mask 255.255.255.255
network 10.2.2.243 mask 255.255.255.255
network 10.2.2.244 mask 255.255.255.255
network 10.2.2.248 mask 255.255.255.255
network 10.2.4.11 mask 255.255.255.255
network 10.2.4.12 mask 255.255.255.255
network 10.2.4.13 mask 255.255.255.255
network 10.2.4.131 mask 255.255.255.255
network 10.2.4.132 mask 255.255.255.255
network 10.2.4.133 mask 255.255.255.255
network 10.2.4.134 mask 255.255.255.255
network 10.2.4.135 mask 255.255.255.255
network 10.2.4.200 mask 255.255.255.255
network 10.2.5.11 mask 255.255.255.255
network 10.2.5.12 mask 255.255.255.255
network 10.2.5.13 mask 255.255.255.255
network 10.2.5.101 mask 255.255.255.255
network 10.2.7.11 mask 255.255.255.255
network 10.2.7.12 mask 255.255.255.255
network 10.2.7.13 mask 255.255.255.255
network 10.2.7.14 mask 255.255.255.255
network 10.2.7.15 mask 255.255.255.255
network 10.2.7.16 mask 255.255.255.255
network 10.2.7.17 mask 255.255.255.255
network 10.2.7.200 mask 255.255.255.255
network 10.25.101.9 mask 255.255.255.255
network 10.25.101.13 mask 255.255.255.255
network 10.29.1.0 mask 255.255.255.128
network 10.45.1.1 mask 255.255.255.255
exit-address-family

 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.29.1.2 4 64513 696 696 0 0 0 never Idle
172.17.32.86 4 9829 497 342 773 0 0 04:25:46 99

 

 

Router 2 output

interface FastEthernet0/0
description >>> Connected to LAN <<<
ip address 10.29.1.2 255.255.255.128
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip nbar protocol-discovery
ip virtual-reassembly
ip route-cache flow
no ip mroute-cache
speed 100
full-duplex
no cdp enable
standby 1 ip 10.29.1.1
standby 1 priority 110
standby 1 preempt
!
interface FastEthernet0/1
description SANMAR_VML-CLOUD_BHARTI_MPLS_8Mb_WANS_Fa0/1_1088039
bandwidth 8192
ip address 192.168.1.42 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip route-cache flow
load-interval 30
duplex auto
speed 100
max-reserved-bandwidth 95
service-policy output BSNL-PARENT

 

router bgp 64513
no synchronization
bgp log-neighbor-changes
network 10.2.0.0 mask 255.255.0.0
network 10.2.1.11 mask 255.255.255.255
network 10.2.2.51 mask 255.255.255.255
network 10.2.2.52 mask 255.255.255.255
network 10.2.2.200 mask 255.255.255.255
network 10.2.2.241 mask 255.255.255.255
network 10.2.2.242 mask 255.255.255.255
network 10.2.2.243 mask 255.255.255.255
network 10.2.2.244 mask 255.255.255.255
network 10.2.2.246 mask 255.255.255.255
network 10.2.2.248 mask 255.255.255.255
network 10.2.4.11 mask 255.255.255.255
network 10.2.4.12 mask 255.255.255.255
network 10.2.4.13 mask 255.255.255.255
network 10.2.4.100 mask 255.255.255.255
network 10.2.4.101 mask 255.255.255.255
network 10.2.4.131 mask 255.255.255.255
network 10.2.4.132 mask 255.255.255.255
network 10.2.4.133 mask 255.255.255.255
network 10.2.4.134 mask 255.255.255.255
network 10.2.4.135 mask 255.255.255.255
network 10.2.4.200 mask 255.255.255.255
network 10.2.5.11 mask 255.255.255.255
network 10.2.5.12 mask 255.255.255.255
network 10.2.5.13 mask 255.255.255.255
network 10.2.5.100 mask 255.255.255.255
network 10.2.5.101 mask 255.255.255.255
network 10.2.6.100 mask 255.255.255.255
network 10.2.7.11 mask 255.255.255.255
network 10.2.7.12 mask 255.255.255.255
network 10.2.7.13 mask 255.255.255.255
network 10.2.7.14 mask 255.255.255.255
network 10.2.7.15 mask 255.255.255.255
network 10.2.7.16 mask 255.255.255.255
network 10.2.7.17 mask 255.255.255.255
network 10.2.7.100 mask 255.255.255.255
network 10.2.7.101 mask 255.255.255.255
network 10.2.7.200 mask 255.255.255.255
network 10.25.101.13 mask 255.255.255.255
network 10.45.1.1 mask 255.255.255.255
network 10.45.1.2 mask 255.255.255.255
network 10.50.15.16 mask 255.255.255.248
neighbor 10.29.1.3 remote-as 64513
neighbor 10.29.1.3 next-hop-self
neighbor 192.168.1.41 remote-as 9730
neighbor 192.168.1.41 allowas-in
neighbor 192.168.1.41 soft-reconfiguration inbound
neighbor 192.168.1.41 route-map BGP-IN-BHARTI in
neighbor 192.168.1.41 route-map BGP-OUT-BHARTI out
no auto-summary
!
ip route 10.2.0.0 255.255.0.0 10.29.1.4
ip route 10.10.1.0 255.255.255.128 192.168.1.2
ip route 10.50.15.16 255.255.255.248 10.29.1.4

 

 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.29.1.3 4 64513 849 849 0 0 0 never Active
192.168.1.41 4 9730 482 444 360 0 0 05:00:59 111

 

Hi,

Thank you, please let me check the configuration, are you able to ping these IP addresses:

10.29.1.3

10.29.1.2

 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hello

How 10.29.1.x being seen by either rtr?
Is this a direct p2p connection or via an igp via switching infrastructure

Can you ping each ibgp peer address from either site router?

Res
Paul

Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi,

 

Issue resolved. There was a power disruption in the morning. Due that both Routers got rebooted. Post reboot this issue occurred.

 

Identified router Id is same in both routers. That has been changed now and Ibgp session established.

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

Just like to add and confirm with you is that IBGP peering between your two site rtrs isnt working, but you do have connectivity to both ISP's via ebgp ?

 

Do you have network reachability between your sites ibgp rtrs and if how is that connectivity established- static or dyanmic routing ( rip,eigrp/opf)

 

Can you post running config of both site rtrs please as along with julios suggested posts

 

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers