cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
721
Views
0
Helpful
1
Replies

IBM Bladeswitch connecting to core-switches causing STP Loops

netadmindha
Beginner
Beginner

Dear All,

I am facing Spanning Tree Loop when i connect the IBM Blade Centre switches to my Core1 & Core2 (6513) .

Let me brief you the problem further as below .

Current setup : 

we have two core-switches (6513) connecting  each other  with L2 ether-channel.

Core-switches 1 & 2 are connected to my Access-switches with trunk and vlan 1 is native vlan.

We have Production  IBM Blade Centre switch (2) are connected on Core1 switch with access port vlan 222.

We have another Nortel Blade swithes connected on Core1 switch with access port vlan 222.

New Requirement :-

To connect the IBM Blade Centre switch as attached in the diagram need to connect  as follows.

1) Blade-sw1 & 3 will be connected to Core1

2)Blade-sw2 & 4 will be connected to Core2

This requirement is to provide the servers redundancy interms of proividing switch redundancy.

STP Loop issue  :-

First we connected  the Blade-sw2 & 4 will be connected to Core2 as Port-channel trunk ports  and channel has come-up

when we connected the Blade-sw1 & 3 will be connected to Core1 we immediately got a Loop in the network  and we immdiately

found that on the Bladeswitch 1 the port-channel was configured as follows .

!

interface Port-channel1

description " Connected to Core Switch-1 PORT G2/12-13"

switchport mode trunk

logging event trunk-status

link state group 1 upstream

storm-control broadcast level 70.00

spanning-tree bpdufilter disable

-------------------------------------------

interface GigabitEthernet0/15

--More--                            description " Connected to Core Switch-1 PORT G2/12"

switchport mode trunk

logging event trunk-status

udld port aggressive

storm-control broadcast level 70.00

channel-group 1 mode on

link state group 1 upstream

  spanning-tree bpdufilter disable

!

interface GigabitEthernet0/16

description " Connected to Core Switch-1 PORT G2/13"

switchport mode trunk

logging event trunk-status

udld port aggressive

storm-control broadcast level 70.00

channel-group 1 mode on

link state group 1 upstream

spanning-tree bpdufilter disable

When we remove the

"" link state group 1 upstream"" the command from port-channel members and connect the physical cable  and no Loop

has been observed . however it has already impacted my Access-switches & Critical other two IBM Blade servers &

Nortel Blade switches which got resovled un-shutting the trunk/acces interfaces and some with reboot access switches.

As per cisco link cisco recommeds us to not to use the command"" link state group 1 upstream " on port channel

member gig 0/15,0/16 

Can somebody please tell me configuring the  ""link state group 1 upstream"" the commands on port-channel

have any worst impact like STP Loop .

Dear Cisco Team ..... Please comment your valuable suggessions at the earliest.

I am attaching the Blade-swtiches config & IBM Blade Centre switch connectivity.

Appreciate your valuable comments !

Regards,

Akber Mirza

1 Reply 1

netadmindha
Beginner
Beginner

Hello,

Can somebody please respond to my Query

Dear Cisco Team - Kindly post your comments.

Regards,

Akber Mirza.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers