cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
4806
Views
0
Helpful
11
Replies
Zarahelll
Beginner

IGMP Snooping on 3560

Good day to you all

I need a little help on how to configure igmp snooping on a 3560.

I have a pure L2 switching network and 2 hosts on the same vlan that want to communicate a protocol between each other using multicast packets.

I wanted to configure ip snooping only on this vlan and create a multicast group limited to only these 2 host ir order to make sure that the multicast traffic is only between both of them.

Since both are sender and receiver I´m not quite sure on how to configure this. In theory I also need to set an IP Multicast Address on the switch to where the hosts will send their multicast packets.

This is basically the network:

HOST_A---|SWITCH_A|==|SWITCH_B|---HOST_B

Can anyone help me with the configurations required to make it work?

Best regards

11 REPLIES 11
Raju Sekharan
Cisco Employee

by default igmp snooping should be on

if it is not on, use the below command in global mode to enable it

ip igmp snooping

Also configure on of the switch as igmp snooping querier becasue you don't have any multicast-routing

ip igmp snooping querier

Reference link:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_52_se/configuration/guide/swigmp.html#wp1193337

Thank you

Raju

rajs2

Thank you for your feedback

I just have one doubt. What if I want to use an unregistered multicast address? I don´t want the hosts to send multicast packets through 224.0.0.1 address...I want to use any other address (for instance 239.10.10.1). Do I have to configure it on the switch?

My current configs are:

ip igmp snooping querier

ip igmp profile 1

    permit

    range 239.10.10.1 239.10.10.1

interface GigabitEthernet1/20

switchport access vlan 50

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

no ip igmp snooping tcn flood

ip igmp filter 1

end

Will this suffice?

Hi

The hosts can send multicast to any group. There is no need of additional config on the switch.

however for the igmp snooping querier to work, there should be an IP address configured on the switch

Raju

My current config:

ip igmp snooping querier address 192.10.40.5

ip igmp profile 1

    permit

    range 239.10.10.1 239.10.10.1

interface GigabitEthernet1/20

switchport access vlan 50

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

no ip igmp snooping tcn flood

ip igmp filter 1

end

The querier address IP address is part of the host's network range.

The config looks good

Thank you

Raju

rajs2

Thank you very much for your help. Just one final question: I´ve tried disabling igmp snooping globally, since I just want it to work on 1 specific vlan, but when I do so I'm not able to set a querier address. It returns an error saying it requires for igmp snooping to be set globally.

Since you mentioned I need ip igmp snooping querier for my L2 Multicast solution to work, is there any way to set it up without having the igmp snooping defined globally?

remove the querier and disable igmp snooping globally

After that configure igmp snooping only for VLAN

ip igmp snooping vlan

After that configure the querier

Thank you

Raju

Doesn´t work.

I´ve enabled it on vlan 50:

SWA# show ip igmp snooping

Global IGMP Snooping configuration:

-------------------------------------------

IGMP snooping                : Disabled

IGMPv3 snooping              : Disabled

Report suppression           : Disabled

TCN solicit query            : Disabled

TCN flood query count        : 2

Robustness variable          : 2

Last member query count      : 2

Last member query interval   : 1000

Vlan 10:

--------

IGMP snooping                       : Disabled

IGMPv2 immediate leave              : Disabled

Multicast router learning mode      : pim-dvmrp

Robustness variable                 : 2

Last member query count             : 2

Last member query interval          : 1000

Vlan 50:

--------

IGMP snooping                       : Enabled

IGMPv2 immediate leave              : Disabled

Multicast router learning mode      : pim-dvmrp

Robustness variable                 : 2

Last member query count             : 2

Last member query interval          : 1000

but when I check for the igmp querier I have no output:

SWA#show ip igmp snooping querier

Vlan      IP Address               IGMP Version   Port            

-------------------------------------------------------------

SWA#

after that did you try configuring igmp snooping querier for that Vlan

Raju

Yes. This is my current config:

ip igmp snooping querier

ip igmp snooping vlan 50 querier address 192.168.40.5

no ip igmp snooping

ip igmp snooping vlan 50

ip igmp profile 1

    permit

    range 239.10.10.1 239.10.10.1

interface GigabitEthernet1/20

switchport access vlan 50

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

no ip igmp snooping tcn flood

ip igmp filter 1

end

But when I perform the 'show ip igmp snooping querier' command I get no output:

SWA#show ip igmp snooping querier

Vlan      IP Address               IGMP Version   Port            

-------------------------------------------------------------

SWA#

Can you try confguring  " ip igmp snooping querier" under interface vlan 50

Raju

Content for Community-Ad
This widget could not be displayed.