cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
119
Views
0
Helpful
4
Replies
Highlighted
Beginner

Increasing Subnet size to allow more addresses

Based on my configuration below, can someone assist me in changing the VLAN 30 to a subnet that will allow more addresses. Maybe 192.168.30.1 - 192.168.31.254? Thank you for your help.

 

Current configuration : 7309 bytes
!
! Last configuration change at 13:17:33 CDT Sun May 27 2018
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname Core
!
boot-start-marker
boot-end-marker
!
enable secret HIDDEN
enable password HIDDEN
!
username cisco privilege 15 secret 5 $1$gfxt$AiSfqjNeB5/ztq7LDztSB/
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring
switch 1 provision ws-c3750g-24ps
system mtu routing 1500
ip routing
ip domain-name HIDDEN
ip name-server 192.168.10.2
!
!
!
!
crypto pki trustpoint TP-self-signed-2955339520
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2955339520
 revocation-check none
 rsakeypair TP-self-signed-2955339520
!
!
crypto pki certificate chain TP-self-signed-2955339520
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32393535 33333935 3230301E 170D3933 30333031 30303033
  34315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39353533
  33393532 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100F459 BBD7C0AF 2BD93C88 DD8E8287 AA235578 11176144 625D417A E0EE7716
  418D18E5 189EF478 7D936F76 2162E458 8E57ECDA 86C3D290 735D3B30 D7C085A7
  06C5ED23 EE54E38F 5CAC8C59 67A22EB6 7D74D752 15FADD29 3DAD0633 CDEC95AB
  285B0E0C 6FB5192E 4EC1272F 68D3615A EDADDFAA 57CC7554 3FA8DD12 04069324
  FA890203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14E7A165 18C74807 55EE27EF 8D9E8B8A AE32754E B6301D06
  03551D0E 04160414 E7A16518 C7480755 EE27EF8D 9E8B8AAE 32754EB6 300D0609
  2A864886 F70D0101 05050003 81810038 E8E1234D 35B7925A CE8C41CD 280A9177
  DA859E09 D5A4A087 4D138F3A 8905A3DF 5692557E 2AF74D23 C30D0EC7 C54C5E2F
  F0FC5DE4 408D498F BFDEDBC1 176B137A B47A754B 30B01EF7 B9C6555C 0B973054
  0BAB6E38 97E30605 DD937FB3 4FE42879 3F2F8EFE BE3E7A0D 323DA2A3 E47B7741
  37F9AEC9 48F23ECC C31BD3B7 D6193C
        quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/9
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/10
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/12
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/13
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/14
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/15
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/16
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/17
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/18
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/19
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/20
 switchport access vlan 254
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/21
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/22
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,20,30,1001-1005
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.10.2
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
 ip access-group 130 in
 ip helper-address 192.168.10.2
!
interface Vlan254
 ip address 192.168.254.1 255.255.255.0
!
ip default-gateway 192.168.10.254
ip http server
ip http authentication local
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.10.254
!
!
!
line con 0
line vty 0 4
 password HIDDEN
 login
line vty 5 15
 password HIDDEN
 login
!
ntp server time1.google.com
ntp server time2.google.com
end

4 REPLIES
VIP Rising star

Re: Increasing Subnet size to allow more addresses

Change the mask to 192.168.30.1 255.255.254.0.

If you need additional explanation just say so.

Hope this helps

Beginner

Re: Increasing Subnet size to allow more addresses

Thank you, I did that to no avail. Maybe the issue is on the DHCP server? What kind of scope options should I put in to Windows DHCP?

VIP Rising star

Re: Increasing Subnet size to allow more addresses

Changing it on the VLAN interface will accommodate the hosts, but yes, you need to increase the scope in the DHCP server. The size would all depend on how you want things to work and if you'll be assigning static IPs to devices which should not be in the scope. If the subnet is DHCP only, then you could go as large as you want, except for the VLAN interface IP of course.

VIP Expert

Re: Increasing Subnet size to allow more addresses

Hi,

You can simply change the mask to a /23 and that will give you 512 addresses.

192.168.30.0

255.255.254.0 = 23

HTH

CreatePlease to create content
Ask the Expert- Webex Hybrid Services Solutions