cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

972
Views
11
Helpful
7
Replies
Beginner

inter vlan routing

Hi my friend.
What is the method's of inter vlan routing?
Tnx

Sent from Cisco Technical Support iPhone App

7 REPLIES 7
Hall of Fame Community Legend

inter vlan routing

Depends on what you have.

Do you have a Layer 3 switch or a router?

How To Configure InterVLAN Routing on Layer 3 Switches

Configuring InterVLAN Routing

Beginner

Re: inter vlan routing

No i just want name of this method! Both with mls and router.

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

inter vlan routing

Hello Sahar,

If you will use the router for the inter vlan routing than its named as router on a stick, while if you used a Layer three switch than its called Layer 3 switch-Inter VLAN Routing

Hope it will help

Ahmed Sonba

Beginner

Re: inter vlan routing

Tnx i get my answer!!!
one question i have. What is the other methods of inter vlan routing except with router and mls!!?

Sent from Cisco Technical Support iPhone App

inter vlan routing

The last method is to configure each router port ( as a layer 3 port) connecting to each switch port as an access port.

this is the less scalable method of the 3.

Example

PC1---SWITCH---ACCESS_PORT_VLAN_20---ROUTER-----ACCESS_PORT_VLAN_10SWITCH----PC2

If you do not have any other question, please mark the question as answered,

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Participant

Re: inter vlan routing

HI Sarah,

Its really depends how you want to configure inter vlan routing and what you want to use.

http://www.firewall.cx/networking-topics/vlan-networks/222-intervlan-routing.html

Please check this link and its explaining all the different methods you can use.

thanks

VIP Mentor

inter vlan routing

Hi Sahar,

you have to configure subinterfaces for encapsulation.

see the example:If you are configuring on Router


Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface

Router(config)#interface f0/0
Router(config-if)#no shutdown

(Note: The main interface f0/0 doesn’t need an IP address but it must be turned on)

Router(config)#interface f0/0.0
Router(config-subif)#encapsulation dot1q 15
Router(config-subif)#ip address 192.168.15.1 255.255.255.0
Router(config-subif)#interface f0/0.1
Router(config-subif)#encapsulation dot11 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

(Note: In the “encapsulation dot1q 15″ command, 15 is the VLAN ID this interface operates in)

Configure VLAN

Switch(config)#vlan 15
Switch(config-vlan)#name SALES
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name TECH

Set ports to access mode & assign ports to VLAN

Switch(config)#interface range fa0/1
Switch(config-if)#no shutdown
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 15
Switch(config-if)#interface range fa0/3
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)# switchport access vlan 20

see the example:If you are configuring on layer 3 switch:

ip routing
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access

interface Vlan15
ip address 192.168.15.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0

And on hosts just assign IP addresses and default gateways (to the corresponding interface VLANs) -> hosts in different VLANs can communicate.

Regards

please rate if it helps.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards