cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2428
Views
0
Helpful
2
Replies
boueng
Beginner

Internal power supply is declared unavailable when the 3750G connect to RPS

Hi Everyone,

After upgraded Cisco 3750G switches to IOS Version 122-55.SE7, the output of "show env all" showing the built-in power is unavailable.  If we remove RPS, the switches show built-in is good, see the output below.  I wonder has anyone seen this?  It looks like a bug to me.

Disconnect RPS: .............................................

Cisco3750G-01#sh env all
FAN is OK
TEMPERATURE is OK
Temperature Value: 32 Degree Celsius
Temperature State: GREEN
Yellow Threshold : 55 Degree Celsius
Red Threshold    : 65 Degree Celsius
SW  PID                 Serial#     Status           Sys Pwr  PoE Pwr  Watts
--  ------------------  ----------  ---------------  -------  -------  -----
1  Built-in                                         Good

SW  Status          RPS Name          RPS Serial#  RPS Port#
--  -------------   ----------------  -----------  ---------
1   Not Present     <>

RPS Connected: ..............................................

Cisco3750G-01#sh env all
FAN is OK
TEMPERATURE is OK
Temperature Value: 32 Degree Celsius
Temperature State: GREEN
Yellow Threshold : 55 Degree Celsius
Red Threshold    : 65 Degree Celsius
SW  PID                 Serial#     Status           Sys Pwr  PoE Pwr  Watts
--  ------------------  ----------  ---------------  -------  -------  -----
1  Built-in                                         Unavail

SW  Status          RPS Name          RPS Serial#  RPS Port#
--  -------------   ----------------  -----------  ---------
1   Active          <>

 

Thank you..

2 REPLIES 2
Reza Sharifi
Hall of Fame Expert

Hi,

It could be a bug, because even when the RPS is disconnected, the output is not correct.

It should show something like this:

Try a different version and test again.

c3750#sh env all
FAN 1 is OK
FAN 2 is OK
FAN PS-1 is OK
FAN PS-2 is OK
SYSTEM TEMPERATURE is OK
System Temperature Value: 23 Degree Celsius
System Temperature State: GREEN
Yellow Threshold : 46 Degree Celsius
Red Threshold    : 60 Degree Celsius
SW  PID                 Serial#     Status           Sys Pwr  PoE Pwr  Watts
---  ------------------  ----------  ---------------  -------  -------  -----
1A  C3KX-PWR-350WAC     xxxxxxxxxxxx OK              Good     Good     350/0
1B  C3KX-PWR-350WAC     xxxxxxxxxxxx OK              Good     Good     350/0

SW  Status          RPS Name          RPS Serial#  RPS Port#
--  -------------   ----------------  -----------  ---------
1   Not Present     <>

c3750#

Hi,

I have the same behavior on C2960S-48TS-L and C2960S-24TS-L running 12.2(58)SE2.

.

One connected to a RPS is showing

GSFRDCE-SW091#sh env power

SW  PID                 Serial#     Status           Sys Pwr  PoE Pwr  Watts

---  ------------------  ----------  ---------------  -------  -------  -----

1  Built-in                                         Unavail

And another one without RPS is showing :

GSFRDCQ-SW091#sh env power

SW  PID                 Serial#     Status           Sys Pwr  PoE Pwr  Watts

---  ------------------  ----------  ---------------  -------  -------  -----

1  Built-in                                         Good

Regards,