cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1025
Views
0
Helpful
4
Replies
unleashed333
Beginner

Internet is working only on VLAN 1

Greetings

I need to connect two switches with each have different Vlans and wants to Connect the users of These Switches to Existing Network of Company(Vlan 1 ; showing Right in the picture).

I have created Vlans and able to route packets from Two Vlans (10,20) to VLAN 1 but i am unable to get access to Users existing in vlan 10,20.

Internet is working fine from VLAN1 and existing network did not have any router ,it is just a DSL modem and did not have Static /Default Route option,NAT.

What Option should i choose for it.

3750x have 12 Mini Gbic Slots and 1 Routed port and did not have any NAT options in it.

Please find the attached image and guide me,I am thankful to you.

4 REPLIES 4
mfurnival
Enthusiast

Something must be doing the routing to the internet - presumably your DSL modem has an interface in VLAN1 with an IP address in the same subnet as your VLAN1 users.I think you need to add a bit more detail about the switch configurations and the IP address scheme you are using in the different VLANs. I suspect that your DSL modem does not know how to get back to VLAN10 and VLAN20 addresses hence no internet.

Ip of Modem is 192.168.2.1 but i searched it hard,No option of NAT/Staitc Route/Vlan in it.

3750X ON LEFT

!

enable password cisco

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

ip address 10.0.0.2 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.99 255.255.255.0

!

router eigrp 10

network 192.168.1.0

network 10.0.0.0

auto-summary

!

ip classless

!

!

!

ip dhcp excluded-address 192.168.10.0 192.168.10.50

!

ip dhcp pool VLAN10POOL

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 192.168.1.100

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

no switchport

ip address 10.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

!

router eigrp 10

network 192.168.10.0

network 10.0.0.0

network 192.168.20.0

auto-summary

!

ip classless

!

!

3750X on RIGHT

!

enable password cisco

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

ip address 10.0.0.2 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.99 255.255.255.0

!

router eigrp 10

network 192.168.1.0

network 10.0.0.0

auto-summary

!

ip classless

!

!

ip route 0.0.0.0 0.0.0.0 192.168.2.1

Well the modem must be doing NAT, either that or something further upstream is doing it - you would not be able to get on the internet otherwise. I still think my guess about the DSL modem not knowing how to get back to your 192.168.10.x and 192.168.20.x holds true. Can you add static routes on the DSL modem?

ALIAOF_
Frequent Contributor

Why do you have so many switches in the mixture?  Especially the 2960-24?

What is the second 3750x on the left for?  What are the IP ranges of all the VLAN's in your network?

Looks like you are running EIGRP which is fine but you do need a router connected in this mixture that can route all that internal traffic to the outside and do the PAT.  Usually DSL modems are just cheap modems or modem/routers and they can't do all that.

Internet from VLAN1 will work because that is the network the DSL modem is on.  So basically need a router to do the routing.