cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
122
Views
0
Helpful
1
Replies
Highlighted
Beginner

InterVLAN Routing, cant ping

Hello all!

I am new to cisco IOS and am trying to setup some basic inter vlan routing. I am unable to ping from one vlan to the other. I just recently purchased a 3750 switch and think i'v got it all setup right. Can someone help?

I have the default vlan 1 setup as ip 192.168.1.0/24 and vlan 3 setup as ip 192.168.3.0/24. The two can not ping each other.

vlan 1 is connected to a consumer router (netgear) which is connected to the internet, and I want vlan 3 to be able to access the internet.

3750switch#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, Vlan1
C    192.168.3.0/24 is directly connected, Vlan3
S*   0.0.0.0/0 [1/0] via 192.168.1.1

3750switch#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/1, Gi1/0/2, Gi1/0/3
                                                Gi1/0/4, Gi1/0/6, Gi1/0/7
                                                Gi1/0/8, Gi1/0/9, Gi1/0/10
                                                Gi1/0/11, Gi1/0/12, Gi1/0/13
                                                Gi1/0/14, Gi1/0/16, Gi1/0/17
                                                Gi1/0/18, Gi1/0/19, Gi1/0/20
                                                Gi1/0/21, Gi1/0/22, Gi1/0/23
                                                Gi1/0/24, Gi1/0/25, Gi1/0/26
                                                Gi1/0/27, Gi1/0/28
2    work                             act/lshut
3    garage                           active    Gi1/0/5, Gi1/0/15
10   home                             act/lshut
11   rooms                            act/lshut
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

3750switch#show running-config
Building configuration...

Current configuration : 3903 bytes
!
version 12.2
<--OUTPUT SUPPRESSED-->
!
hostname 3750switch
!
boot-start-marker
boot-end-marker
!
<-- OUTPUT SUPPRESSED -->
!
!
!
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring
switch 1 provision ws-c3750g-24ts
system mtu routing 1500
!         
shutdown vlan 2
shutdown vlan 10
shutdown vlan 11
ip routing
ip dhcp excluded-address 192.168.3.3 192.168.3.254
!
ip dhcp pool vlan3
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
!
!
!
!

<-- OUTPUT SUPPRESSED -->

!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!         
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!         
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.168.1.250 255.255.255.0
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 ip address 192.168.11.1 255.255.255.0
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
ip http secure-server
!
!
<--OUTPUT SUPPRESSED-->
end

Thanks in advanced

P

1 REPLY 1
Highlighted
Frequent Contributor

please close this as getting answers  on

VLANs not routing to eachother - 3750 post

Content for Community-Ad