cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
27
Views
0
Helpful
1
Replies
Highlighted
Beginner

InterVLAN routing issue

Hello, i am having trouble getting 2 PC to ping each other on 2 differnent vlans that i have set up on my cisco 3750x

there is vlan 10 - ip address 192.168.10.1 

PC1 that is connected to this is 192.168.10.2 - 255.255.255.0 - 192.168.10.1

and vlan 20 - ip address 192.168.20.1

PC2 that is connected to this is 192.168.20.2 - 255.255.255.0 - 192.168.20.1

i have got ip routing enabled

From the switch i am able to ping all devices

When i turn the windows firewall off PC1 is able to ping PC2 but when it is turned back on even with file and printer sharing enable the ping requests time out.

What firewall exception do i need to enable in order to get ICMP working? incase there is something i havent done in the switch the running-config is below

Building configuration...

Current configuration : 3749 bytes
!
! Last configuration change at 19:17:23 UTC Thu Mar 16 2017
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HomeSW01
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c3750x-48
system mtu routing 1500
ip routing
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cache
shutdown
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
switchport access vlan 10
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
switchport access vlan 20
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
......(cut to save space).....
!
interface GigabitEthernet1/0/48
no switchport
ip address 192.168.1.254 255.255.255.0
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.10.2
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
ip helper-address 192.168.20.2
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
ip helper-address 192.168.30.2
!
interface Vlan151
ip address 192.168.151.1 255.255.255.0
ip helper-address 192.168.151.2
!
interface Vlan152
ip address 192.168.152.1 255.255.255.0
ip helper-address 192.168.152.2
!
ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
line con 0
line vty 5 15
!
end

1 REPLY 1
VIP Expert

You may have a firewall

You may have a firewall software on your PCs installed/enabled that is blocking ping.  Disable the firewall and try again?

HTH

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards