cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
340
Views
5
Helpful
5
Replies
Highlighted
Beginner

IR829 how to access internet via Gi1-4 using cellular 0

I am working on Cisco IR829GW.

I have my cellular 0 working and can ping to 8.8.8.8.

As IP add can not be given to Gi1, I have created VLAN10 and assigned VLAN10 to Gi1.

Now how to I get access to internet if I connect a PC to the same port?

 

interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1

ip route 0.0.0.0 0.0.0.0 Cellular0
dialer-list 1 protocol ip permit
line 0

 

interface Vlan10
description Connection to PC
ip address 192.168.10.254 255.255.255.0
ip nat outside
ip virtual-reassembly in

interface GigabitEthernet1
switchport access vlan 10
no ip address

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Expert

Hello,

 

not wanting to be redundant to Mark's post, but here is what the config should look like:

 

interface Cellular0
ip address negotiated
ip nat outside
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
!
interface Vlan10
description Connection to PC
ip address 192.168.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly in

!

interface GigabitEthernet1
switchport access vlan 10
spanning-tree portfast
!
ip route 0.0.0.0 0.0.0.0 Cellular0
dialer-list 1 protocol ip permit
!
ip nat inside source list 1 interface Cellular0 overload
!
access-list 1 permit 192.168.10.0

View solution in original post

5 REPLIES 5
Highlighted
VIP Mentor

Hi
wheres the rest of the NAT , ip nat inside should `be on vlan interface where pcs are v10, and ip nat outside on external interface if its the cellular , then an ip nat statemnet with acl

see this example in this link below, it would be the same setup as your breaking out to the internet from that router , just change the interface to the outside interface in the nat statement ...... ip nat inside source list 100 interface serial 0/0 overload

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/260-cisco-router-nat-overload.html
Highlighted
VIP Expert

Hello,

 

not wanting to be redundant to Mark's post, but here is what the config should look like:

 

interface Cellular0
ip address negotiated
ip nat outside
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
!
interface Vlan10
description Connection to PC
ip address 192.168.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly in

!

interface GigabitEthernet1
switchport access vlan 10
spanning-tree portfast
!
ip route 0.0.0.0 0.0.0.0 Cellular0
dialer-list 1 protocol ip permit
!
ip nat inside source list 1 interface Cellular0 overload
!
access-list 1 permit 192.168.10.0

View solution in original post

Highlighted

Hi @Georg Pauwen 

Your previous reply helped me to solve the issue and it worked.

Today again I am using the same updated config, but having same issue again.

I couldn't understand why its not working. I am able to ping 8.8.8.8 but couldn't access internet via PC.

Hope you would be able to help.

Thanks

Bas

config below:

 

!Router Config
!Cellular Connection
conf t
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0

interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
ip nat outside

ip route 0.0.0.0 0.0.0.0 Cellular0
dialer-list 1 protocol ip permit
line 0

ip nat inside source list 1 interface Cellular0 overload
access-list 1 permit 192.168.10.0 0.0.0.255

!VLAN connection

conf t
vlan 10
name data10
exit

interface GigabitEthernet1
switchport
switchport mode access
switchport access vlan 10
desc To Switch Fa0/1

ip routing
int vlan 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
no shut

Highlighted

Hello,

 

the configuration looks good as far as I can see. Where do your PCs get their IP address from ?

 

Actually, post the full running config (sh run)...

Highlighted

Hi,
Its working again as on PC I put IP, DGW and DNS values.
Previously DNS 8.8.8.8 was missing.
Content for Community-Ad