cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6149
Views
10
Helpful
8
Replies

IR829GW - Problems to conf. the cellular interface

julioegb
Level 1
Level 1

Hello everyone. My company has just bought a IR829GW, the idea is install this equipment in a vehicle to give WiFi connection.

 

It's my first time configuring a cellular interface, I want to use a SIM from Claro Guatemala, this ISP doen't need authentication, I had already configured the profile and I think it's ok:

 

IR800#show cell 0 profile

Profile 1 = INACTIVE **
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

Profile 15 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = internet.ideasclaro
Authentication = None

Profile 16 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

* - Default profile
** - LTE attach profile

 

I configured the int cell 0 with this commands:

 

interface Cellular0
 ip address negotiated
 encapsulation slip
 dialer in-band
 dialer-group 1
end

 

And the controller:

 

controller Cellular 0
lte sim data-profile 15 attach-profile 1 slot 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6

 

The problem is that I can't obtain an IP addres from the ISP in the interface cellular, please I need help:

 

IR800#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0           unassigned      YES NVRAM  administratively down down
GigabitEthernet1           unassigned      YES unset  down                  down
GigabitEthernet2           unassigned      YES unset  down                  down
GigabitEthernet3           unassigned      YES unset  down                  down
GigabitEthernet4           unassigned      YES unset  down                  down
Wlan-GigabitEthernet0      unassigned      YES unset  up                    up
Async0                     unassigned      YES unset  up                    down
Async1                     unassigned      YES unset  up                    down
GigabitEthernet5           unassigned      YES NVRAM  administratively down down
Cellular0                  unassigned      YES manual up                    up
Cellular1                  unassigned      YES NVRAM  down                  down

 

Regards,

Julio Guzmán

2 Accepted Solutions

Accepted Solutions

Ben Walters
Level 3
Level 3

For your controller you used lte sim data-profile 15 attach-profile 1 slot 0 but it should be lte sim data-profile 15 attach-profile 15 slot 0 otherwise in your current setup it will try to use profile 1 to attach to the LTE network not the profile 15 you already created.

 

You may be missing a couple things in your int Cell 0 configuration.

!

interface Cellular0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 6
dialer string lte
dialer-group 1
async mode interactive

!

View solution in original post

Hello,

 

try and add the lines in bold to your cellular interface configuration:

 

interface Cellular0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 6
dialer string lte
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic

 

That said, how are you triggering/activating the interface ? You currently have no IP addressing configured locally...

View solution in original post

8 Replies 8

Ben Walters
Level 3
Level 3

For your controller you used lte sim data-profile 15 attach-profile 1 slot 0 but it should be lte sim data-profile 15 attach-profile 15 slot 0 otherwise in your current setup it will try to use profile 1 to attach to the LTE network not the profile 15 you already created.

 

You may be missing a couple things in your int Cell 0 configuration.

!

interface Cellular0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 6
dialer string lte
dialer-group 1
async mode interactive

!

Ben Thanks for your valuable help, you're rigth with the profile and with the other commands, I had change the wrong command and included the new ones but nothing change, my int cellular 0 doesn't have IP address, the complete conf. of the IR829 is:

 

Mobile_Router#show runn
Building configuration...

 

Current configuration : 2871 bytes
!
! Last configuration change at 19:29:17 UTC Fri Dec 29 2017
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mobile_Router
!
boot-start-marker
boot system flash:ir800-universalk9-mz.SPA.156-3.M
boot-end-marker
!
no aaa new-model
ethernet lmi ce
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 9
!
no ignition enable
!
ip dhcp excluded-address 192.168.43.1 192.168.43.6
!
ip dhcp pool W_DHCP
 network 192.168.43.0 255.255.255.0
 default-router 192.168.43.1
 domain-name Allied.network
 dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
license udi pid IR829GW-LTE-NA-AK9 sn FTX2043Z010
!
redundancy
!
controller Cellular 0
 lte sim data-profile 15 attach-profile 15 slot 0
 lte modem link-recovery rssi onset-threshold -110
 lte modem link-recovery monitor-timer 20
 lte modem link-recovery wait-timer 10
 lte modem link-recovery debounce-count 6
!
interface GigabitEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1
 no ip address
!
interface GigabitEthernet2
 no ip address
!
interface GigabitEthernet3
 no ip address
!
interface GigabitEthernet4
 no ip address
!
interface Wlan-GigabitEthernet0
 no ip address
!
interface GigabitEthernet5
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Cellular0
 ip address negotiated
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer enable-timeout 6
 dialer string lte
 dialer-group 1
 async mode interactive
!
interface Cellular1
 no ip address
 encapsulation slip
!
interface wlan-ap0
 ip address 1.1.1.1 255.255.255.255
!
interface Vlan1
 no ip address
!
interface Async0
 no ip address
 encapsulation scada
!
interface Async1
 no ip address
 encapsulation scada
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
ipv6 ioam timestamp
!
access-list 1 permit any
!
control-plane
!
line con 0
 stopbits 1
line 1 2
 stopbits 1
line 3
 script dialer lte
 no exec
 transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 4
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
 no exec
 transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
 transport preferred none
 transport output none
 stopbits 1
line vty 0 4
 login
 transport input none
!
no scheduler max-task-time
!
end

 

Look this show command:

 

Mobile_Router#show cellular 0 network
Current System Time = Fri Dec 29 19:18:28 2017
Current Service Status = No service
Current Service = Unknown
Current Roaming Status = Home
Network Selection Mode = Automatic
Network =
Mobile Country Code (MCC) = 704
Mobile Network Code (MNC) = 1
Packet switch domain(PS) state = Not attached
Location Area Code (LAC) = 0
Cell ID = 0

 

This is the show for the hardware:

 

Mobile_Router#show cellular 0 hardware
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7354
Package Identifier ID: 1102037_9903214_MC7354_05.05.58.00_00_Cisco_005.009_000
International Mobile Subscriber Identity (IMSI) =
International Mobile Equipment Identity (IMEI) = 356734060308776
Integrated Circuit Card ID (ICCID) =
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Modem Status = Online
Current Modem Temperature = 35 deg C
PRI SKU ID = 9903214, PRI version = 005.026, Carrier = AT&T

 

 

This is the profile info:

 

Mobile_Router#show cell 0 profile
Profile 1 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

Profile 15 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = internet.ideasclaro
Authentication = None

Profile 16 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

  * - Default profile
 ** - LTE attach profile

The configuration of my interfaces:

 

Mobile_Router#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0           unassigned      YES NVRAM  administratively down down
GigabitEthernet1           unassigned      YES unset  up                    up
GigabitEthernet2           unassigned      YES unset  down                  down
GigabitEthernet3           unassigned      YES unset  down                  down
GigabitEthernet4           unassigned      YES unset  down                  down
Wlan-GigabitEthernet0      unassigned      YES unset  up                    up
Async0                     unassigned      YES unset  up                    down
Async1                     unassigned      YES unset  up                    down
GigabitEthernet5           unassigned      YES NVRAM  administratively down down
Cellular0                  unassigned      YES manual up                    up
Cellular1                  unassigned      YES NVRAM  down                  down

 

Again thanks for your help, It's hard to find information about this, I feel like I'm lost in the jungle.

 

Julio Guzmán

Are you able to post the output from sho cell 0 all?

 

It may give more information as to why the cellular is not connecting. Are you sure that the APN is correct for your carrier too? 

Thanks Ben, below the info of the show cell 0 all:

 

Mobile_Router#show cell 0 all
Hardware Information
====================
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7354
Package Identifier ID: 1102037_9903214_MC7354_05.05.58.00_00_Cisco_005.009_000
International Mobile Subscriber Identity (IMSI) = 704012024396712
International Mobile Equipment Identity (IMEI) = 356734060308776
Integrated Circuit Card ID (ICCID) = 8950201016696768069
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Modem Status = Online
Current Modem Temperature = 23 deg C
PRI SKU ID = 9903214, PRI version = 005.026, Carrier = AT&T

Profile Information
====================

Profile 1 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

Profile 15 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = internet.ideasclaro
Authentication = None

Profile 16 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

  * - Default profile
 ** - LTE attach profile


Configured default profile for active SIM 0 is profile 15.


Data Connection Information
===========================
Profile 1, Packet Session Status = INACTIVE
Profile 2, Packet Session Status = INACTIVE
Profile 3, Packet Session Status = INACTIVE
Profile 4, Packet Session Status = INACTIVE
Profile 5, Packet Session Status = INACTIVE
Profile 6, Packet Session Status = INACTIVE
Profile 7, Packet Session Status = INACTIVE
Profile 8, Packet Session Status = INACTIVE
Profile 9, Packet Session Status = INACTIVE
Profile 10, Packet Session Status = INACTIVE
Profile 11, Packet Session Status = INACTIVE
Profile 12, Packet Session Status = INACTIVE
Profile 13, Packet Session Status = INACTIVE
Profile 14, Packet Session Status = INACTIVE
Profile 15, Packet Session Status = INACTIVE
Profile 16, Packet Session Status = INACTIVE

Network Information
===================
Current System Time = Tue Jan 2 15:8:59 2018
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Network =
Mobile Country Code (MCC) = 704
Mobile Network Code (MNC) = 1
Packet switch domain(PS) state = Attached
Location Area Code (LAC) = 499
Cell ID = 13595054

Radio Information
=================
Radio power mode = online
Channel Number = 9716
Current Band = WCDMA 1900
Current RSSI(RSCP) = -49 dBm
Current ECIO = -5 dBm
Primary Scrambling Code = 0x122
Number of nearby cells = 2
Idx      PSC (Primary Scrambling Code)
-------------------------------------
1              101
2              253
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = UMTS ( HSDPA HSUPA UMTS/WCDMA )

Modem Security Information
==========================
Active SIM = 0
SIM switchover attempts = 0
Card Holder Verification (CHV1) = Disabled
SIM Status = General failure
SIM User Operation Required = None
Number of CHV1 Retries remaining = 0

GPS Information
==========================

GPS Info
-------------
GPS Feature: enabled
GPS Port Selected: Dedicated GPS port
GPS Status: GPS location cannot be acquired
GPS auto tracking status: unknown
GPS auto tracking config: disabled
GPS Mode Configured: not configured/unknown
Last Location Fix Error: Offline [0x0]

SMS Information
===============
Incoming Message Information
----------------------------
SMS stored in modem = 0
SMS archived since booting up = 0
Total SMS deleted since booting up = 0
Storage records allocated = 25
Storage records used = 0
Number of callbacks triggered by SMS = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0

Outgoing Message Information
----------------------------
Total SMS sent successfully = 0
Total SMS send failure = 0
Number of outgoing SMS pending = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0
Last Outgoing SMS Status = SUCCESS
Copy-to-SIM Status =     0x0
Send-to-Network Status = 0x0
Report-Outgoing-Message-Number:
  Reference Number =     0
  Result Code =          0x0
  Diag Code =            0x0 0x0 0x0 0x0 0x0

SMS Archive URL =

Error Information
=================

This command is not supported on this platform.


Modem Crashdump Information
===========================
WIC type is 00
Cellular0 is MC73xx based
Modem crashdump logging: off

Hello,

 

try and add the lines in bold to your cellular interface configuration:

 

interface Cellular0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 6
dialer string lte
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic

 

That said, how are you triggering/activating the interface ? You currently have no IP addressing configured locally...

I think I see the issue here, you may not have the correct model of 829 for your provider.

 

If you look here:

https://www.cisco.com/c/en/us/products/collateral/routers/829-industrial-router/datasheet-c78-734981.html

 

Under Table 2. 4G LTE Specifications, you will see that there are different models of 829 for service providers and regions. It looks like you have the North American AT&T(IR829GW-LTE-NA-AK9) model when you may need a LATAM model. Claro seems to use the 1800 LTE band 3 (Wikipedia) so you may need to use the IR829GW-LTE-GA-*K9 model of 829.

 

That is the only other thing that I can think of at this time. The rest of the config looks ok to the point where you should at least be connecting to a cell network and have an IP address on the router.

 

https://en.wikipedia.org/wiki/LTE_frequency_bands - second table had the Claro information. 

Thanks for your help Ben, I don't know why but I made your changes and it didn't work. I included the commands that Georg suggest me and it didn't work too.

I looked the bands of the ISP, I found my IR829 support the actual bands of CLARO Guatemala.

 

Too try another configuration, I started to configure the DHCP server of the device, I had a problem in my DHCP configuration which my int vlan address. I changed the wrong address and after that the cellular interface start to work fine.

 

I really appreciate your help and assistance Ben and Georg, It's the first time I used this forum, but I going to use it frequently.

 

Regards,

Julio Guzmán

 cellular interface.PNG

Normally with an LT router you need a Dialer Interface to get and IP address

 

interface Dialer1
ip address negotiated
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent

 

 

My 2 Cents worth!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card