cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2937
Views
0
Helpful
10
Replies

Is it possible for DHCP Clients to get IP in this scenario

netadmindha
Beginner
Beginner

    Dear Experts,

I  would like to share you my requirement as follows  -

Current setup :

Core-switch :  Lan protocol - Eigrp , Connected to Access-switches via trunk, Spanning Treee Root & VTP server.

Layer 2 vlans, DHCP Scope Layer 3 vlans configured with helper address.

Now we want to deploy Distribution switch between  Core and Access Layer as follows

I donot want to make much changes to my networks thus only bring layer 2 sepearation from Core-switch which prevents STP loops for ever

from any access-switches.

Query1 : Does my host ( PC's or wireless device ) connected to access switches to receive dynamic IP-address from DHCP scope configured on Core-switch ?

Query2 :  Incase if above question answer is  "NO"  .....If i just configure DHCP scope for each subnet and their relevant  Layer 2vlans ..

Does my Host will receive Dynamic IP-address from Distribution switch .

Query 3 :  If my hosts obtain as per query 2 ...do they able to ping the gateway and other subnets ?

Sample config  : -

Core-switch 1

interface Vlan7

description HQ_Users_VLAN2

ip address 10.1.2.2 255.255.255.0

no ip route-cache cef

standby 7 ip 10.1.2.1

standby 7 priority 110

standby 7 preempt

standby 7 name HQ_Users_VLAN2

interface Vlan242

ip address 10.1.242.2 255.255.255.0

no ip redirects

delay 100

no ipv6 mld snooping

standby 242 ip 10.1.242.1

standby 242 priority 110

standby 242 preempt

Distribution switch :

#config t

vlan 7   ( Does Dist.switch required Layer 3 vlan  for vlan 7 and vlan 242 such that host in access-switch gets ip-address and

Vlan 242            communicate to default gw and other vlans. )

ip dhcp pool DHCP2

   network 10.1.242.0 255.255.255.0

   default-router 10.1.242.1

   lease 90

ip dhcp pool DHCP1

   network 10.1.2.0 255.255.255.0

   default-router 10.1.2.1

   lease 90

Access-sw1:

Int fa 0/1

sw acc vl 7

Access-sw2:

Int fa 0/1

sw acc vl 242

Attached the network digram for reference

Request you to please provide your valuable suggesstions 

Regards,

Akber Mirza.

2 Accepted Solutions

Accepted Solutions

Joe Lentine
Beginner
Beginner

I really need a more clear explanation of your physical connectivity. Please copy in the whole configs from the switches and label what is connected to what. Also please submit a show ip route and show ip route eigrp

Sent from Cisco Technical Support iPhone App

View solution in original post

Hi,

If you want to put Distribution switch between access switch and core, and act like L2 device then you do not need to configure DHCP helper address and SVIs on it. Just connect it to access and core via trunk. In this way core will be default gateway and HSRP failover with SVIs and DHCP pools.

But if you want L3 separation between distribution and core then you need to configure SVIs on it and it will be default gateway for hosts. DHCP pools you can configure either on core or distribution.

First it will be better if you tell what exactly you want to achieve. I would select second option with HSRP failover if you have at least two distribution switch.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

View solution in original post

10 Replies 10

netadmindha
Beginner
Beginner

Dear Experts,

Please give your valuable inputs  at the earliest.

Appreciate your quick response.

Joe Lentine
Beginner
Beginner

Ok first off I'm not sure if you are looking to route from your distribution layer as typical hierarchal designs suggest. That's what i would recommend.

-So your distribution switch would be the gateways for you vlans . Configure dhcp scopes on distribution switch without helper addresses. You do not need them on a layer 3 switch if it is directly handing addresses. Then setup eigrp and configure your networks in it. Then set it up on your core also. Make sure you either propagate a default route into the eigrp domain, or configure it statically.

I hope this helps. Feel free to ask more questions

Sent from Cisco Technical Support iPhone App

Abzal
Rising star
Rising star

Hi,

1. Yes, it's possible. However to make it work you need to configure DHCP relay on distr. switch.

Suppose g1/0/1 is interface connected to core and it's IP 10.100.0.1. And vlan 10  is Data VLAN, vlan 30 Voice VLAN

int vlan 10

ip helper-address 10.100.0.1

int vlan 30

ip helper-address 10.100.0.1

2. No distr. switch does require it. Just make sure that your SVIs for Data and Voice are on the same subnet as on DHCP scope configuration.

http://www.cisco.com/en/US/docs/ios/12_4t/ip_addr/configuration/guide/htdhcpre.html

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

Hello,

Currently i have my DHCP Scope configured on my Core-switch  and access-switch directly connected to it by Trunk.

Now i am planning to bring Distribution switch between Core and access layer.

Current Core-switch :  Lan protocol - Eigrp , Connected to Access-switches via trunk, Spanning Treee Root & VTP server.Layer 2 vlans, DHCP Scope Layer 3 vlans configured with helper address.

Distribution switch ROLE will be : -

Spanning Treee Root & VTP server.Layer 2 vlans,

Distribution switch will be connected with L3 connectvity    (ex10.1.130.1  ---- 10.1.130.2) to Core-swtitch .

My Question can we send DHCP host UDP broadcast  over a layer 3 connectivity from DIStribution to core-sw?

as per your above suggesstion

You want me to configute as below  ?

Core-switch   will remain the Layer 3 subnet  and DHCP scope for VLAN 7 ( example)

Disctribution -sw:

Int vlan 7

ip helper-address 10.1.130.2 255.255.255.0

( does this vlan 7 not required an ip address again from same

Commands ++++++++++++++++++++++++++++++++++++

Core-switch 1

interface Vlan7

description HQ_Users_VLAN2

ip address 10.1.2.2 255.255.255.0

no ip route-cache cef

standby 7 ip 10.1.2.1

standby 7 priority 110

standby 7 preempt

standby 7 name HQ_Users_VLAN2

end

ip dhcp pool DHCP1

   network 10.1.2.0 255.255.255.0

   default-router 10.1.2.1

   lease 90

Distribution switch :

#config t

vlan 7  

Int vlan 7

no shut

ip helper-address 10.1.130.2

Access-sw1:

Int fa 0/1

sw acc vl 7

Regards,

Akber Mirza.

Hi,

I don't understand your above configuration, but let me try explain.

You have two options here:

1. Make L3 core switch default gateway for hosts with HSRP. Distribution and access will be L2 and connected via trunk.

Then you could configure DHCP on the core. No additional configuration needed.

2. L3 core switch and L3 distribution switch. Connected via L3 link. You could configure DHCP on  either Core or distribution switch. But on distribution you will need ip helper-address pointing to Core. Because as you know DHCP request is broadcast packet. And distribtuion switch will be default gateway for hosts. Access switch will be connected via trunk to distribution.

I prefer 2nd option because you reduce STP tree. Also if you run dynamic routing protocol it will give redundant paths and fast convergence.

Access:

int f0/1

switchport mode access

switchport access vlan 7

Distribution:

int vlan 7

ip add 10.0.0.1 255.255.255.0

ip helper-address 10.1.1.1

int g1/0/1

no switchport

ip add 10.1.1.2 255.255.255.252

Core:

int g1/0/1

no switchport

ip add 10.1.1.1 255.255.255.252

ip dhcp pool DHCP

   network 10.0.0.0 255.255.255.0

   default-router 10.0.0.1

   lease 90

You can configure DHCP on either core or distribtuion. If on core you will need ip helper address pointing to core.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

Hi,

I tried your recommendation and achieved some part of my requirement.

My current setup:

Core-switch :

interface Vlan7

description HQ_Users_VLAN2

ip address 10.1.2.2 255.255.255.0

no ip route-cache cef

standby 7 ip 10.1.2.1

standby 7 priority 110

standby 7 preempt

standby 7 name HQ_Users_VLAN2

end

ip dhcp pool DHCP1

   network 10.1.2.0 255.255.255.0

   default-router 10.1.2.1

   lease 90

router eigrp 1

no auto-summary

network 10.0.0.0

New Deployement  ( Distributionswitch) :-

Int vlan 7

ip add 10.1.2.5 255.255.255.0

no shut

ip helper-address 10.1.131.1  ( this core-swi ip which is conecting to Distr-swi L3 interface 10.1.131.2)

router eigrp 1

no auto-summary

network 10.0.0.0

Access:

int f0/1

switchport mode access

switchport access vlan 7

with this setup i am able to get DHCP IP on hosts connected to access-sw and able to ping till 10.1.2.5.

Problem : host from access-sw not able to ping 10.1.2.1 ( core-sw ip) and from distr-switch also i am not able to ping 10.1.2.1 .

Also i see that my distr-sw 4900 has limitation with Eigrp as it allows Eigrp stub and hence can  i just use the following command on dist-sw.

ip route 0.0.0.0 0.0.0.0 10.1.131.1 ( core-sw int ip connected to dist-sw interface 10.1.131.2)

Please help with your valuable inputs !

Thanks and Regards,

Akber Mirza.

Hi,

If you want to put Distribution switch between access switch and core, and act like L2 device then you do not need to configure DHCP helper address and SVIs on it. Just connect it to access and core via trunk. In this way core will be default gateway and HSRP failover with SVIs and DHCP pools.

But if you want L3 separation between distribution and core then you need to configure SVIs on it and it will be default gateway for hosts. DHCP pools you can configure either on core or distribution.

First it will be better if you tell what exactly you want to achieve. I would select second option with HSRP failover if you have at least two distribution switch.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

Joe Lentine
Beginner
Beginner

Did your eigrp neighbors establish?
Do a show ip eigrp neighbors to check. If they did then you should have a route to your core. Make sure your switch has the gateway to 10.2.2.5 (distribution) and make sure you can ping your core from your distribution switch. Also make sure you redistribute a default route to your distribution layer to your ISP , without broadcasting your ISP route.

Sent from Cisco Technical Support iPhone App

Hi,

Yes , Eigrp adjacnecy forming between Dist and Core switches.However host at access-sw  not able to ping  core switch ip-addres

Can you please above commment in detail ...and let me know whether the scenario will work or not?

Appreciate your posts

Regards,

Akber Mirza.

Joe Lentine
Beginner
Beginner

I really need a more clear explanation of your physical connectivity. Please copy in the whole configs from the switches and label what is connected to what. Also please submit a show ip route and show ip route eigrp

Sent from Cisco Technical Support iPhone App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers