Showing results for 
Search instead for 
Did you mean: 

ISP Modem to 1721, private subnet allocation?


I've been struggling with this for more than a month now and cannot find the solution. Any help would be much appreciated.

The following setup works perfectly and with these specs±


IP 80.57.X.167/24

DG 80.57.X.1

DNS 213.46.X.196 & 62.179.X.196

DHCP 10.15.X.1

However, when I try this setup, I get the following:

ISP_MODEM => 1721 => LAN

With the 1721 configured as follows:

interface FastEthernet0[
ip address dhcp
ip dhcp relay information trusted
speed auto


no ip bootp server
no ip dhcp-client broadcast-flag


FastEthernet0              10.15.X.22    YES DHCP   up                    up
ip name-server 212.142.X.13

Here, the IP of the ext. interface is assigned an IP in the same subnet as the actual ISP DHCP-server. The name server is completely different from what they are supposed to supply (checked with others with the same ISP just to be sure). Any domain lookup, regardless of actual domain name, allways gives the same result.

I even tried it with a netgear AP (allthough it was ment for my internal WLAN only), but the AP is not able to get any outside connectivity when configured for this purpose (but no CLI so no troubleshooting).

The modem of the ISP is not configurable.

I tried contacting the ISP, but offcourse the helpdesk guys simply state that if I have an outside connection through my PC their service is excellent.

My best guess is that somehow they see my router as something from their internal network and give me alot of privileges I shouldnt get and dont want! But I cant put my finger around why, and how to solve this. I tried having the router spoof my PC's MAC, but to no avail.

Am I doing something terribly wrong here?

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards