cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

3980
Views
0
Helpful
6
Replies
Highlighted

Issue with switch port voice vlan config

Dear All,

I have configured one switch port on WS-C3548-XL for data and voice vlan but voice vlan is not coming up and ipphone connected is not getting ip.

below is the config,

interface  fastethernet 0/5

swicth mode access

switchport acces vlan 88

switchport voice vlan 140

spanning-tree portfast

the vlan is present in the switch and voice vlan is working perfectly in other switches, appreciate any help to resolve the issue.

Thanks in Advance,

Shanil

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Expert

Issue with switch port voice vlan config

Hi

Can you try below config and test again?

interface  fastethernet 0/5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport acces vlan 88

switchport voice vlan 140

spanning-tree portfast

HTH

View solution in original post

Rising star

Re: Issue with switch port voice vlan config

Hi

Can you try below config

interface fastethernet 0/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport acces vlan 88
switchport voice vlan 140
switcport trunk native vlan 88
spanning-tree portfast


HTH

Sent from Cisco Technical Support iPhone App

View solution in original post

6 REPLIES 6

Issue with switch port voice vlan config

Hi,

If this vlan is working and  not working only on this switch alone then you can check the following thigs.

1.check the free ip's space in the DHCP for this subnet.

2. check the trunk config and allowed vlan.

3. Also show spanning tree for this vlan.

sh run interface trunk

show interface trunk

show vlan

show spanning tree vlan fa0/5

thanks

V.S.Suresh .

VIP Expert

Issue with switch port voice vlan config

Hi

Can you try below config and test again?

interface  fastethernet 0/5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport acces vlan 88

switchport voice vlan 140

spanning-tree portfast

HTH

View solution in original post

Beginner

Re:Issue with switch port voice vlan config

Question: is the ip phone a cisco ip phone? If it isn't then set the port to a trunk port.


Sent from Cisco Technical Support Android App

Joel _______________________________ Please rate helpful posts and answered questions!
Contributor

Issue with switch port voice vlan config

I would also verify what the OP didnt say, is the phone getting power?  Layer 1, layer 2, layer 3.....

Rising star

Re: Issue with switch port voice vlan config

Hi

Can you try below config

interface fastethernet 0/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport acces vlan 88
switchport voice vlan 140
switcport trunk native vlan 88
spanning-tree portfast


HTH

Sent from Cisco Technical Support iPhone App

View solution in original post

Issue with switch port voice vlan config

Thank you all..

Thank you reza ..the below config solved the issue..

interface fastethernet 0/5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport acces vlan 88

switchport voice vlan 140

spanning-tree portfast


Reagrds

Shanil

CreatePlease to create content
Content for Community-Ad