cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

347
Views
5
Helpful
13
Replies
Beginner

Issues connecting two Nexus 5k to 6509s running in VSS mode.

I need assistance. 

I am trying ti implement two Nexus 5k into my network. I'm connecting them to a pair of 6509s running in VSS mode. Whenever I turn on the portchannel the ports go into error disabled mode. 

Here are the configs for the connections:

On 6509:

interface Port-channel500
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 55
switchport mode trunk

interface TenGigabitEthernet1/4/6
description uplink to N5K-Sw2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 55
switchport mode trunk
channel-group 500 mode on

interface TenGigabitEthernet2/4/6
description link to N5K-Sw1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 55
switchport mode trunk
channel-group 500 mode on

on N5K-1:

interface port-channel1
switchport mode trunk
switchport trunk allowed vlan 55
spanning-tree port type network
speed 10000

interface Ethernet1/37
switchport mode trunk
switchport trunk allowed vlan 55
channel-group 1

on N5K-2:

interface port-channel1
switchport mode trunk
switchport trunk allowed vlan 55
spanning-tree port type network
speed 10000

interface Ethernet1/37
switchport mode trunk
switchport trunk allowed vlan 55
channel-group 1

 

Between the two 5Ks there is a VPC peer-link:

interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 55
spanning-tree port type network
speed 10000
vpc peer-link

interface Ethernet1/40
description up link to N5k-Sw1
switchport mode trunk
switchport trunk allowed vlan 55
channel-group 10

 

 

 

 

Everyone's tags (1)
13 REPLIES 13
VIP Collaborator

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

From 6509
what is indicate from terminal monitor when you plug the LAG.

please share,
show interfaces tatus
show interface errdisable
Jaderson Pessoa
*** Rate All Helpful Responses ***
Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

Jaderson,

I attached the file. When I ran the err-disabled command nothing showed up.

VIP Collaborator

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

well, right now there is no port connected on interface TenGigabitEthernet1/4/6

Te1/4/6 uplink to N5K-Sw2 notconnect 1 full 10G 10Gbase-SR
Te2/4/6 link to N5K-Sw1 connected trunk full 10G 10Gbase-SR
Jaderson Pessoa
*** Rate All Helpful Responses ***
Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

I shut the port down temporarily

Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

Use "spanning-tree port type normal" to disable Bridge Assurance on Nexus side or "spanning-tree portfast network" to enable it on Catalyst side.

Highlighted
VIP Advisor

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

Try 6500 side example :

 

interface TenGigabitEthernet1/4/6
description uplink to N5K-Sw2
switchport
switchport mode trunk

switchport trunk allowed vlan 55

channel-group 500 mode active

 

N5K side :

 

interface Ethernet1/37
switchport mode trunk
switchport trunk allowed vlan 55
channel-group 1 mode active

 

make sure VLAN 55 added on both the side.

 

once you changed the config in shutdown mode, bring up the port-channel

 

and post the logs - what is the reason of err-disabled

show spanning-tree vlan 55  ( 6500 and Nexus 5K)

show vpc from both 5K

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

BB,

Thanks for the suggestion. I changed the channel-group to mode active on both the 5K and 6509s. On the 6509 po500 port t1/4/6 is still down, though not err-disabled.  I attached a file with new config and the logs

VIP Advisor

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

I would like to config couple of testing before we proceed further.

 

1. What happend if you shutdown 2/4/6, will 1/4/6 come up ? YES or NO ?

2. Do you see any Logs on nexus, try command show logging last 20 both the side post the logs here

3. Hope you have VSS 6509 - they are terminating to 2 5K(they are vPC)

 

so you need to change the config both the 5K.

 

interface port-channel1
switchport mode trunk
switchport trunk allowed vlan 55
spanning-tree port type normal
speed 10000

vpc 10

BB
*** Rate All Helpful Responses ***
Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

BB

What happend if you shutdown 2/4/6, will 1/4/6 come up ? YES or NO ?  NO

See attached for the logs. On N5K-2 i had to go back 100 entries

The 6509s are in VSS mode. Do I still need to add vpc? 

VIP Advisor

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

What happend if you shutdown 2/4/6, will 1/4/6 come up ? YES or NO ?  NO

 

BB - in this case you need to investigate physical connection, this not related to config.

this is basic requirement, before you put them in port-channel

 

BB - on Nexus side you need to add vPC config as suggested, ( once your physical or other problem fixed)

 

are you running any HSRP  ? i see some logs in your last message ?

 

N5K-Sw2 %ARP-3-DUP_SRC_IP_PROBE: arp [3458] Duplicate add
ress Detected. Probe packet received from 0c27.24cf.1138 on Vlan55(port-channel
10) with destination set to our local ip, 172.16.55.11

BB
*** Rate All Helpful Responses ***
Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

That worked. The hardware failure was the 10g gbic in the 6509. I swapped it out and added the vpc to the 5k links and it worked. Thank you for the help.

Beginner

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

That worked. The hardware failure was the 10g gbic in the 6509. I swapped it out and added the vpc to the 5k links and it worked. Thank you for the help. 

VIP Advisor

Re: Issues connecting two Nexus 5k to 6509s running in VSS mode.

Glad all working as expected, of the solution worked, can we mark as resolved- so other community members can use same solution.

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad