cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
835
Views
0
Helpful
12
Replies
pmarques
Beginner

iTunes Sharing and Multicast on CAT3560

Hi,

I'm having trouble in making this work across VLANs.

I've already enabled ip multicast-routing on the switch. In the SVIs I have the ip pim sparse-dense-mode command.

Everything works fine if I'm on the same VLAN.

Between VLANs it doesn't work.

what am i missing here?

cheers,

pedro

12 REPLIES 12
Harold Ritter
Cisco Employee

Pedro,

The TTL is most probably set to 1 on the multicast packet.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi hritter,

The final scenario will have several switches but for the purpose of this test I'm only using one switch.

Do I still have to worry about TTL even though this is all happening in one switch?

Pedro,

If the switch is configured as a L3 device, which seems to be the case, then the answer is yes, you do need to worry about the TTL of 1.

If the switch was configured as a L2 device only then you wouldn't need to worry about the TTL.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
dominic.caron
Contributor

The application is trying to initiate a sparse-mode session. You've got two choice, ether configure your pim to use dense mode or configure you a rendez-vous(RP) point for your pim session

I would do the second.

Pedro is correct with the TTL issue, it a very common issue... but i ve never seen that with Itune...

Hi Dominic,

I did some more testing, checked the TTL on the multicast packet (it was set to 255) and somehow I'm getting the impression that iTunes will only work in a pure L2 environment.

I say this because I used another multicast application (VLC) and with the same configurations everything worked fine.

So for me, as of now, iTunes doesn't work across VLANs.

cheers,

pedro

Hi Dominic,

Thanks for your reply.

I understand the need for a RP in a multiple switch / router environment.

In the context of my tests which include only one switch (which, by default has autoRP enabled) I don't quite see the need for an explicit RP configuration.

Additionally, with the command "sh ip igmp groups" i see the group associated with MDNS (239.255.255.250) used by iTunes.

Somehow I would still think I would be able to see the group 224.0.0.251 which seems to be where the actual sharing is occurring.

I will later get back to the lab and do further testing.

cheers

your switch is routing between vlans, thus the need for at least somthing like a autorp setup and pim enabled on the interfaces involved. Also have you enabled multicasting routing? If you want SAP make sure that you have ip sap listen on the SVI you have the announcement sourced.

hello nathan,

thanks for your input but if you see my first post (the one that originated this conversation) you'll see that multicast-routing is enabled on the switch and ip pim is enabled on the SVIs.

And no, I'm not using SAP.

cheers,

pedro

has anyone find a solution to this? this is currently my problem as well. i can't get bonjour to work across multiple vlans.

Jesus,

Can you tell us more about the issue. What is the multicast group used by the application? Is the application using a TTL greater than 1? What is the configuration on the L3 device?

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Shaun Bender
Enthusiast

Hi,

Do something similar but not with iTunes directly. Using AirPlay on Apple iOS and Apple TV devices.

I've setup:

ip multicast-routing distributed

on a 3560 running IP Services and on the two vlans:

ip pim sparse-dense-mode

I'm able to see the Apple TV devices while on the same subnet, but once I switch to the other subnet, the device are no longer visible.

Any suggestions?

Thanks