cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
310
Views
0
Helpful
5
Replies
Beginner

Joining a new 2960X switch to 2960S stack

Hi

As the subject indicates, I am trying to add a new 2960X switch to an existing 2960S stack. 

There are two switches in the existing stack, running in a non-redundant mode.

I have upgraded the software of the 2960S to 15.0(2a)SE9, as this matches the major version of available software for the 2960X, 15.0(2a)EX5.  I know that 15.2 is available for the 2960X, but I understood that the switches needed to be at the same major version.

I set the priority of the existing switches to be high - the master at 14, and the other existing member at 13.

I have added the FlexStack module to the 2960X, connected the stacking cables together, and powered on the new switch, and after a considerable amount of time (~30+ minutes), the 2960X does not show as a member of the CLI.

Reading http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/stack_manager/configuration_guide/b_stck_152ex_2960-x_cg/b_stck_152ex_2960-x_cg_chapter_010.html#task_E4FC5C32789B42B19C79AB60E126BEC9, I do:

  • Disconnect the stacking cable
  • a factory reset of the 2960X,
  • set it's stack speed to 10GBPS,
  • save it's running config to startup config,
  • power the switch off,
  • connect the stacking cables
  • power the switch on

Again, after considerable time, the 2960X does not show in the CLI (using show switch).

If I use the LEDs as indicators, the new 2960X thinks that it's the master of the stack.  It's not :P

Any help or direction is greatly appreciated.

5 REPLIES
Hall of Fame Guru

I have upgraded the software

I have upgraded the software of the 2960S to 15.0(2a)SE9, as this matches the major version of available software for the 2960X, 15.0(2a)EX5. 

Everything you've describe supports my guess the 2960X will never join the 2960S stack due to software incompatibility. 

2960X will NOT/NEVER support 2960S IOS version 15.0(2a)SE9.

The only IOS which "intersects" 2960X support with 2960S is 15.2(2)E train.  So both the 2960S stack and the new 2960X will need to be upgraded to 15.2(2) train.

Beginner

Ah, ok.  I didn't realise

Ah, ok.  I didn't realise there was a 15.2 version for the 2960S - the "recommended" download was 15.0.

I will try upgrading the switches to 15.2(2a)E1 - I see the same version available for both switches.

Thanks,

Highlighted
Enthusiast

Hi,

Hi,

I have customers who run mixed stacks (2960S & 2960X) with 15.0(2)EX5 release without any problem for quite some time.

Best regards,

Antonin

Beginner

Hi Leo,

Hi Leo,

A few months has passed, can you recommend a new version of the IOS for a mixed stack.

I'm using right now for a mixed stack of 2960s and 2960x the 15.2(2)E4 but I'm seeing this errors on the logs:

Execution of Set trust type from Trust Boundary command failed

If you know of a better version to use on this kind of environment please let us know.

Thanks.

Hall of Fame Guru

Try 15.2(2)E5.

Try 15.2(2)E5.

CreatePlease to create content
Ask the Expert- MPLS troubleshooting