cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1096
Views
0
Helpful
6
Replies

KNX IP routers not communicating between several vlans

RonKoperdraad
Level 1
Level 1

I try to get KNX IP routers to communicate over a layer3 network, divided in several vlans..
The gateway of all vlans is present on a Cisco Nexus 7000 switch. When communication needs to take place, this will always be routed via this Cisco Nexus 7000 switch.
Multicast is enabled on the Cisco Nexus 7000 switch for the vlans.
Only “IP pim” in sparse mode is supported on the Cisco Nexus 7000 switch.
Furthermore, a loopback interface has been created which is configured as a static rendezvous point.
When requesting the IGMP groups, I see that the KNX Routers register at group address 224.0.23.12 (see output below).
IGMP Connected Group Membership for VRF "Facilitair" - 7 total entries
Type: S - Static, D - Dynamic, L - Local, T - SSM Translated, H - Host Proxy
Group Address Type Interface Uptime Expires Last Reporter
224.0.5.128 D Vlan1596 1w5d 00:02:45 10.141.56.14
224.0.23.12 D Vlan1589 1d13h 00:03:31 10.141.48.27
224.0.23.12 D Vlan1568 1d13h 00:03:10 10.141.27.29
224.0.23.12 L loopback105 1d13h never 10.255.255.105

There is NO firewall present between the vlans.
We use the Weinzierl KNX IP Router 752 Secure to connect to the IP network.
Anyone an idea how to get this working?

6 Replies 6

M02@rt37
VIP
VIP

Hello @RonKoperdraad 

Do you have configured IGMP querier? The Cisco Nexus 7000 switch needs to act as an IGMP querier to send IGMP queries to the connected multicast hosts (KNX IP routers). You can enable the IGMP querier on the switch using the "ip igmp snooping querier" command.

Also, you may need to ensure that the KNX IP routers are also configured to send and receive multicast traffic over the VLANs. This may involve configuring the KNX IP routers to join the correct multicast groups and/or configuring VLAN routing on the KNX IP routers.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

The command "ip igmp snooping querier" is not available on our Nexus switch running System version: 8.2(5)

 

The Nexus 7000 is a cluster of two switches with a vpc config and hsrp configured on the vlan's

The output for the "show ip igmp snooping vlan 1596"


Global IGMP Snooping Information:
IGMP Snooping enabled
Optimised Multicast Flood (OMF) enabled
IGMPv1/v2 Report Suppression enabled
IGMPv3 Report Suppression disabled
Link Local Groups Suppression enabled

IGMP Snooping information for vlan 1596
IGMP snooping enabled
Lookup mode: IP
Optimised Multicast Flood (OMF) enabled
IGMP querier present, address: 10.141.56.2, version: 2, i/f Vlan1596
Querier interval: 125 secs
Querier last member query interval: 1 secs
Querier robustness: 2
Switch-querier disabled
IGMPv3 Explicit tracking enabled
IGMPv2 Fast leave disabled
IGMPv1/v2 Report suppression enabled
IGMPv3 Report suppression disabled
Link Local Groups suppression enabled
Router port detection using PIM Hellos, IGMP Queries
Number of router-ports: 2
Number of groups: 1
VLAN vPC function enabled
Active ports:
Po1 Po156
Report Flooding: Disabled
Interfaces for Report Flooding: n/a
Use Group Address for Proxy Leaves: no

mlund
Level 7
Level 7

It looks like igmp is working. You stated that multcast is enabled, but is it enabled for vrf Facilitair? Is anyone sending on that group, can you verify with sh ip mroute vrf Facilitair? Is the sending device using a ttl of at least 2?

The output of the "sh ip mroute vrf Faciliitair" is

IP Multicast Routing Table for VRF "Facilitair"

(*, 224.0.5.128/32), uptime: 4w0d, igmp ip pim
Incoming interface: loopback105, RPF nbr: 10.255.255.105
Outgoing interface list: (count: 1)
Vlan1596, uptime: 4w0d, igmp


(*, 224.0.23.12/32), uptime: 2w3d, igmp ip pim
Incoming interface: loopback105, RPF nbr: 10.255.255.105
Outgoing interface list: (count: 4)
Vlan1588, uptime: 17:45:21, igmp
loopback105, uptime: 2w3d, igmp, (RPF)
Vlan1568, uptime: 2w3d, igmp
Vlan1589, uptime: 2w3d, igmp


(10.141.2.249/32, 224.0.23.12/32), uptime: 4w0d, ip mrib pim
Incoming interface: Vlan1543, RPF nbr: 10.141.2.249, internal
Outgoing interface list: (count: 4)
Vlan1588, uptime: 17:45:21, mrib
loopback105, uptime: 2w3d, mrib
Vlan1568, uptime: 2w3d, mrib
Vlan1589, uptime: 2w3d, mrib


(10.141.47.250/32, 224.0.23.12/32), uptime: 18:28:44, ip mrib pim
Incoming interface: Vlan1588, RPF nbr: 10.141.47.250, internal
Outgoing interface list: (count: 4)
Vlan1588, uptime: 17:45:21, mrib, (RPF)
loopback105, uptime: 18:28:44, mrib
Vlan1568, uptime: 18:28:44, mrib
Vlan1589, uptime: 18:28:44, mrib


(*, 232.0.0.0/8), uptime: 2w3d, pim ip
Incoming interface: Null, RPF nbr: 0.0.0.0
Outgoing interface list: (count: 0)


(*, 239.255.255.250/32), uptime: 4w0d, igmp ip pim
Incoming interface: loopback105, RPF nbr: 10.255.255.105
Outgoing interface list: (count: 3)
Vlan1546, uptime: 1w0d, igmp
Vlan1560, uptime: 4w0d, igmp
Vlan1550, uptime: 4w0d, igmp

in the mean time we got a little further with a solution:

We have on our access switches standard interface configs to support access and voice. I see that the KNX IP Router use the voice vlan for multicast and NOT the access vlan.

on the switchports where the KNX IP routers are connected I removed the voice vlan and it started to work.

We have several multicast environments in our network but this is the first one that uses the voice vlan for multicast. 

Review Cisco Networking products for a $25 gift card