cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1521
Views
0
Helpful
4
Replies
Highlighted
Beginner

LACP interface falling out of port-channel / mac flap

Hi,

We have a 3750x (running 15.0(2)SE10a ), and for some reason there is an interface falling out of a port channel by the looks of it as we are getting a mac flap on one of the interfaces in the port channel and the Po interface itself.

We have both ends set to active/ active, at the moment both Ten interfaces and bundled and seem to be working fine, however occasionally  we get  a mac flap, any ideas? 

4 REPLIES 4
Highlighted
Frequent Contributor

What is the output from the following -

sh etherchannel summary

Can we see a show run of each of the Interfaces in the port channel on the 3750 and also a show run of the port channel itself.

What is on the other end of the port channel? Can we see the same info from the opposite end?

Highlighted

Sounds like one of the sides is not set up correctly and the ports on the 3750x are running in stand-alone mode (I). 

Highlighted
Contributor

You mentioned you are using LACP and not using static ether channel then most likely LACP will suspend all member ports if there is any misconfiguration as it has built in loop prevention mechanism and ether channel won't come up until you fix the issue.

You didn't mention if you have ether channel configured between switches or a downstream server, if ether channel is configured between a switch and server that is hosting virtual machines then there is a possibility that you see a mac flapping between member ports because of active active configuration on the server side.  

  

Highlighted
Beginner

Morning,

As we have removed one of the interfaces the show etherchannel summary wont be of any benefit,

However below is the config of the port-channels, both ends (router to switch)

One side: (core)

description Core: 3750x-dc2

switchport

switchport trunk allowed vlan 122,166,176,177,192,200,207,216,257-262,265,267

switchport trunk allowed vlan add 268,270-272,282,283,297,298,302,500,501,503

switchport trunk allowed vlan add 609,635,638,655-658,663,664,699-701,722,725

switchport trunk allowed vlan add 802,804,810,850-852,860,861,898-921,999,2004

switchport trunk allowed vlan add 2006,2008

switchport trunk pruning vlan none

switchport mode trunk

channel-group 18 mode active

 

other side:

interface TenGigabitEthernet2/1/1

description Link to WMBC-6509E

switchport trunk encapsulation dot1q

switchport mode trunk

history BPS

srr-queue bandwidth share 1 30 35 5

priority-queue out

udld port

mls qos trust cos

channel-protocol lacp

channel-group 48 mode active

Content for Community-Ad