cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
575
Views
10
Helpful
11
Replies
Highlighted
Participant

LACP issue

I've got 4 switch stacks setup in a hub and spoke. Each spoke has a LACP connection using 2 fiber connections to the hub. I seem to be having an issue where my monitoring VM can't see certain devices even though they are online and can be pinged from other devices. It only seems to be with one specific type of device (Ruckus AP). I've replaced the fiber, transceivers and even a switch and still no luck. If I unplug one of the LACP pairs it works, but once I plug it back in I loose connection.

 

Any advice? They are Cisco 3750e switches running 12.2

11 REPLIES 11
Highlighted
VIP Expert

Can you post the configuration and how the device connected each other.

 

how is your Port-channel Loadbalance config ?



BB


*** Rate All Helpful Responses ***

Highlighted

Here is the config on one of the switches.

 

interface Port-channel3
description MDF to Server Rack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
no vtp

 

I'm not sure about a load balance config or how to check that.

Highlighted

i would prefer to see both the switch full config to understand, and give us what port connection you removed to resolve the issue.



BB


*** Rate All Helpful Responses ***

Highlighted

Here is switch 1, I've turned tengigabit 1/0/1 to fix the issue

 

hostname Server_Rack
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c3750e-48pd
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
spanning-tree mode rapid-pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree vlan 2-1000 priority 36864
!
!
!
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
interface Port-channel3
description MDF to Server Rack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
no vtp
!
interface Port-channel4
description ICTVMBox04_VLAN10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,10
switchport mode trunk
no vtp
!
interface Port-channel5
description ICTVMBox04_Hyper_V
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
spanning-tree portfast trunk
!
interface Port-channel6
description Hyper-V_Team_ictvmbox01
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
spanning-tree portfast trunk
!
interface Port-channel7
description To-ICT-VMbox-01 Host Team
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface Port-channel8
description TO_NAS
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
spanning-tree portfast
!
interface Port-channel9
description ICTDC01_Host
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
!
interface Port-channel10
description ICTDC01 Hyper-V
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
!
interface Port-channel12
description ICTVMBox02 Host
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
!
interface Port-channel13
description ICTVMBox02 Hyper-V
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast
!
interface Port-channel14
description ICTVMBox04_Hyper-V
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
!
interface Port-channel15
description To_ICTVMBox03_Host
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
!
interface Port-channel16
description To_ICTVMBox03_VMs
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
!
interface Port-channel17
description VLAN10_ICTVmBox01
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
no vtp
!
interface Port-channel18
description LWNAS2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
!
interface Port-channel19
description LWNAS365
switchport access vlan 2
switchport mode access
no vtp
!
interface Port-channel20
description To_ICTBackup01
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast trunk
!
interface FastEthernet0
no ip address
no ip route-cache
no ip mroute-cache
!
interface GigabitEthernet1/0/1
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 9 mode active
!
interface GigabitEthernet1/0/2
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 9 mode active
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 10 mode active
!
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 10 mode active
!
interface GigabitEthernet1/0/5
description LACP_15
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 15 mode active
!
interface GigabitEthernet1/0/6
description LACP_15
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 15 mode active
!
interface GigabitEthernet1/0/7
description to LACP_16
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 16 mode active
!
interface GigabitEthernet1/0/8
description to LACP_16
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 16 mode active
!
interface GigabitEthernet1/0/9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/11
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet1/0/12
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
no vtp
!
interface GigabitEthernet1/0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,10
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 4 mode active
!
interface GigabitEthernet1/0/14
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,10
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 4 mode active
!
interface GigabitEthernet1/0/15
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast
channel-group 13 mode active
!
interface GigabitEthernet1/0/16
description ict2k14apps01
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast
channel-group 13 mode active
!
interface GigabitEthernet1/0/17
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 14 mode active
!
interface GigabitEthernet1/0/18
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 14 mode active
!
interface GigabitEthernet1/0/19
description to APC Power TOR
switchport access vlan 10
no vtp
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/20
description to APC Power TOR
switchport access vlan 10
no vtp
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 5 mode active
!
interface GigabitEthernet1/0/22
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 5 mode active
!
interface GigabitEthernet1/0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 6 mode active
!
interface GigabitEthernet1/0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 6 mode active
!
interface GigabitEthernet1/0/25
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 7 mode active
!
interface GigabitEthernet1/0/26
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 7 mode active
!
interface GigabitEthernet1/0/27
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 17 mode active
!
interface GigabitEthernet1/0/28
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 17 mode active
!
interface GigabitEthernet1/0/29
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 18 mode active
!
interface GigabitEthernet1/0/30
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
channel-group 18 mode active
!
interface GigabitEthernet1/0/31
description To_iDrac_ictpbxhost01
switchport access vlan 10
switchport mode access
no vtp
!
interface GigabitEthernet1/0/32
switchport access vlan 2
no vtp
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/33
description To_NAS
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 8 mode active
!
interface GigabitEthernet1/0/34
description To_NAS
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 8 mode active
!
interface GigabitEthernet1/0/35
description To_NAS
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 8 mode active
!
interface GigabitEthernet1/0/36
description To_NAS
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2
switchport mode trunk
no vtp
spanning-tree portfast trunk
channel-group 8 mode active
!
interface GigabitEthernet1/0/37
switchport access vlan 10
switchport mode access
no vtp
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/38
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/39
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/40
switchport access vlan 63
switchport mode access
no vtp
!
interface GigabitEthernet1/0/41
description To_ICTBackup01
switchport access vlan 2
switchport mode access
no vtp
channel-group 20 mode active
!
interface GigabitEthernet1/0/42
description To_ICTBackup01
switchport access vlan 2
switchport mode access
no vtp
channel-group 20 mode active
!
interface GigabitEthernet1/0/43
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/44
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/45
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 19 mode active
!
interface GigabitEthernet1/0/46
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
channel-group 19 mode active
!
interface GigabitEthernet1/0/47
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/48
switchport access vlan 2
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/49
no vtp
!
interface GigabitEthernet1/0/50
no vtp
!
interface GigabitEthernet1/0/51
no vtp
!
interface GigabitEthernet1/0/52
no vtp
!
interface TenGigabitEthernet1/0/1
description Server_Rack_To_MDF
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
shutdown
channel-group 3 mode active
!
interface TenGigabitEthernet1/0/2
description Server_Rack_To_MDF
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
channel-group 3 mode active
!
interface Vlan1
no ip address
no ip route-cache
no ip mroute-cache
!
interface Vlan10
ip address 192.168.10.236 255.255.255.0
no ip route-cache
no ip mroute-cache


Here is the other switch

 

version 12.2
!
hostname S1
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa group server radius ICTDC06
server 192.168.10.100 auth-port 1812 acct-port 1813
!
aaa authentication login default group radius local
aaa authorization exec default group radius if-authenticated
!
!
!
aaa session-id common
switch 1 provision ws-c3750e-48pd
switch 2 provision ws-c3750e-48pd
switch 3 provision ws-c3750e-48pd
system mtu routing 1500
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 70 30
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input cos-map queue 1 threshold 2 3
mls qos srr-queue input cos-map queue 1 threshold 3 6 7
mls qos srr-queue input cos-map queue 2 threshold 1 4
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree vlan 2-100 priority 4096
auto qos srnd4
!
!
!
errdisable recovery cause bpduguard
errdisable recovery interval 30
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
interface Port-channel1
description MDF to Accounting
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport mode trunk
!
interface Port-channel3
description MDF to Switch Rack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
!
interface Port-channel4
description To_BoardRoom
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2-4,10,20,33,500
switchport mode trunk
no vtp
!
interface FastEthernet0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 10
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 113
switchport mode access
!
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2,10,20
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/5
switchport access vlan 113
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 113
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/9
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/11
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/12
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/15
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/16
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/17
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/18
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/21
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/23
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/24
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/25
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/26
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/27
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/28
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/29
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/30
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/31
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/32
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/33
switchport access vlan 500
switchport mode access
switchport protected
!
interface GigabitEthernet1/0/34
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/35
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/36
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/37
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/38
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/39
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/40
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet1/0/41
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/42
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/43
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/44
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/45
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/46
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/47
switchport access vlan 500
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/48
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface TenGigabitEthernet1/0/1
description To_Accounting_Po1
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust cos
channel-group 1 mode active
!
interface TenGigabitEthernet1/0/2
description TO_SERVER_RACK
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet2/0/1
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
no vtp
spanning-tree portfast
!
interface GigabitEthernet2/0/3
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
!
interface GigabitEthernet2/0/5
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/6
switchport access vlan 10
switchport mode access
no vtp
!
interface GigabitEthernet2/0/7
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/8
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/9
switchport access vlan 33
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/10
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/11
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet2/0/12
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/13
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2,10,20,500
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet2/0/14
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2,10
switchport mode trunk
no vtp
spanning-tree portfast
!
interface GigabitEthernet2/0/15
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/16
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/17
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet2/0/18
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/19
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/20
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/21
switchport access vlan 2
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet2/0/22
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet2/0/23
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/24
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/25
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/26
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/27
switchport access vlan 20
switchport mode access
no vtp
!
interface GigabitEthernet2/0/28
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/29
description Luke_office_printer
switchport access vlan 33
switchport mode access
no vtp
!
interface GigabitEthernet2/0/30
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/31
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/32
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/33
switchport access vlan 20
switchport mode access
no vtp
!
interface GigabitEthernet2/0/34
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/35
switchport access vlan 2
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet2/0/36
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/37
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet2/0/38
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/39
switchport access vlan 33
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/40
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet2/0/41
switchport access vlan 33
switchport mode access
no vtp
!
interface GigabitEthernet2/0/42
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet2/0/43
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet2/0/44
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/45
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
no vtp
!
interface GigabitEthernet2/0/46
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet2/0/47
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
!
interface GigabitEthernet2/0/48
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/49
!
interface GigabitEthernet2/0/50
!
interface GigabitEthernet2/0/51
!
interface GigabitEthernet2/0/52
!
interface TenGigabitEthernet2/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2-4,10,20,33,500
switchport mode trunk
no vtp
channel-group 4 mode active
!
interface TenGigabitEthernet2/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,10,20,63
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet3/0/1
description To Corp_WiFi_ASA_Int
switchport trunk encapsulation dot1q
switchport trunk native vlan 3
switchport trunk allowed vlan 2,3
switchport mode trunk
!
interface GigabitEthernet3/0/2
switchport access vlan 500
switchport mode access
!
interface GigabitEthernet3/0/3
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
no vtp
!
interface GigabitEthernet3/0/4
switchport access vlan 500
switchport mode access
no vtp
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/5
description to ASA_Port 4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 33,63
switchport mode trunk
no vtp
!
interface GigabitEthernet3/0/6
switchport access vlan 20
switchport mode access
no vtp
spanning-tree portfast
!
interface GigabitEthernet3/0/7
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet3/0/8
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/9
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet3/0/10
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 2,10,500
switchport mode trunk
!
interface GigabitEthernet3/0/11
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/12
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/13
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/14
switchport access vlan 20
switchport mode access
no vtp
!
interface GigabitEthernet3/0/15
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/16
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/17
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/18
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/19
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/20
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/21
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/22
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/23
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 3,10,500
switchport mode trunk
!
interface GigabitEthernet3/0/25
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/26
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/27
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet3/0/28
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/29
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 2,3,10,500
switchport mode trunk
!
interface GigabitEthernet3/0/30
switchport access vlan 10
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/31
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/32
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/33
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
no vtp
!
interface GigabitEthernet3/0/34
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/35
switchport access vlan 500
switchport mode access
no cdp enable
no vtp
no lldp receive
!
interface GigabitEthernet3/0/36
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet3/0/37
switchport access vlan 500
switchport mode access
!
interface GigabitEthernet3/0/38
switchport access vlan 20
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no vtp
!
interface GigabitEthernet3/0/39
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/40
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/41
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet3/0/42
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/43
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet3/0/44
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/45
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet3/0/46
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet3/0/47
switchport access vlan 2
switchport mode access
no vtp
!
interface GigabitEthernet3/0/48
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet3/0/49
!
interface GigabitEthernet3/0/50
!
interface GigabitEthernet3/0/51
!
interface GigabitEthernet3/0/52
!
interface TenGigabitEthernet3/0/1
description To_Accounting_Po1
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust cos
channel-group 1 mode active
!
interface TenGigabitEthernet3/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2-4,10,20,33,500
switchport mode trunk
no vtp
channel-group 4 mode active
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan2
no ip address
no ip route-cache
!
interface Vlan3
description Corp_WiFi
no ip address
no ip route-cache
!
interface Vlan4
description HR_Dept
no ip address
!
interface Vlan10
ip address 192.168.10.237 255.255.255.0
no ip route-cache
!
interface Vlan63
no ip address
!
interface Vlan113
description ASA Failover vlan asa to asa
no ip address
!
interface Vlan500
description Guest-WiFi
no ip address

Highlighted

Hi,

 

   Activate the port, leave it for like 1 minute and post the output of, from both sides of the channel, so from both switches: (make sure to use the proper ports, not sure about the port numbers on the other side)

 

show lacp neighbor

show lacp interface port-channel 3

show lacp interface TenGigabit1/0/1

show lacp interface TenGigabit1/0/2

show eherchannel summary

show eherchannel 3 detail

show spanning-tree vlan x (x is the VLAN with the AP)

 

 

Regards,

Cristian Matei.

Highlighted

Here are the outputs of those commands on one of the switches (the spoke not the hub switch)

 

Show LACP Neighbor

Channel group 3 neighbors

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/1 SA 32768 0007.0e3b.4380 0s 0x0 0x3 0x237 0x3D
Te1/0/2 SA 32768 0007.0e3b.4380 16s 0x0 0x3 0x137 0x3D

 

Show LACP 3 internal detail

Server_Rack#show lacp 3 internal detail
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 3

Actor (internal) information:

Actor Actor Actor
Port System ID Port Number Age Flags
Te1/0/1 32768,c471.fed1.7300 0x136 16s SA

LACP Actor Actor Actor
Port Priority Oper Key Port State
32768 0x3 0x3D

Port State Flags Decode:
Activity: Timeout: Aggregation: Synchronization:
Active Long Yes Yes

Collecting: Distributing: Defaulted: Expired:
Yes Yes No No

Actor Actor Actor
Port System ID Port Number Age Flags
Te1/0/2 32768,c471.fed1.7300 0x137 4s SA

LACP Actor Actor Actor
Port Priority Oper Key Port State
32768 0x3 0x3D

Port State Flags Decode:
Activity: Timeout: Aggregation: Synchronization:
Active Long Yes Yes

Collecting: Distributing: Defaulted: Expired:
Yes Yes No No

 

 

Show LACP interface TenGigabit 1/0/1 - command not available


Show LACP interface TenGigabit 1/0/2 - command not available


Show etherchannel summary
Server_Rack#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 17
Number of aggregators: 17

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
3 Po3(SU) LACP Te1/0/1(P) Te1/0/2(P)
4 Po4(SU) LACP Gi1/0/13(P) Gi1/0/14(P)
5 Po5(SU) LACP Gi1/0/21(P) Gi1/0/22(P)
6 Po6(SU) LACP Gi1/0/23(P) Gi1/0/24(P)
7 Po7(SU) LACP Gi1/0/25(P) Gi1/0/26(P)
8 Po8(SU) LACP Gi1/0/33(P) Gi1/0/34(P) Gi1/0/35(D)
Gi1/0/36(D)
9 Po9(SU) LACP Gi1/0/1(P) Gi1/0/2(P)
10 Po10(SU) LACP Gi1/0/3(P) Gi1/0/4(P)
12 Po12(SU) LACP Gi1/0/9(P) Gi1/0/10(P)
13 Po13(SU) LACP Gi1/0/15(P) Gi1/0/16(P)
14 Po14(SU) LACP Gi1/0/17(P) Gi1/0/18(P)
15 Po15(SU) LACP Gi1/0/5(P) Gi1/0/6(P)
16 Po16(SU) LACP Gi1/0/7(P) Gi1/0/8(P)
17 Po17(SU) LACP Gi1/0/27(P) Gi1/0/28(P)
18 Po18(SU) LACP Gi1/0/29(P) Gi1/0/30(P)
19 Po19(SU) LACP Gi1/0/45(P) Gi1/0/46(P)
20 Po20(SU) LACP Gi1/0/41(P) Gi1/0/42(P)

 


Show etherchannel 3 detail
Server_Rack#show etherchannel 3 detail
Group state = L2
Ports: 2 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Te1/0/1
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 3 Mode = Active Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Te1/0/1 SA bndl 32768 0x3 0x3 0x136 0x3D

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/1 SA 32768 0007.0e3b.4380 26s 0x0 0x3 0x237 0x3D

Age of the port in the current state: 0d:00h:02m:35s

Port: Te1/0/2
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 3 Mode = Active Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Te1/0/2 SA bndl 32768 0x3 0x3 0x137 0x3D

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/2 SA 32768 0007.0e3b.4380 11s 0x0 0x3 0x137 0x3D

Age of the port in the current state: 0d:12h:10m:40s

Port-channels in the group:
---------------------------

Port-channel: Po3 (Primary Aggregator)

------------

Age of the Port-channel = 310d:13h:30m:54s
Logical slot/port = 10/3 Number of ports = 2
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Te1/0/1 Active 0
0 00 Te1/0/2 Active 0

Time since last port bundled: 0d:00h:02m:37s Te1/0/1
Time since last port Un-bundled: 0d:12h:02m:13s Te1/0/1

 

Show spanning-tree vlan 10
Server_Rack#show spanning-tree vlan 10 ?
active Report on active interfaces only
blockedports Show blocked ports
bridge Status and configuration of this bridge
detail Detailed information
inconsistentports Show inconsistent ports
interface Spanning Tree interface status and configuration
root Status and configuration of the root bridge
summary Summary of port states
| Output modifiers
<cr>

Server_Rack#show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 4106
Address 0007.0e3b.4380
Cost 1
Port 504 (Port-channel3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 36874 (priority 36864 sys-id-ext 10)
Address c471.fed1.7300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/19 Desg FWD 19 128.19 P2p Edge
Gi1/0/20 Desg FWD 19 128.20 P2p Edge
Gi1/0/31 Desg FWD 4 128.31 P2p
Gi1/0/37 Desg FWD 4 128.37 P2p Edge
Po3 Root FWD 1 128.504 P2p
Po4 Desg FWD 3 128.512 P2p
Po17 Desg FWD 3 128.616 P2p

Highlighted

Here are those commands run on the hub switch stack

 

S1#show lacp neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 1 neighbors

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/1 SA 32768 001d.70ad.c380 24s 0x0 0x1 0x31F 0x3D
Te3/0/1 SA 32768 001d.70ad.c380 26s 0x0 0x1 0x236 0x3D

Channel group 3 neighbors

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/2 SA 32768 c471.fed1.7300 14s 0x0 0x3 0x137 0x3D
Te2/0/2 SA 32768 c471.fed1.7300 16s 0x0 0x3 0x136 0x3D

Channel group 4 neighbors

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te2/0/1 SA 32768 001d.70ad.bd80 7s 0x0 0x4 0x136 0x3D
Te3/0/2 SA 32768 001d.70ad.bd80 5s 0x0 0x4 0x237 0x3D

 

 

 

 

S1#show lacp 3 internal detail ?
| Output modifiers
<cr>

S1#show lacp 3 internal detail
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 3

Actor (internal) information:

Actor Actor Actor
Port System ID Port Number Age Flags
Te1/0/2 32768,0007.0e3b.4380 0x137 18s SA

LACP Actor Actor Actor
Port Priority Oper Key Port State
32768 0x3 0x3D

Port State Flags Decode:
Activity: Timeout: Aggregation: Synchronization:
Active Long Yes Yes

Collecting: Distributing: Defaulted: Expired:
Yes Yes No No

Actor Actor Actor
Port System ID Port Number Age Flags
Te2/0/2 32768,0007.0e3b.4380 0x237 21s SA

LACP Actor Actor Actor
Port Priority Oper Key Port State
32768 0x3 0x3D

Port State Flags Decode:
Activity: Timeout: Aggregation: Synchronization:
Active Long Yes Yes

Collecting: Distributing: Defaulted: Expired:
Yes Yes No No
S1#

 

 


S1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Te1/0/1(P) Te3/0/1(P)
3 Po3(SU) LACP Te1/0/2(P) Te2/0/2(P)
4 Po4(SU) LACP Te2/0/1(P) Te3/0/2(P)

 

 

 


S1#show etherchannel 3 detail
Group state = L2
Ports: 2 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Te1/0/2
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 3 Mode = Active Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Te1/0/2 SA bndl 32768 0x3 0x3 0x137 0x3D

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te1/0/2 SA 32768 c471.fed1.7300 1s 0x0 0x3 0x137 0x3D

Age of the port in the current state: 0d:12h:14m:33s

Port: Te2/0/2
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 3 Mode = Active Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Te2/0/2 SA bndl 32768 0x3 0x3 0x237 0x3D

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Te2/0/2 SA 32768 c471.fed1.7300 4s 0x0 0x3 0x136 0x3D

Age of the port in the current state: 0d:00h:01m:27s

Port-channels in the group:
---------------------------

Port-channel: Po3 (Primary Aggregator)

------------

Age of the Port-channel = 632d:21h:36m:35s
Logical slot/port = 10/3 Number of ports = 2
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Te1/0/2 Active 0
0 00 Te2/0/2 Active 0

Time since last port bundled: 0d:00h:01m:28s Te2/0/2
Time since last port Un-bundled: 0d:00h:02m:56s Te2/0/2

 

 

 


S1#show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 4106
Address 0007.0e3b.4380
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4106 (priority 4096 sys-id-ext 10)
Address 0007.0e3b.4380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/0/24 Desg FWD 4 128.132 P2p
Gi3/0/29 Desg FWD 4 128.137 P2p
Gi3/0/45 Desg FWD 4 128.153 P2p
Po1 Desg FWD 1 128.488 P2p
Po3 Desg FWD 1 128.504 P2p
Po4 Desg FWD 1 128.512 P2p
Gi2/0/5 Desg FWD 4 128.59 P2p Edge
Gi2/0/6 Desg FWD 19 128.60 P2p
Gi2/0/14 Desg FWD 4 128.68 P2p

 

 

 

 

 

 

 

 

 

Highlighted

Hi,

    

     I see nothing suspicious. I would recommend an upgrade of IOS code on both sides. But before that, have you tried moving that etherchannel to PAgP or even on mode, to see if the same issues comes up? This way, we isolate the issue being LACP/PAgP for whatever reason.

 

Regards,

Cristian Matei.

Highlighted

So I have both ends set to LACP mode active, what other mode should I change it to?

 

If I change to PAgP will I need to modify anything on STP? I've never used PAgP so not sure if it's much different than LACP or not.

 

Thanks for the help

Highlighted

Hi,

 

   No need for any changes in STP. The difference between LACP and PAgP is not relevant for this setup. Run "channel-group x mode desirable" for PAgP on both sides, or "channel-group mode on" for ON mode on both sides, and see if it works. This process is only to exclude something faulty related to LACP for that channel. Before moving to ON or PAgP, completely remove the Port-Channel and its configuration and ideally use a different Port-Channel number (to avoid further bugs, i've seen bugs related to Port-Channel number, yes).

 

Regards,

Cristian Matei.

Highlighted

Haven't been able to take down the LACP trunk yet to test PAgP. However this issue is only occurring on one vlan, which happens to be our management vlan. 

Content for Community-Ad