cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2694
Views
0
Helpful
10
Replies

LACP to switch and router

sebastien3
Level 4
Level 4

Hello,

 

I want to set up an LACP between an ASR1000 and a 3750X.

ASR = LACP Active

3750X = LACP Passive

 

ASR1000 :

interface Port-channel1
 description *** PO1 to 3750X ***
ip address 10.0.0.1 255.255.255.252 no negotiation auto ! interface GigabitEthernet0/0/0 description *** LACP *** no ip address no negotiation auto channel-group 1 mode active ! interface GigabitEthernet0/0/1 description *** LACP *** no ip address no negotiation auto channel-group 1 mode active !

3750X :

interface Port-channel1
 description *** LACP to ASR1001 ***
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/7
 description *** LACP ***
 switchport access vlan 10
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode passive
!
interface GigabitEthernet1/0/8
 description *** LACP ***
 switchport access vlan 10
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode passive
!
ASR#sh etherchannel load-balancing
EtherChannel Load-Balancing Method:
Global LB Method: flow-based
LB Algo type: Source Destination IP

  Port-Channel:                       LB Method
    Port-channel1                   :  flow-based (Source Destination IP)
    Port-channel2                   :  flow-based (Source Destination IP)
3750X#sh etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address
  IPv6: Source MAC address

On ASR and 3750 I specified port-channel load-balance src-dst-ip but on the ASR but it does not work, it stays in mode Source Destination IP.

What do you think is the problem ?

Many thank !

10 Replies 10

Hello

 


@sebastien3 wrote:

On ASR and 3750 I specified port-channel load-balance src-dst-ip but on the ASR but it does not work, it stays in mode Source Destination IP.

What do you think is the problem ?

Many thank !


You have a L3 PC on the rtr and L2 PC on the switch, this wont work.

Change the switch to a L3 PC.

conf t
no int port 1
default interface gig1/0/7
default interface gig1/0/8

 

int port 1
ip address x.x.x.x.
no shut

 

int range interface gig1/0/7 -8
shut
no switchport
channel-group 1 mode active


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi @paul driver 

My switch have a VLAN, I don't use no switchport...

Hello

I understand that but i would say you cannot really establish a L2 port-channel with a L3 PC, So for this specific connection to work between your rtr and switch i would suggest make the PC on the switch a L3 connection as such it will then require its own ip addressing.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello @sebastien3 ,

in your current setup the switch will use a different load balancing algorythm based on source MAC address if all the traffic is sourced by the switch SVI in vlan 10, then  a single member link will be used in the direction switch to ASR regardless of source IP and destination IP address.

You can have IP connectivty between a L3 port channel and an SVI via a L2 port channel, but load balancing results can be poor as explained above based on the output of your first post.

Probably with a L3 port channel you could be able to use a different load balancing on the C3750 too getting more fair use of member links.

 

Hope to help

Giuseppe

 

Thank you @Giuseppe Larosa 

My need is to have redundancy between the switch and the router with a higher bandwidth if possible due to the use of two ports on each device.

 

The only solution that I found on the redundancy between the two devices is to make the following configuration.

I don't think the traffic is sending 50/50 on each port but rather a port that is always active. I am wrong ??

 

ASR1000

interface Port-channel1
 no ip address
 negotiation auto
!
interface Port-channel1.99
 encapsulation dot1Q 99
 ip address 10.0.99.1 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Port-channel1.100
 encapsulation dot1Q 100
 ip address 10.0.100.1 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface GigabitEthernet0/0/0
 description *** EIGRPP IPv4 ***
 no ip address
 no negotiation auto
 channel-group 1
!
interface GigabitEthernet0/0/1
 description *** EIGRPP IPv4 ***
 no ip address
 negotiation auto
 channel-group 1
!

3750X

interface Port-channel10
 switchport trunk allowed vlan 99,100
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/7
 description *** EIGRP ASR ***
 switchport trunk allowed vlan 99,100
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
!
interface GigabitEthernet1/0/8
 description *** EIGRP ASR ***
 switchport trunk allowed vlan 99,100
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
!

Hello @sebastien3 ,

unfortunately even using two different SVI vlan 99 and vlan 100 they will use the same source MAC address by default.

 

However, you should be able to manually change the MAC address used on one of the two SVI

 

do

show int vlan 99

show int vlan 100

then take note of the listed MAC address and change the last bit in the less significant byte (rightmost)

 

int vlan 100

mac 00AA.BBBB.CCCD

 

in this way you should achieve load balancing with two different source MAC addresses on the two ECMP vlan 99, vlan 100 in the direction switch to ASR.

 

Hope to help

Giuseppe

 

Hello @Giuseppe Larosa 

Thank for your help !


unfortunately even using two different SVI vlan 99 and vlan 100 they will use the same source MAC address by default.


Not stupid this trick to change the MAC, but I have a question !

 

I don't have a VLAN interface on the switch and therefore no IP. The switch is only in access mode for VLANs.

 

Do I have to change the MAC on the Port-channel of the router or can I only create a vlan99 & vlan100 interface on the switch with only the MAC without @ IP?

I recall (?) the 3750 offers multiple (global) Etherchannel hashing choices. If so, look for one that uses src-dest-x. (Even with a L2 Etherchannel, you should also still be able to use a src-dest-IP option [often a better choice than -MAC], if offered.)

Hello @Joseph W. Doherty 

Here is what can be configured on a 3750X :

3750X12S(config)#port-channel load-balance ?
  dst-ip       Dst IP Addr
  dst-mac      Dst Mac Addr
  src-dst-ip   Src XOR Dst IP Addr
  src-dst-mac  Src XOR Dst Mac Addr
  src-ip       Src IP Addr
  src-mac      Src Mac Addr

On my 3750X I have configured src-dst-ip (port-channel load-balance src-dst-ip)

"On my 3750X I have configured src-dst-ip (port-channel load-balance src-dst-ip)"

Yup, that's (again) often the best choice.

BTW, changing the load balancing algorithm might (?) require a reload for it to actually change.
Review Cisco Networking products for a $25 gift card