cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

206
Views
0
Helpful
5
Replies
Beginner

Layer 3 communication between Nexus and 6509's

Dear Members/Experts,

 

We are replacing the Core infrastructure in Building -2 as depicted in the diagram. The Core switches will be Nexus 9k's. These N9k's should talk to one 6509 Core switch in Building-1.That is 10.100.0.0/16 should be able to talk to 10.200.0.0/16. I need to have layer3 communication between them, however vpc does not support Layer 3 and supports Layer2. I cannot have layer2 communication for other reasons. 

 

Please find the diagram attached.

 

Need our suggestions and help.

 

Thanks

 

5 REPLIES 5
VIP Collaborator

Re: Layer 3 communication between Nexus and 6509's

Just a suggestion. Instead of connecting the two Nexus 9372s to the 6509 using a vPC, why not just make it two separate L3 links? One L3 connection between the 6509 and each of the 9372s. This will give you the necessary redundancy and to some degree load balancing.

Hope this helps

 

Highlighted
Beginner

Re: Layer 3 communication between Nexus and 6509's

Agree. If using L2 communication is not an option, then don't use VPC, use L3 links.

Beginner

Re: Layer 3 communication between Nexus and 6509's

Hi Chris,

 

Apologies for the delay in responding back.

 

Yes that is a good idea. So will the configuration will look this.

 

At 6509 end

 Int vlan 1

ip address 1.1.1.1 255.255.255.0

 

int te1/1

switchport

switchport mode access

switchport access vlan 1

 

int te1/2

switchport

switchport mode access

switchport access vlan 1

 

At N9k1.

 

Int vlan 1

ip address 1.1.1.2 255.255.255.0

standby 1 ip address 1.1.1.3

 

int eth1/1

switchport mode access

switchport access vlan 1

 

At N9k2

 

Int vlan 1

ip address 1.1.1.4 255.255.255.0

standby 1 ip address 1.1.1.3

 

int eth1/1

switchport mode access

switchport access vlan 1

 

 

Would request you to confirm if this approach is right ?

 

Thanks

Deepak George

 

Beginner

Re: Layer 3 communication between Nexus and 6509's

Hi Chris,

 

Or do you suggest you the template below.

 


========= N9K =========

interface E3/3
description ## ##
logging event port link-status
mtu 9216
channel-group 1 mode active
no shutdown

interface port-channel1
description ## CORE-01 Connectivity ##
logging event port link-status
no ip redirects
mtu 9216
ip address x.x.x.x/30


========6500=========

interface xx
description ## ##
no switchport
mtu 9216
channel-group 3 mode active
logging event link-status
load-interval 30
carrier-delay msec 0
no shutdown
!
interface port-channel3
description ## Towards N9K ##
no switchport
mtu 9216
ip address x.x.x.x/30
logging event link-status
no ip redirects
no ip proxy-arp
load-interval 30
carrier-delay msec 0
no shut

 

 

Thanks

Deepak

VIP Collaborator

Re: Layer 3 communication between Nexus and 6509's

If there is going to be only a single link between the 6509 and each of the Nexus, I would suggest making each of the links their own /30. I don't think it would be necessary to create VLAN interfaces or port channels for each connection, but instead just make each port a L3 port.

You'll probably also want to peer between the Nexus on a VLAN that goes across the switch's peer link. That's the way I do it across Nexus 5Ks. I assume it would be the same across the 9Ks.

Regards

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards