cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
388
Views
0
Helpful
6
Replies

Layer 3 Ether-channel Dual Up link

qasimkhans8
Level 1
Level 1

Hi,

     i have setup layer 3 switch with need to have Ether-channel Dual Up links. please see the attached network diagram. my goal is if Router 1 goes down then all traffic go through Router 2 and PC1 can communicate with PC3. i entered default routes of both routers

ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 0.0.0.0 0.0.0.0 10.2.2.1

if i use single route of Router1 then PC1 can communicate PC2, when i enter default routes of both routers, then PC1 cannot communicate with PC2 and PC3. how can i fix it?  Thanks,

following is my Layer 3 Switch config.


Current configuration : 2157 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel 1
description Link to R1
no switchport
ip address 10.1.1.2 255.255.255.252
!
interface Port-channel 2
description Link to R2
no switchport
ip address 10.2.2.2 255.255.255.252
!
interface FastEthernet0/1
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
!

!
interface FastEthernet0/21
no switchport
channel-group 2 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/22
no switchport
channel-group 2 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/23
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/24
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
!
!

interface Vlan1
no ip address
shutdown
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
!
interface Vlan31
ip address 192.168.31.1 255.255.255.0
!
interface Vlan32
ip address 192.168.32.1 255.255.255.0
!
interface Vlan33
ip address 192.168.33.1 255.255.255.0
!
interface Vlan34
ip address 192.168.34.1 255.255.255.0
!
interface Vlan35
ip address 192.168.35.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 0.0.0.0 0.0.0.0 10.2.2.1

6 Replies 6

Philip D'Ath
VIP Alumni
VIP Alumni

Enter routes for both remote subnets.

ip route 172.16.1.0 255.255.255.0 10.2.2.1
ip route 110.90.120.0 255.255.255.0 10.1.1.1.

Thanks, but what to do if we want to route traffic on internet. like i have to use default route. like....

ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 0.0.0.0 0.0.0.0 10.2.2.1

There is not enough information to comment on routing to the Internet.  The routes I have given will fix your issue regardless of the two above default routes.

please see the attached image of network, there is 1 layer 3 switch which is connected to 2 routers and both routers are connected to internet. 

all in and out traffic is going through R1, if R1 goes down then all in and out traffic go through R2.

You would need to use a different administrative distance like this:

ip route 0.0.0.0 0.0.0.0 10.1.1.1 
ip route 0.0.0.0 0.0.0.0 10.2.2.1 10

However this will only failover if the whole connection to the router is lost.

this does not work, i switched off R1 but traffic does not goes through R2. when i run sh ip route there is no route for R2

ip route 0.0.0.0 0.0.0.0 10.1.1.1

ip route 0.0.0.0 0.0.0.0 10.2.2.1 10

sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

10.0.0.0/30 is subnetted, 2 subnets

C 10.1.1.0 is directly connected, Port-channel 1

C 10.2.2.0 is directly connected, Port-channel 2

C 192.168.30.0/24 is directly connected, Vlan30

S* 0.0.0.0/0 [1/0] via 10.1.1.1

Review Cisco Networking for a $25 gift card