cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
117
Views
5
Helpful
0
Replies

Let me ask the PROS! lol about my 10 gig nightmare

joshhboss
Beginner
Beginner

So this issue first happened when the forums here were down and I resorted to reddit and I admit the help I got there got to me a solution but I wanted to run it by the community here to just get some insight. I admit I know close to nothing about QOS but it had everything to do with my solution. 

Reddit Post Below...

So im admittedly here because the Cisco Forums are down until the 12th but im having a real hard time understanding how to get the most out of this 10 gig connection im getting for an event.

So this is the issue im having. there is actually some Mikrotik gear in the mix but that isnt where im having the problem. So I am getting 10gig from my ISP for this event and I have it coming in Untagged to a port on my CRS317 10 gig switch. Now when I connect my computer to the next port on that switch with a 10gig copper SFP. And I get 7g down and around 6g up. Now I imagine my computer (MacMini M1 with 10gig Interface) might have something to do with it, BUT HEY, 7g down and 6up.. I can live with that. Now here is where the problem lies. after testing the connection from the Mikrotik. I then untagged the ISP VLAN to my 3 routers.. 2 Edge routers from Ubiquiti and a big PFSense box from Netgate. Now when I connect to the Mikrotik Gear from a network on the PFsense box. I still get great speeds. BUT when I connect the same computer to a 3750X on a 1 gig port. I am only getting 700mgs down and 900 up (only on speedtest.net, all other sites are in the 300s).. the 3750 is connected to the Mikrotik on a 10gig link configured as a trunk port. NOW the only other thing connected to the switch is my computer. basic configs too..

 

Switch Ports Model                     SW Version            SW Image                 
------ ----- -----                     ----------            ----------               
*    1 30    WS-C3750X-24P             15.2(4)E10            C3750E-UNIVERSALK9-M     
          

Configuration register is 0xF

Sw141# show run int te1/1/2
Building configuration...

Current configuration : 145 bytes
!
interface TenGigabitEthernet1/1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed nonegotiate
 ip dhcp snooping trust
end

Sw141#show run int gig1/0/1
Building configuration...

Current configuration : 119 bytes
!
interface GigabitEthernet1/0/1
 switchport access vlan 230
 switchport mode access
 spanning-tree portfast edge
end

Sw141#show int status | i connected
Gi1/0/2                      connected    230        a-full a-1000 10/100/1000BaseTX
Te1/1/2                      connected    trunk        full    10G SFP-10GBase-LR
Sw141#

 

 

Are there other things I need to be doing to ensure that the 3750 can properly distribute the traffic to the ports. Ive ran two computers at the same time. And they both get the same speeds at the same time. so its almost like the issue is just capping the connection.

Im also getting another internet connection from another company and its 1gig down and up.. now only the same router and the same switch. just changing the load balancing rules.. I get 1g down and up. so I dont know if there is something that needs to be address on the 10gig side but im completely lost. hard cording speed and duplex has been down and there are no CRC errors or anything like that on the ports.

THANK you ALL!!

End of Reddit post.. 

Now these were the commands that I used off of someones recommendation on Reddit.

 

mls qos queue-set output 2 threshold 1 1600 1600 50 1600
mls qos queue-set output 2 threshold 2 1600 1600 50 1600
mls qos queue-set output 2 threshold 3 1600 1600 50 1600
mls qos queue-set output 2 threshold 4 1600 1600 50 1600
mls qos queue-set output 2 buffers 25 25 25 25 
mls qos
interface gig1/0/2
queue-et 2

 

And immediately after that it worked as I hoped.. Giving me a gig on the 1 gig ports. Now I was considering applying this QOS to the trunk ports going to the APs so the ports dont get bogged down when a lot of clients connect. 

I know that was a lot to read but Im eager to learn and experience, mistakes, YouTube and forums is how it seems to be happening. Thank you all!!

 

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers