cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
215
Views
5
Helpful
1
Replies
nokoya001
Beginner

limiting bandwith of two port same vlan

Hello,

 

Here is the diagram

Internet  <--> .Cisco ASR  <--> Cisco 3750

 

2 server connect to Cisco 3750 on port gi1/0/3 and gi1/0/7 get internet thru ASR with portchannel 1.101

These are the config of ASR

!

interface Port-channel1.101

encapsulation dot1Q 101

  ip address 103.2.0.1 255.255.255.0

  ip address 103.2.1.1 255.255.255.0 secondary

  no ip redirects

  no ip proxy-arp

end

 

And these are config of gi1/0/3 and gi1/0/7 which is same.

!

interface GigabitEthernet1/0/3

  switchport access vlan 101

  switchport mode access

end

 

Questions:

1. How can I limit vlan 101 bandwidth to maximum 50mbps going to outside of the internet ?

2. Should I do it on ASR or 3750 ? 

3. With policy-map ? Could you give me an example.

 

Thanks in advanced.

1 ACCEPTED SOLUTION

Accepted Solutions
Georg Pauwen
VIP Expert

Hello,

 

the config below should limit VLAN 101 to 50MB out:

 

platform qos port-channel-aggregate 1
!
class-map VLAN_101_CLASS
match vlan 101
!
policy-map VLAN_101_POLICY
class VLAN_101_CLASS
police cir 50000000
conform-action transmit
!
interface port-channel 1.101
service-policy output VLAN_101_POLICY

 

Here is the step by step syntax:

 

ASR#conf t
ASR(config)#platform qos port-channel-aggregate 1
ASR(config)# class-map VLAN_101_CLASS
ASR(config-cmap)# match vlan 101
ASR(config-cmap)#exit
ASR(config)# policy-map VLAN_101_POLICY
ASR(config-pmap)# class VLAN_101_CLAS
ASR(config-pmap-c)# police cir 50000000
ASR(config-pmap-c-police)#confirm-action transmit
ASR(config-pmap-c-police)#end
ASR#conf t
ASR(config)#interface port-channel 1.101
ASR(config-subif)#service-policy output VLAN_101_POLICY

View solution in original post

1 REPLY 1
Georg Pauwen
VIP Expert

Hello,

 

the config below should limit VLAN 101 to 50MB out:

 

platform qos port-channel-aggregate 1
!
class-map VLAN_101_CLASS
match vlan 101
!
policy-map VLAN_101_POLICY
class VLAN_101_CLASS
police cir 50000000
conform-action transmit
!
interface port-channel 1.101
service-policy output VLAN_101_POLICY

 

Here is the step by step syntax:

 

ASR#conf t
ASR(config)#platform qos port-channel-aggregate 1
ASR(config)# class-map VLAN_101_CLASS
ASR(config-cmap)# match vlan 101
ASR(config-cmap)#exit
ASR(config)# policy-map VLAN_101_POLICY
ASR(config-pmap)# class VLAN_101_CLAS
ASR(config-pmap-c)# police cir 50000000
ASR(config-pmap-c-police)#confirm-action transmit
ASR(config-pmap-c-police)#end
ASR#conf t
ASR(config)#interface port-channel 1.101
ASR(config-subif)#service-policy output VLAN_101_POLICY

View solution in original post