cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
5669
Views
0
Helpful
16
Replies
henrik-stryhn
Beginner

Link flapping, C3750<->WLC5500

I've got a simple setup with a C3750 connected with a WLC5500 on two fiberports.

Configuration:

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
speed nonegotiate
channel-group 1 mode on
end
Interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
speed nonegotiate
channel-group 1 mode on
end

Ports on WLC are configured with LAG on.

Both ports on C3750 keeps changing states, 10-100 down's/up's in an hour.

I've tried to disable each link separetly, disabling channel-group, etc., nothing works.

I've upgraded the software to 12.2(52)SE. I've debugged etherchannel, link states, changed fibercabling, etc., nothing shows any errors.

The problem persists on both interfaces, no matter which interfaces are disabled, etc.

Log:

001124: Dec 27 13:48:12.257 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down
001125: Dec 27 13:48:15.352 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up
001126: Dec 27 13:48:26.954 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down
001127: Dec 27 13:48:30.049 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up
001128: Dec 27 13:48:43.664 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down
001129: Dec 27 13:48:46.768 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up
001130: Dec 27 13:49:03.680 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to down
001131: Dec 27 13:49:06.775 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to up
001132: Dec 27 13:49:33.912 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down
001133: Dec 27 13:49:36.999 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up
001134: Dec 27 13:50:36.282 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to down
001135: Dec 27 13:50:39.378 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to up

Any good ideas?

16 REPLIES 16

HI!

The magic is more friquent then we want to hear about it.

The same problem trapped with my network.

We have two 650x with some 3750 stacks connected to it  on 2x10 Gbit (EtherChan) .

To each of those 3750 are connectedby one else 3750 stacks on 2x1Gbit (EtherChan)

One "happy" day (3 days ago)  ALL the NETWORK got a crazy - domaine is not accessible!

Network pings about 5 secconds, then not at all.

After some hours of braine rings and restarting everithing in different combinations we shut all the ports on the both 650x.

Then began to not shut by one stack. The A and B up - network works good. Pings are pingingin all the pings.

When we uped X stack  -- IMXO!!! To est - all falt down.

So we localized the problem. Then we shut the X down-stack (1 G-trunk).

With X stack 10G the LAN works good.

So we break the X down-stack 1G and find out the one 3750 who was the monster.

The network works during some years and that is the first but very remember INCIDENT.

Now we are trying to find out what is the problem.

Neither MARS, neither IDS kill the anomalia! -???? Why?!

We have fixed the baginning: Flapping vlan 1 MAC-address on port 1G X-down stack,

then flapping MAC Y between 10G trunks, ports down, ports up and all of those are continuosly.

IS IT Spanning-tree Protocol slapping?

On Layer 2 we have:

access ports are in port-fast

all switches are in Rapid PVST

trunk-ports are with vlan-lists  and fast trunks

What shall I do to prevent from these surprises?

And is this problem of cisco devices or somebody else?

The C3750 hardware was faulty. When it was replaced, all flapping disappeared.