cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
150
Views
0
Helpful
4
Replies
Highlighted
Beginner

Little VLAN Trunk Topology with multiple virtual NICS

Hello guys i have this little Topology for you.

I have on the OpenVPNServer2 Machine multiple NICs and i want them to be able to ping the devices in VLAN10 and VLAN20

through the trunking port of the Switch.

vlanTrunkTopology.png

I have configured the vlans and the trunk like this:

 

Switch(config)#interface FastEthernet 0/0
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit


Switch(config)#interface FastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit


Switch(config)#interface FastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit

 

I cant ping the IoT1 or IoT2 device from OpenVPNServer2 device.

What else is needed?
Internally the devices should be using ARP Protocol and the pings should find their way.

What did I miss?

 

Thanks to anybody taking his time for this !

Everyone's tags (1)
4 REPLIES 4
VIP Expert

Re: Little VLAN Trunk Topology with multiple virtual NICS

Hi,

I am not familiar with OpenVPNServer2 but can you make sure that lot1 and 2 have the correct gateway?

Also, for testing, can you create an SVI for one of the vlans on the switch and give it an IP and see if you can ping it?

HTH

Beginner

Re: Little VLAN Trunk Topology with multiple virtual NICS

Can you share output of 'route-n' and 'iptables -nL' from your Linux server.


@pokito123 wrote:

Hello guys i have this little Topology for you.

I have on the OpenVPNServer2 Machine multiple NICs and i want them to be able to ping the devices in VLAN10 and VLAN20

through the trunking port of the Switch.

vlanTrunkTopology.png

I have configured the vlans and the trunk like this:

 

Switch(config)#interface FastEthernet 0/0
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit


Switch(config)#interface FastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit


Switch(config)#interface FastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit

 

I cant ping the IoT1 or IoT2 device from OpenVPNServer2 device.

What else is needed?
Internally the devices should be using ARP Protocol and the pings should find their way.

What did I miss?

 

Thanks to anybody taking his time for this !


route-n and

Beginner

Re: Little VLAN Trunk Topology with multiple virtual NICS

Hi guys still struggling with this,

 

So i made a wireshark capture on the trunking connection,(When Pinging IoT1) the ARP broadcast is send but a response is not coming back.

The Gateway for IoT1 is the NIC IP: 192.100.1.1
The Gateway for IoT2 is the NIC IP: 192.100.2.1

 

iptables command.pngroute screen.png

Beginner

Re: Little VLAN Trunk Topology with multiple virtual NICS

Ok i reconfigured and restarted from scratch.

 

The OpenVPNServer2 can ping both IoT1 and IoT2.

But now the IoT1(VLAN10) and IoT2(VLAN20) can also ping each other, how can i disable this ?

Is there any possible configuration directly on the L2 Switch or i would say i could try ip tables by source adress and block traffic at the OpenVPNServer2, which is the best solution for that?

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards