cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
621
Views
0
Helpful
2
Replies

LLDP med on cisco switch

Joli Martinez
Beginner
Beginner

We had a non Cisco switch running our IP phones.  The phones are polycoms phones.  That switch has died and we are replacing it with a cisco switch.  How would I setup a voice vlan.  So if a phone is plugged into the switch port it will pickup one vlan, but if it is a pc Or anything else it will get a different vlan.   Below is the config from the non cisco switch.  I am looking for an equivalent config and/or any better suggestions.

 

 interface 0/14
  voice vlan 100    
  voice vlan data priority untrust
  auto-voip protocol-based
  auto-voip oui-based
  description 'Some phone'
  spanning-tree edgeport
  vlan participation exclude 10,20,30,50,60,200
  vlan participation include 100
  vlan tagging 100
  lldp transmit
  lldp receive
  lldp transmit-tlv port-desc
  lldp transmit-tlv sys-name
  lldp transmit-tlv sys-desc
  lldp transmit-tlv sys-cap
  lldp transmit-mgmt
  lldp notification
  lldp med
  lldp med confignotification
  exit
2 Replies 2

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

below a sample config for ports with Polycom phones attached:

 

interface GigabitEthernet0/14
description Polycom Phone port
switchport mode access
switchport access vlan x
switchport voice vlan 100
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust
no cdp enable
lldp transmit
lldp receive
spanning-tree portfast

Joli Martinez
Beginner
Beginner

My voice vlan is 10 and my data is 40.  I have dropped the following config and both the pc and the phone are getting IP's from vlan 40.  Is there a global config or something else I need to do?

 

interface GigabitEthernet0/7
description Polycom Spare Phone
switchport mode access
switchport access vlan 40
switchport voice vlan 10
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust
no cdp enable
lldp transmit
lldp receive
spanning-tree portfast
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers