cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
542
Views
2
Helpful
5
Replies

MAC Flap

untamed2233
Level 1
Level 1

Hello, 

I see the following in syslog from an IDF (C3850) switch in our warehouse. The gig interfaces flapping are Extreme Networks 410i wireless access points, and the port channel is the link back to the MDF. 

3: Nov 27 22:23:22: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.d460 in vlan 52 is flapping between port Gi1/0/27 and port Gi1/0/46

119944: Nov 27 22:32:23: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ebd3 in vlan 52 is flapping between port Po1 and port Gi1/0/27

119945: Nov 27 22:48:21: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.971c in vlan 52 is flapping between port Gi1/0/46 and port Po1

119946: Nov 27 22:52:08: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.97ec in vlan 52 is flapping between port Gi1/0/27 and port Gi1/0/46

119947: Nov 27 22:56:52: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.971c in vlan 52 is flapping between port Po1 and port Gi1/0/46

119948: Nov 27 23:20:49: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ee6b in vlan 52 is flapping between port Po1 and port Gi1/0/27

119949: Nov 27 23:30:32: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ee6b in vlan 52 is flapping between port Po1 and port Gi1/0/46

119950: Nov 27 23:30:35: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ee32 in vlan 52 is flapping between port Po1 and port Gi1/0/46

119951: Nov 27 23:41:53: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.da95 in vlan 52 is flapping between port Gi1/0/46 and port Po1

119952: Nov 27 23:49:35: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.d3f2 in vlan 52 is flapping between port Gi1/0/27 and port Gi1/0/46

119953: Nov 27 23:57:08: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.97ec in vlan 52 is flapping between port Gi1/0/27 and port Gi1/0/46

119954: Nov 27 23:58:38: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ee6b in vlan 52 is flapping between port Gi1/0/46 and port Po1

119955: Nov 28 00:04:02: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.fecd in vlan 52 is flapping between port Po1 and port Gi1/0/27

119956: Nov 28 00:18:22: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.ee6b in vlan 52 is flapping between port Po1 and port Gi1/0/27

119957: Nov 28 00:45:48: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.fecd in vlan 52 is flapping between port Gi1/0/27 and port Po1

119958: Nov 28 00:49:32: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.971c in vlan 52 is flapping between port Po1 and port Gi1/0/27

119959: Nov 28 00:55:38: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.d460 in vlan 52 is flapping between port Po1 and port Gi1/0/46

119960: Nov 28 01:04:35: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.fecd in vlan 52 is flapping between port Gi1/0/27 and port Po1

119961: Nov 28 01:15:19: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.d482 in vlan 52 is flapping between port Po1 and port Gi1/0/27

119962: Nov 28 01:18:50: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.b616 in vlan 46 is flapping between port Gi1/0/27 and port Po1

119963: Nov 28 01:22:04: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.97ec in vlan 52 is flapping between port Gi1/0/46 and port Gi1/0/27

Here is the config for all 3 interfaces

interface GigabitEthernet1/0/46
switchport trunk native vlan 172
switchport trunk allowed vlan 46,48,50,52,56,172,900
switchport mode trunk
spanning-tree portfast
service-policy input PER-PORT-MARKING
service-policy output EGRESS-QUEUING
!
interface GigabitEthernet1/0/27
switchport trunk native vlan 172
switchport trunk allowed vlan 46,48,50,52,56,172,900
switchport mode trunk
spanning-tree portfast
service-policy input PER-PORT-MARKING
service-policy output EGRESS-QUEUING
!
interface Port-channel1
switchport trunk allowed vlan 6,7,10,46,48,50,52,56,100,111,125,127,172,814
switchport trunk allowed vlan add 900,2002
switchport mode trunk
switchport nonegotiate
end

Please let me know what I need to do to resolve this. I'll be happy to provide any other details needed. 

1 Accepted Solution

Accepted Solutions

That normal if wireless client is l2 roaming 

Do

no mac address-table notification mac-move

To not see this log again.

MHM

View solution in original post

5 Replies 5

That normal if wireless client is l2 roaming 

Do

no mac address-table notification mac-move

To not see this log again.

MHM

Reza Sharifi
Hall of Fame
Hall of Fame

Hi,

Mac flapping is not unusual when you have APs connected to multiple ports on a switch or multiple switches, and the users are moving around with their laptops or mobile devices.
What ports are members of PO1?

HTH

Hi thanks for that. I was not aware. 

Only one member of Po1 and thats the fiber run back to the MDF, Te1/1/1

Only one member of Po1 and thats the fiber run back to the MDF, Te1/1/1

Ok, so when you see the flap coming from the PO, that means the AP is connected to a different switch of the core, and someone with a mobile device is romaing around.

HTH

Hmm. The only thing plugged back in to the core is the WLC.

Our full topology is Core > Switch > PoE WAP and the controllers for the WAPs are plugged directly into the core (C9K)
Review Cisco Networking for a $25 gift card