cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
137
Views
0
Helpful
3
Replies
Beginner

MACFLAP_NOTIF

Just want to ask assistance regarding to this log message on our cisco switch. Is this a layer 2 looping issue. how can I prevent this or fix this?

 

Jun 14 2018 07:31:37.821 PHT: %SW_MATM-4-MACFLAP_NOTIF: Host c8d7.19c2.a4e4 in vlan 8 is flapping between port Gi0/7 and port Gi0/8
Jun 14 2018 09:32:21.113 PHT: %SW_MATM-4-MACFLAP_NOTIF: Host b88a.60d4.92e8 in vlan 8 is flapping between port Gi0/7 and port Gi0/8

 

nhcph036#show run interface gigabitEthernet 0/7
Building configuration...

Current configuration : 233 bytes
!
interface GigabitEthernet0/7
description connected to - R600 RUCKUS AP
switchport trunk allowed vlan 1,8,10,12,256
switchport trunk native vlan 256
switchport mode trunk
switchport nonegotiate
no power efficient-ethernet
end

nhcph036#show run interface gigabitEthernet 0/8
Building configuration...

Current configuration : 163 bytes
!
interface GigabitEthernet0/8
description CONNECTED TO NHCPH014 SWITCH
switchport trunk allowed vlan 1,8,10,12,256
switchport mode trunk
switchport nonegotiate
end

3 REPLIES 3
Highlighted

Re: MACFLAP_NOTIF

Hi Mate,

 

you'd find a lot of discussions in regards to this matter in the forum.

MACFLAP notifications basically indicate that the MAC address is moved from one port to the other within a short time.

In your case, it looks like a wireless client roamed from an access point attached to the port Gi0/7 to another access point. This behaviour is normal for wireless

 

you should be able to observe the behaviour with #show mac-address-table address **MAC**

 

Regards,

Prabath

 

***Please rate all the useful posts***
-Prabath
Collaborator

Re: MACFLAP_NOTIF

Hi,

What devices are using those mac addresses? Are they wireless devices? If they are wireless devices, it could be that they are bouncing from between access points. If they are not wireless  devices, they there could be a layer 2 loop.

 

If it is a layer 2 issue you could enable bpdu guard on all ports that should not be connected to a switch.

 

Thanks

John

**Please rate posts you find helpful**
Hall of Fame Community Legend

Re: MACFLAP_NOTIF

Both ports 7 & 8 are in a trunk, however, they are not in an etherchnnel. What are these two ports? Are they uplinks or are these two links to the downstream client?
What happens if both ports are configured in an etherchannel?
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards