cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
32909
Views
194
Helpful
21
Replies
haikalmesiniaga
Beginner

MD5 digest checksum mismatch on trunk: Gi0/1

#sh vtp status

VTP Version capable             : 1 to 3

VTP version running             : 1

VTP Domain Name                 : msc2020

VTP Pruning Mode                : Disabled

VTP Traps Generation            : Disabled

Device ID                       : 9c4e.2082.1680

Configuration last modified by 10.112.117.xxx at 3-1-93 01:09:03

Feature VLAN:

--------------

VTP Operating Mode                : Client

Maximum VLANs supported locally   : 255

Number of existing VLANs          : 12

Configuration Revision            : 0

MD5 digest                        : 0x97 0x34 0xA1 0x22 0xEF 0x55 0x38 0xE9

                                    0x5D 0x66 0x03 0x6B 0x36 0x30 0xC1 0xA8

*** MD5 digest checksum mismatch on trunk: Gi0/2 ***

****************

Any ide how to fix this ?

21 REPLIES 21

I assume that the counters for received and transmitted advertisements increase and the number of config digest errors as well? If so, there must be something wrong with domain name and/or password (maybe a whitespace).

You can try to find a difference by comparing the vlan.dat "header" (cli-command: more flash:vlan.dat; domain-name and password are clear text) or -more pragmatic-, delete the vlan.dat like suggested by Leo and re-enter the domain-name/password. As an alternative, you could also copy the vlan.dat from another switch into the flash: of the not-synchronizing switch (by TFTP).

I had this issue on a new set of 6509 switches (non-production) adding and dropping a vlan did it for me. Thanks for this it was driving me crazy for a bit.

I had a pair of Cisco 3560X switches, but the one set as the vtp server failed.  So, my second switch in my environment needed to be the primary and I changed it to "vtp mode server". This second one was originally set with the "vtp mode client".

Then, the replacement switch was set with "vtp mode client" but reported the MD5 mismatch.  The steps outlined by insharie worked great!!!  Thanks for sharing the needed steps to check and correct the MD5 mismatch!!!

InayathUlla Sharieff,

Thank you. This worked a treat.

3-

Last option is that the  problem could be due to bug if you are running version 12.2(40)SE ) VTP digest mismatch.

Solution: The resolve is to simply create another vlan that you will never use.

{Eg:

The fastest way I am aware of to solve this is to just force an update from the VTP server.

We could do this for example in config mode, by creating and removing a bogus vlan:

Thanks InayathUlla for your helpful response...

IT WORKS !!!

 

Previously I´ve already checked de first 2 steps, the third one worked on mi switches.

 

Had a similar problem, this helped alot, thanks.