cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3168
Views
0
Helpful
8
Replies
Daniel Mansilla
Beginner

Multicast Does Not work in the same Vlan in the same Switch?

Hello.

My question is the next:

I am configuring one cluster red-hat (two machines). My problem is that in my "clúster" only show me one machine and appears this message in the log "conexion refused" . In the Switch is enabled igmp snooping and filter. I would like know if this information can help me for solution my problem. I Guess that something  is  cutting the multicast traffic between both machines.

http://www.cisco.com/image/gif/paw/6813/cat_multicast_prob.pdf

This document show the solution for problems between two switches. I only have one Switch for this machines.

Thanks so much.

Best Regards

Daniel Mansilla

8 REPLIES 8
Eugene Lau
Cisco Employee

Hi Daniel,

Firstly, I'd like to check what platform/version you are running. Example, IOS 6500 switches will constrain unknown multicast by default.

For multicast to be "known", there would be the need for a  "multicast router" or similar function such as the IGMP Querier.  Could you confirm whether you have a mrouter or similar function?

Some questions:

1. Does the cluster work when IGMP is disabled?

2. With IGMP Enabled, what happens when you configure a static multicast MAC on the port? Does this work as well?

3. Confirm that you ping is successful between the two servers (and for a sanity check, that they are in the same VLAN )

Can start from there.

Eugene.

Thanks for you answer.

Answering your questions:

First.- The platform is WS-C4948-10GE, IOS running cat4500-ipbase-mz.122-46.SG.bin

Second- Yes, my platform have features mrouter and query but aparent is not configured. attached the command output:

Some questions:

1. Does the cluster work when IGMP is disabled?

R: I don't know. This switch currently is in production and is very hard starting with tests.

2. With IGMP Enabled, what happens when you configure a static multicast MAC on the port? Does this work as well?

R:I have not configured anything yet. currently the switch is in production and can not make changes.

3. Confirm that you ping is successful between the two servers (and for a sanity check, that they are in the same VLAN )

R: The servers have normal comunication the ping is succesfull  and I have not conectivity problems. Actually is in the same vlan.

My question is the next: If i configuring one mac statics or other solution of the guide.  It the solution my problem?

Thanks so much