Showing results for 
Search instead for 
Did you mean: 

Multicast ip not being forwarded L2 on fex-ports on Nexus5010 and on Cat6509:WS-X6748-GE-TX

Jesper Joensen


Had a problem and now I have a question:

A server setup relying on multicast on udp 45591 (internally on the vlan - non-routed) was moved from one vlan on a Catalyst 2960 switch (working OK here) to a datacenter vlan.

First it was established on 4 gigabit ports (fex) on a Nexus 5010 setup: apparantly was not forwarded by the switch (wireshark check on both source and destinations), but f.ex. was forwarded for a period of time - then it stopped, apparantly blocked by the switch ! We tried to move the servers to 4 gigabit ports on a Cat65 module with same result.
Eventually the application guys changed the multicast IP to udp 45591 and everything works fine !!!

Is there something with switches and multicast ?


Regards Jesper

2 Replies 2


Hi Jesper,

While I'm no expert on Multicast - (only several years in the trenches), it appears the address range you are attempting to use may not be valid as reported by this draft - see url below.

Hope this helps


IPv4 Multicast Unusable Group And Source Addresses


 (*,       Control plane of IGMP snoopers  Section 7.1
 (*,     Control plane of IGMP snoopers  Section 7.1


Hi Frank
Thanks for your reply.
I got this explanation from our national Cisco office:   = 1110 0000 . 0000 0000 . 0000 0000 . 0000 0000 = 1110 0000 . 0000 0000 . 0000 0000 . 1111 1111  = 1110 1101 . 0000 0000 . 0000 0000 . 0001 0101 = 1110 0100 . 0000 1010 . 0000 1010 . 0000 1001

23 bits to the right should have been yellow in all 4 lines!

L3 to L2 mapping:
Multiclass Class-D always starts with 1110. Hereafter 32-4= 28 bits left. You only have 23 bits for multicast L2 addresses, that is 28-23 = 5 bits ovelap - 23 bits marked with yellow.
224.0.0.x is Link Local Multicast and will always be flooded in switches. maps to the same L2 address range (0x0100.5e00.00xx) as the Link Local Multicast, so eventually it will be flooded as well with as without igmp snooping enabled.
228.10.10.x will not be L2 flooded with igmp snooping enabled (=default).

Regards Jesper

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers