cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
688
Views
0
Helpful
5
Replies
James Simpson
Beginner

Multicast VLAN clients not talking to the server

Multicast within a vlan not working

Hi

 

I have a 3850 switch with vlan 18 that I want to enable multicast on 

Off this witch I have a couple of 2960 stacks

 

(3850)

interface vlan 18 

ip address 192.168.1.1 255.255.255.0

ip pim sparse-mode

!

ip pim rp-address 192.168.1.1 
!
ip multicast-routing
!
ip igmp snooping querier

 

All other switches 

!

ip igmp snooping querier

!

ip pim rp-address 192.168.1.1 
!
ip multicast-routing

 

I need a a couple of clients to access a server with vlan 18, and they cant seem to communicate 

is there something im missing 

 

Thanks in advance 

5 REPLIES 5
Giuseppe Larosa
Hall of Fame Master

Hello James,

you don't need the IGMP snooping querier because the C3850 SVI interface has PIM enabled and this enables IGMP too (version 2 by default).

 

You need also to know that in a given Vlan only one device can be configured with the IGMP snooping querier command (there is no way to perform an election of the best IGMP snooping querier).

 

Try again removing all the IGMP snooping querier commands

 

Hope to help

Giuseppe

 

brselzer
Cisco Employee

Hello James,

 

Are the 2960s L2 only? If so, they don't need the PIM config. Also, you only want one querier in a vlan and enabling PIM on an interface enables it as a querier so you can remove "ip igmp snooping querier" from all switches as "ip pim sparse-mode" automatically enables it for you. 

 

The clients and the source server are both in vlan 18? I assume unicast from the source server to the clients work?

 

Hope that helps!

-Bradley Selzer
CCIE# 60833