cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
563
Views
25
Helpful
8
Replies
springs015
Beginner

Multiple Trunked Routers

Is it possible to connect two or even three routers that are trunked to a switch with sub-interfaces. I have made a diagram of the situation.

Simple Diagram Here

In testing the configuration, the only way I have gotten it to work is to not trunk a routers connection to the switch, and only have one trunked router.

I am either missing something in the configuration, or this is just not a possible configuration.

***EDIT** UPDATE As the below posts have confirmed this is possible, I will upload more information to my main post.  In summary. I am not seeing VLAN 10 and 20 showing in the Trunking VLANs Active. I am unable to ping between the routers. 

S1

!

interface FastEthernet0/10

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

interface FastEthernet0/20

switchport trunk encapsulation dot1q

switchport mode trunk

!

S1#sh int fa0/10 sw

Name: Fa0/10

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,67-70,78,88,101,108,125-127,199

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Self Loopback: No

S1#sh int fa0/20 sw

Name: Fa0/20

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,67-70,78,88,101,108,125-127,199

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

*******************************************************************************

******************************R1 Config****************************************

R1#show run

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.10.255.254 255.255.0.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 10.20.255.254 255.255.0.0

!

r14-1700#sh int fa0/0 summary

*: interface is up

IHQ: pkts in input hold queue     IQD: pkts dropped from input queue

OHQ: pkts in output hold queue    OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)

TRTL: throttle count

  Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

------------------------------------------------------------------------

* FastEthernet0/0          0     0    0     0     0    1     0    0    0

* FastEthernet0/0.10       -     -    -     -     -    -     -    -   -

* FastEthernet0/0.20       -     -    -     -     -    -     -    -   -

r14-1700#sh int fa0/0

FastEthernet0/0 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 000f.24af.1fb0 (bia 000f.24af.1fb0)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:06, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

r14-1700#sh int fa0/0.20

FastEthernet0/0.20 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 000f.24af.1fb0 (bia 000f.24af.1fb0)

  Internet address is 10.20.255.254/16

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

r14-1700#sh int fa0/0.10

FastEthernet0/0.10 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 000f.24af.1fb0 (bia 000f.24af.1fb0)

  Internet address is 10.10.255.254/16

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never 

*******************************************************************************

******************************R2 Config****************************************

R2#show run

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.10.255.253 255.255.0.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 10.20.255.253 255.255.0.0

!

R2#sh int fa0/0 summary

*: interface is up

IHQ: pkts in input hold queue     IQD: pkts dropped from input queue

OHQ: pkts in output hold queue    OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)

TRTL: throttle count

  Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

------------------------------------------------------------------------

* FastEthernet0/0          0     0    0     0     0    0     0    0    0

* FastEthernet0/0.10       -     -    -     -     -    -     -    -   -

* FastEthernet0/0.20       -     -    -     -     -    -     -    -   -

R2#sh interfaces fa0/0

FastEthernet0/0 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 0013.8063.fa6e (bia 0013.8063.fa6e)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:09, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

R2#sh interfaces fa0/0.20

FastEthernet0/0.20 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 0013.8063.fa6e (bia 0013.8063.fa6e)

  Internet address is 10.20.255.253/16

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

R2#sh interfaces fa0/0.10

FastEthernet0/0.10 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 0013.8063.fa6e (bia 0013.8063.fa6e)

  Internet address is 10.10.255.253/16

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

*******************************************************************************

8 REPLIES 8
rassoul.ghaznavi
Beginner

Hi Stefan,

I don't see any problem with this, please explain more what problems are you experiencing.

Regards

Yes it should be perfectly possible. As rassoul said, what other problemsdo you have? Maybe you could post the configuration of the switch ports and routers (just the relevant parts).

springs015
Beginner

I have updated the original post with additional information. I am unsure if this is enough information.

I hope this is some glaring configuration I am just overlooking, I am currently in process of reloading the switch to default configuration to test from there.

Hi, Are VLANs 10 & 20 configured on the switch?

On the switch do a show vlan and see if vlan 10 and 20 are even created , if not create them .  I assume this is just to test in a lab to see if you can get connectivity between devices .  If you look at the switch config that you gave us those vlans appear to be missing .

S1#sh int fa0/10 sw

Name: Fa0/10

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,67-70,78,88,101,108,125-127,199   ----------->   vlan 10 and 20 are not here or allowed on the trunk and need to be created .

Pruning VLANs Enabled: 2-1001

I was convinced that the issue was with the router configuration as I did a packet capture and never saw any VLAN 10 or 20 traverse the trunk. But I was able to get this working after adding the vlans to the database. I still have some confusion on how this is working though.

There are some instances where I do not need to manually create the vlan in the database and it just appears. I noticed this occured if you configured a access port on a VLAN, however I reloaded all of the devices and just did the trunk configuration listed above as well as configured VLAN 10 as the management interface(only on S1). There was no need to manually add VLANs to the database in S1, I did have to manually add them to S2.

I realize creating the management VLAN 10 will put it in the database, but I can't explain how VLAN 20 got added.

Can anyone give some more detail on the circumstances a VLAN with automatically get created (documentation would be good).

Thanks for the help!

OK heres the thing.

WHen you create a vlan i.e.

#vlan 20

#vlan 30

#exit

you SHOULD always type exit so it actually creates the VLAN.

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_configuration_example09186a008009478e.shtml#createvlans3

Also, if your switches are default, then they are both VTP servers. This means when you create the VLAN on one switch it will update the other. You should check out VTP states and modes so you don't accidentally make/delete vlans that could screw up your network.

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml

You can use #sh vtp status

to check this info.

Regards,

Ian

Please rate if I hepled.

Yep, that is what I was trying to find.

Thanks!