cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1462
Views
0
Helpful
2
Replies

Multiple WS-2960CX-8PC-L won't allow use of both fiber ports.

treimers1
Level 1
Level 1

Hi everyone -

 

I have a bit of a strange problem.

I have THREE of the WS-C2960CX-8PC-L switches

that will not allow me to use both of the SFP ports.

Links to "yes this should work" from the Datasheets are below.

 

Troubleshooting thus far:

- This is true when connecting ANY fiber optical device using ANY fiber transceiver (Cisco, CXTec, etc) to either of those ports. You can use ONE fiber port -- and both copper ports. 

You cannot use all FOUR (2 fiber, 2 copper) uplinks at the same time.

 

I've moved the SFPs/fiber patches to two OTHER Cisco switches and had links come up - the SFPs and fiber patches are just fine, no bad hardware.

 

But as soon as I try to connect the second SFP (either one) of the fiber ports to an SFP, and bring up _anything_ on the other end, the link _will not_ come up.

 

The SFP does show up in 'show inv' == but no link will happen.

 

 

 

 

 
 

2960-CX
(LAN Base)

8

Non PoE

8 x 1G

2 x 1 G SFP

2 x 1 G Cu

WS-C2960CX-8TC-L

PoE+

(124W)

8 x 1G

2 x 1 G SFP

2 x 1 G Cu

WS-C2960CX-8PC-L

This from the 3560 portion
 
 Can you use both the 2 x 10G SFP+ uplinks along with 2 x Multigigabit ports on WS-C3560CX-8XPD-S at the same time?
A.     Yes, all 4 ports can be used at the same time and are line rate.
 
 
 

Table 4.       Cisco Catalyst 2960-X Compact Switch Models and Default Software

Model

Ethernet Ports

PoE
Output Ports

Available
PoE Power

Uplinks

Default Software

2960CX-8TC-L

8 x 10/100/1000 Gigabit Ethernet

N/A

2 x 1G copper plus

2 x 1G SFP

LAN Base

2960CX-8PC-L

8 x 10/100/1000 Gigabit Ethernet

8 PoE+

124W

2 x 1G copper plus

2 x 1G SFP

LAN Base

Note:    All four uplink ports (two copper and two fiber) can be used simultaneously and also as downlinks.

 

2 Replies 2

treimers1
Level 1
Level 1

A further quick comment ---

 

I have, of course, swapped SFPs/fiber patches around

on various ports -- this is happening on at least three different 2960CX switches, so I don't think it's failed SFP slots, nor is it failed SFPs/bad patches, etc.

 

If it were a problem with shared ports, I'd expect not to be able to share the copper uplink/downlink ports either - ie, I'd be able to get ONE copper link and ONE fiber link up.

As it is, I can get both copper uplinks and one fiber port working -- not all four.

 

For those who will want to know the firmware involved:

c2960cx-universalk9-mz.152-4.E2.bin

 

Both SFPs do show up - no slot failures

sh inventory
NAME: "1", DESCR: "WS-C2960CX-8TC-L"
PID: WS-C2960CX-8TC-L , VID: V03 , SN: FOC2030Z67Q

NAME: "GigabitEthernet0/11", DESCR: "1000BaseLX SFP"
PID: GLC-LH-SMD , VID: V01 , SN: AXCLHSMD004949

NAME: "GigabitEthernet0/12", DESCR: "1000BaseLX SFP"
PID: GLC-LH-SMD , VID: V01 , SN: GTYW2777

 

One of the other affected switches is running:

c2960cx-universalk9-mz.152-3.E2.bin

 

So not even the same versions of software --

 

Thanks for any advice... Tim

 

 

Punt to top of the list for some to see this...

 

Has anyone got any ideas?

 

Thanks Tim

Review Cisco Networking for a $25 gift card