cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

299
Views
0
Helpful
2
Replies
Highlighted
Beginner

NAT or Access-list problem

This one has me stumped. I am connecting a 2600 router to an ISP. Interface 0/0 is connected to the ISP using DHCP. Interface 0/1 is connected to the inside providing DHCP services to the inside. At least it should only be providing DHCP services to the inside. I also have a public static IP that is NAT to a private static IP. Everything is working except the computer on the static IP. From the router I am able to ping inside and out from each interface. I am able to ping both interfaces of the router from the computer on the static IP but I cannot ping outside the router. If I do a debug all I see a reject for the gateway of the static IP but it has “mobile IP” in the text string. Not sure what mobile IP is relating to. Networks are as follows:

0/0 DHCP 10.X.X.X

0/1 192x.x.x

Static 75.X.X.X

no ip dhcp use vrf connected

ip dhcp excluded-address 192.X.X.1

ip dhcp excluded-address 192.X.X.2

ip dhcp pool CLIENT

   import all

   network 192.X.X.0 255.255.240.0

   default-router 192.X.X.1

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no cdp enable

interface FastEthernet0/1

ip address 192.X.X.1 255.255.240.0

ip nat inside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no cdp enable

no ip forward-protocol nd

ip http server

no ip http secure-server

ip nat inside source list 102 interface FastEthernet0/0 overload

ip nat inside source static 192.X.X.2 75.X.X.21

!

access-list 102 permit ip 192.X.X.0 0.0.0.255 any

no cdp run

Thank you for any help.

Everyone's tags (2)
2 REPLIES 2
Advocate

NAT or Access-list problem

Hi,

how does your ISP know he should route  75.X.X.21 towards your FastEthernet0/0 interface while it's receiving it's IP address from DHCP dynamically?

Is there any routing protocol running between you and your ISP?

HTH,

Milan

Beginner

NAT or Access-list problem

I was only given part of the information. Even though the outside interface could obtain an IP address from DHCP I should have been using the static IP address. I called the ISP this morning to get the subnet mask of the assigned static IP. Everything is working. Thanks for the reply.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards