cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9215
Views
5
Helpful
21
Replies

Need help with inter-vlan routing between hosts in different vlans

UserTM
Level 1
Level 1

Problem:

For a school project I have to configure a rather unconventional network. The original given topology was a bit simpler, but because we have to simulate the devices with EVE-NG we lost the ability to stack devices. So instead of stacking our Core and Distribution switches, we get the mess below.

 

I managed to get the layer 3 link-aggregation between the Core- and Distribution layer switches running and I also configured GLBP for all the Distribution Switches, but I'm still unable to ping between PCs in different VLANS. Pinging between PCs in the same VLAN seems to work just fine, even if they are connected to different access switches. The PCs are also able to ping to the virtual GLBP default gateway address of their respective VLAN. The Native VLAN is 1, and all the links between the Access and Distribution switches are in trunking mode. The Access switches' ports going to the PCs are configured in access mode for a specific VLAN. The Layer 3 Distribution switches are able to ping to the IPs of all the PCs regardless of their VLAN. 

 

I have the feeling I'm missing something obvious, but I can't seem to find it.
I'm hoping that someone on this forum might be able to help me.

 

Let me now if you require further information in order to help me...

Topology:TopologyTopology

Running Configuration:

IP of DEVPC: 172.16.30.20 255.255.255.0 (gateway: 172.16.30.15)

IP of FINPC: 172.16.70.20 255.255.255.0 (gateway: 172.16.70.15)

Configuration of NYCore1

Spoiler
Building configuration...

Current configuration : 3764 bytes
!
! Last configuration change at 14:50:02 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYCore1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
vtp domain NYVTP
vtp mode transparent
!
!
!
ip cef
ipv6 multicast rpf use-bgp
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
 name GUEST
!
vlan 20
 name SALES
!
vlan 30
 name DEVELOPMENT
!
vlan 40
 name CODING
!
vlan 50
 name TESTING
!
vlan 60
 name SUPPORT
!
vlan 70
 name FINANCIAL
!
vlan 80
 name SHIPPING
!
vlan 90
 name MARKETING
!
vlan 99
 name MANAGEMENT
!
vlan 100
 name SERVER
!
vlan 110
 name EXTERNAL
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 no switchport
 ip address 172.16.1.9 255.255.255.252
!
interface Port-channel2
 no switchport
 ip address 172.16.1.13 255.255.255.252
!
interface Port-channel3
 no switchport
 ip address 172.16.1.17 255.255.255.252
!
interface Port-channel4
 no switchport
 ip address 172.16.1.21 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet1/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet2/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 3 mode active
!
interface Ethernet2/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 3 mode active
!
interface Ethernet2/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 3 mode active
!
interface Ethernet2/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 3 mode active
!
interface Ethernet3/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 4 mode active
!
interface Ethernet3/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 4 mode active
!
interface Ethernet3/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 4 mode active
!
interface Ethernet3/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 4 mode active
!
interface Ethernet4/0
!
interface Ethernet4/1
!
interface Ethernet4/2
!
interface Ethernet4/3
!
interface Ethernet5/0
!
interface Ethernet5/1
!
interface Ethernet5/2
 description connection to NYR1-e0/3
 no switchport
 ip address 172.16.1.2 255.255.255.252
 duplex auto
!
interface Ethernet5/3
!
router ospf 1
 network 172.16.1.0 0.0.0.3 area 0
 network 172.16.1.8 0.0.0.3 area 0
 network 172.16.1.12 0.0.0.3 area 0
 network 172.16.1.16 0.0.0.3 area 0
 network 172.16.1.20 0.0.0.3 area 0
 network 172.16.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configuration of NYCore2

Spoiler
Building configuration...

Current configuration : 3336 bytes
!
! Last configuration change at 14:51:01 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYCore2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
no switchport
ip address 172.16.1.25 255.255.255.252
!
interface Port-channel2
no switchport
ip address 172.16.1.29 255.255.255.252
!
interface Port-channel3
no switchport
ip address 172.16.1.33 255.255.255.252
!
interface Port-channel4
no switchport
ip address 172.16.1.37 255.255.255.252
!
interface Ethernet0/0
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/1
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/2
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/3
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet1/0
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 2 mode active
!
interface Ethernet1/1
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 2 mode active
!
interface Ethernet1/2
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 2 mode active
!
interface Ethernet1/3
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 2 mode active
!
interface Ethernet2/0
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 3 mode active
!
interface Ethernet2/1
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 3 mode active
!
interface Ethernet2/2
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 3 mode active
!
interface Ethernet2/3
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 3 mode active
!
interface Ethernet3/0
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 4 mode active
!
interface Ethernet3/1
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 4 mode active
!
interface Ethernet3/2
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 4 mode active
!
interface Ethernet3/3
no switchport
no ip address
duplex auto
channel-protocol lacp
channel-group 4 mode active
!
interface Ethernet4/0
!
interface Ethernet4/1
!
interface Ethernet4/2
!
interface Ethernet4/3
!
interface Ethernet5/0
!
interface Ethernet5/1
!
interface Ethernet5/2
no switchport
ip address 172.16.1.6 255.255.255.252
duplex auto
!
interface Ethernet5/3
!
router ospf 1
network 172.16.1.4 0.0.0.3 area 0
network 172.16.1.24 0.0.0.3 area 0
network 172.16.1.28 0.0.0.3 area 0
network 172.16.1.32 0.0.0.3 area 0
network 172.16.1.36 0.0.0.3 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

Configuration of NYDist1

Spoiler
Building configuration...

Current configuration : 4888 bytes
!
! Last configuration change at 15:12:55 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYDist1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
!
!
!
ip cef
ipv6 multicast rpf use-bgp
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 no switchport
 ip address 172.16.1.10 255.255.255.252
!
interface Port-channel2
 no switchport
 ip address 172.16.1.38 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet1/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet2/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 172.16.1.41 255.255.255.248
 glbp 1 ip 172.16.1.45
!
interface Vlan10
 ip address 172.16.10.11 255.255.255.0
 glbp 10 ip 172.16.10.15
!
interface Vlan20
 ip address 172.16.20.11 255.255.255.0
 glbp 20 ip 172.16.20.15
!
interface Vlan30
 ip address 172.16.30.11 255.255.255.0
 glbp 30 ip 172.16.30.15
!
interface Vlan40
 ip address 172.16.40.11 255.255.255.0
 glbp 40 ip 172.16.40.15
!
interface Vlan50
 ip address 172.16.50.11 255.255.255.0
 glbp 50 ip 172.16.50.15
!
interface Vlan60
 ip address 172.16.60.11 255.255.255.0
 glbp 60 ip 172.16.60.15
!
interface Vlan70
 ip address 172.16.70.11 255.255.255.0
 glbp 70 ip 172.16.70.15
!
interface Vlan80
 ip address 172.16.80.11 255.255.255.0
 glbp 80 ip 172.16.80.15
!
interface Vlan90
 ip address 172.16.90.11 255.255.255.0
 glbp 90 ip 172.16.90.15
!
interface Vlan99
 ip address 172.16.99.11 255.255.255.0
 glbp 99 ip 172.16.99.15
!
interface Vlan100
 ip address 172.16.100.11 255.255.255.0
 glbp 100 ip 172.16.100.15
!
interface Vlan110
 ip address 172.16.110.11 255.255.255.0
 glbp 110 ip 172.16.110.15
!
router ospf 1
 network 172.16.1.8 0.0.0.3 area 0
 network 172.16.1.36 0.0.0.3 area 0
 network 172.16.1.40 0.0.0.7 area 0
 network 172.16.10.0 0.0.0.255 area 0
 network 172.16.20.0 0.0.0.255 area 0
 network 172.16.30.0 0.0.0.255 area 0
 network 172.16.40.0 0.0.0.255 area 0
 network 172.16.50.0 0.0.0.255 area 0
 network 172.16.60.0 0.0.0.255 area 0
 network 172.16.70.0 0.0.0.255 area 0
 network 172.16.80.0 0.0.0.255 area 0
 network 172.16.90.0 0.0.0.255 area 0
 network 172.16.99.0 0.0.0.255 area 0
 network 172.16.100.0 0.0.0.255 area 0
 network 172.16.110.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.1.9
ip route 0.0.0.0 0.0.0.0 172.16.1.37
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configuration of NYDist2

Spoiler
Building configuration...

Current configuration : 4303 bytes
!
! Last configuration change at 15:12:58 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYDist2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 no switchport
 ip address 172.16.1.14 255.255.255.252
!
interface Port-channel2
 no switchport
 ip address 172.16.1.34 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet1/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet2/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 172.16.1.42 255.255.255.248
 glbp 1 ip 172.16.1.45
!
interface Vlan10
 ip address 172.16.10.12 255.255.255.0
 glbp 10 ip 172.16.10.15
!
interface Vlan20
 ip address 172.16.20.12 255.255.255.0
 glbp 20 ip 172.16.20.15
!
interface Vlan30
 ip address 172.16.30.12 255.255.255.0
 glbp 30 ip 172.16.30.15
!
interface Vlan40
 ip address 172.16.40.12 255.255.255.0
 glbp 40 ip 172.16.40.15
!
interface Vlan50
 ip address 172.16.50.12 255.255.255.0
 glbp 50 ip 172.16.50.15
!
interface Vlan60
 ip address 172.16.60.12 255.255.255.0
 glbp 60 ip 172.16.60.15
!
interface Vlan70
 ip address 172.16.70.12 255.255.255.0
 glbp 70 ip 172.16.70.15
!
interface Vlan80
 ip address 172.16.80.12 255.255.255.0
 glbp 80 ip 172.16.80.15
!
interface Vlan90
 ip address 172.16.90.12 255.255.255.0
 glbp 90 ip 172.16.90.15
!
interface Vlan99
 ip address 172.16.99.12 255.255.255.0
 glbp 99 ip 172.16.99.15
!
interface Vlan100
 ip address 172.16.100.12 255.255.255.0
 glbp 100 ip 172.16.100.15
!
interface Vlan110
 ip address 172.16.110.12 255.255.255.0
 glbp 110 ip 172.16.110.15
!
router ospf 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.1.13
ip route 0.0.0.0 0.0.0.0 172.16.1.33
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configuration of NYDist3

Spoiler
Building configuration...

Current configuration : 4869 bytes
!
! Last configuration change at 14:51:34 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYDist3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 no switchport
 ip address 172.16.1.18 255.255.255.252
!
interface Port-channel2
 no switchport
 ip address 172.16.1.30 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet1/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet2/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 172.16.1.43 255.255.255.248
 glbp 1 ip 172.16.1.45
!
interface Vlan10
 ip address 172.16.10.13 255.255.255.0
 glbp 10 ip 172.16.10.15
!
interface Vlan20
 ip address 172.16.20.13 255.255.255.0
 glbp 20 ip 172.16.20.15
!
interface Vlan30
 ip address 172.16.30.13 255.255.255.0
 glbp 30 ip 172.16.30.15
!
interface Vlan40
 ip address 172.16.40.13 255.255.255.0
 glbp 40 ip 172.16.40.15
!
interface Vlan50
 ip address 172.16.50.13 255.255.255.0
 glbp 50 ip 172.16.50.15
!
interface Vlan60
 ip address 172.16.60.13 255.255.255.0
 glbp 60 ip 172.16.60.15
!
interface Vlan70
 ip address 172.16.70.13 255.255.255.0
 glbp 70 ip 172.16.70.15
!
interface Vlan80
 ip address 172.16.80.13 255.255.255.0
 glbp 80 ip 172.16.80.15
!
interface Vlan90
 ip address 172.16.90.13 255.255.255.0
 glbp 90 ip 172.16.90.15
!
interface Vlan99
 ip address 172.16.99.13 255.255.255.0
 glbp 99 ip 172.16.99.15
!
interface Vlan100
 ip address 172.16.100.13 255.255.255.0
 glbp 100 ip 172.16.100.15
!
interface Vlan110
 ip address 172.16.110.13 255.255.255.0
 glbp 110 ip 172.16.110.15
!
router ospf 1
 network 172.16.1.16 0.0.0.3 area 0
 network 172.16.1.28 0.0.0.3 area 0
 network 172.16.1.40 0.0.0.7 area 0
 network 172.16.10.0 0.0.0.255 area 0
 network 172.16.20.0 0.0.0.255 area 0
 network 172.16.30.0 0.0.0.255 area 0
 network 172.16.40.0 0.0.0.255 area 0
 network 172.16.50.0 0.0.0.255 area 0
 network 172.16.60.0 0.0.0.255 area 0
 network 172.16.70.0 0.0.0.255 area 0
 network 172.16.80.0 0.0.0.255 area 0
 network 172.16.90.0 0.0.0.255 area 0
 network 172.16.99.0 0.0.0.255 area 0
 network 172.16.100.0 0.0.0.255 area 0
 network 172.16.110.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.1.17
ip route 0.0.0.0 0.0.0.0 172.16.1.29
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configuration of NYDist4

Spoiler
Building configuration...

Current configuration : 4303 bytes
!
! Last configuration change at 15:13:56 CET Fri May 11 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYDist4
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 no switchport
 ip address 172.16.1.22 255.255.255.252
!
interface Port-channel2
 no switchport
 ip address 172.16.1.26 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet0/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 1 mode active
!
interface Ethernet1/0
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/1
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/2
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet1/3
 no switchport
 no ip address
 duplex auto
 channel-protocol lacp
 channel-group 2 mode active
!
interface Ethernet2/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet2/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet3/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet4/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet5/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 172.16.1.44 255.255.255.248
 glbp 1 ip 172.16.1.45
!
interface Vlan10
 ip address 172.16.10.14 255.255.255.0
 glbp 10 ip 172.16.10.15
!
interface Vlan20
 ip address 172.16.20.14 255.255.255.0
 glbp 20 ip 172.16.20.15
!
interface Vlan30
 ip address 172.16.30.14 255.255.255.0
 glbp 30 ip 172.16.30.15
!
interface Vlan40
 ip address 172.16.40.14 255.255.255.0
 glbp 40 ip 172.16.40.15
!
interface Vlan50
 ip address 172.16.50.14 255.255.255.0
 glbp 50 ip 172.16.50.15
!
interface Vlan60
 ip address 172.16.60.14 255.255.255.0
 glbp 60 ip 172.16.60.15
!
interface Vlan70
 ip address 172.16.70.14 255.255.255.0
 glbp 70 ip 172.16.70.15
!
interface Vlan80
 ip address 172.16.80.14 255.255.255.0
 glbp 80 ip 172.16.80.15
!
interface Vlan90
 ip address 172.16.90.14 255.255.255.0
 glbp 90 ip 172.16.90.15
!
interface Vlan99
 ip address 172.16.99.14 255.255.255.0
 glbp 99 ip 172.16.99.15
!
interface Vlan100
 ip address 172.16.100.14 255.255.255.0
 glbp 100 ip 172.16.100.15
!
interface Vlan110
 ip address 172.16.110.14 255.255.255.0
 glbp 110 ip 172.16.110.15
!
router ospf 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.1.21
ip route 0.0.0.0 0.0.0.0 172.16.1.25
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configuration of NYASW1

Spoiler
Building configuration...

Current configuration : 3212 bytes
!
! Last configuration change at 12:16:25 CET Fri May 11 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYASW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
ip cef
!
!
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet0/3
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet1/0
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet1/1
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet1/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet1/3
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet2/0
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet2/1
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet2/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet2/3
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet3/0
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet3/1
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet3/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet3/3
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet4/0
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet4/1
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet4/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet4/3
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet5/0
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet5/1
 switchport access vlan 30
 switchport mode access
 duplex auto
!
interface Ethernet5/2
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet5/3
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/0
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/1
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/2
 switchport access vlan 10
 switchport mode access
 shutdown
 duplex auto
!
interface Ethernet6/3
 switchport access vlan 10
 switchport mode access
 shutdown
 duplex auto
!
interface Vlan99
 ip address 172.16.99.21 255.255.255.0
!
ip default-gateway 172.16.99.15
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

Configuration of NYASW5

Spoiler
Building configuration...

Current configuration : 3113 bytes
!
! Last configuration change at 12:19:49 CET Fri May 11 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname NYASW5
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
!
ip cef
!
!
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet0/3
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet1/0
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet1/1
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet1/2
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet1/3
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet2/0
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet2/1
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet2/2
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet2/3
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet3/0
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet3/1
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet3/2
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet3/3
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet4/0
 switchport access vlan 70
 switchport mode access
 duplex auto
!
interface Ethernet4/1
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet4/2
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet4/3
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet5/0
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet5/1
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet5/2
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet5/3
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/0
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/1
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet6/2
 shutdown
 duplex auto
!
interface Ethernet6/3
 shutdown
 duplex auto
!
interface Vlan99
 ip address 172.16.99.25 255.255.255.0
 shutdown
!
ip default-gateway 172.16.99.15
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

 

1 Accepted Solution

Accepted Solutions

Good news, I finally managed to resolve the problem. 
The cause was indeed a bug in the emulation software, I found the solution over here...
Basically I had to turn off Cisco Express Forwarding in order to get inter-vlan routing to work.

After issuing the no ip cef command on my Layer 3 Switches everything worked like it was supposed to.

 

A big thank you to Mohammed and Georg Pauwen for helping me along the way...

View solution in original post

21 Replies 21

mohammed01701
Level 1
Level 1

Hi!

 

I think MAYBE you have problem with the routes- (both static and dynamic), you implemented static on NYDist1-3 that means everything routes to NYCore1 or NYCore2. Can you run "show ip route" on NYDist1, NYDist2 and NYDist3 and post it? I don´t understand why you don´t have any subnet under "router ospf 1" on NYDist3. 

 

HTH

 

/Mohammed

topology.PNG

Hi Mohammed,

You are correct to state that I shouldn"t have implemented static default routes on my Distribution Switches. (Instead I need to use the default-information originate command on my actual routers) However, while this is indeed a mistake, I don't believe it causes the issue of the inter-vlan routing since there are better matches for the IPs of the hosts in the routing table.

I deleted the static routes just to be sure and turned off all the core and distribution switches except NYDist1.
In theory I should still be able to route between vlans with only the blue devices in the topology above being active. (I'm hoping to pinpoint the problem by minimizing the area of possible failure)
The 2 DEVPCs are in the same VLAN (30/DEVELOPMENT) and are able to ping to eachother, they have an IP of 172.16.30.20 and 172.16.30.21 respectively with a default-gateway of 172.16.30.11 (I also turned glbp off) They are also able to ping their default gateways (172.16.30.11) and the other interface vlans on the NYDist1 switch (like 172.16.70.11 and 172.16.20.11), but I do get the following message when tracing the route (ICMP type:3, code:3, Destination port unreachable). Which I found strange, since I'm able to ping without any issues. I'm still unable to ping the FINPC (172.16.70.20 in VLAN 70/FINANCIAL) or the SALPC (172.16.20.20 in VLAN20/SALES) from the DEVPCs and vice versa.

Here is the routing table of Dist1:

Spoiler
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 30 subnets, 4 masks
C        172.16.1.8/30 is directly connected, Port-channel1
L        172.16.1.10/32 is directly connected, Port-channel1
C        172.16.1.36/30 is directly connected, Port-channel2
L        172.16.1.38/32 is directly connected, Port-channel2
C        172.16.1.40/29 is directly connected, Vlan1
L        172.16.1.41/32 is directly connected, Vlan1
C        172.16.10.0/24 is directly connected, Vlan10
L        172.16.10.11/32 is directly connected, Vlan10
C        172.16.20.0/24 is directly connected, Vlan20
L        172.16.20.11/32 is directly connected, Vlan20
C        172.16.30.0/24 is directly connected, Vlan30
L        172.16.30.11/32 is directly connected, Vlan30
C        172.16.40.0/24 is directly connected, Vlan40
L        172.16.40.11/32 is directly connected, Vlan40
C        172.16.50.0/24 is directly connected, Vlan50
L        172.16.50.11/32 is directly connected, Vlan50
C        172.16.60.0/24 is directly connected, Vlan60
L        172.16.60.11/32 is directly connected, Vlan60
C        172.16.70.0/24 is directly connected, Vlan70
L        172.16.70.11/32 is directly connected, Vlan70
C        172.16.80.0/24 is directly connected, Vlan80
L        172.16.80.11/32 is directly connected, Vlan80
C        172.16.90.0/24 is directly connected, Vlan90
L        172.16.90.11/32 is directly connected, Vlan90
C        172.16.99.0/24 is directly connected, Vlan99
L        172.16.99.11/32 is directly connected, Vlan99
C        172.16.100.0/24 is directly connected, Vlan100
L        172.16.100.11/32 is directly connected, Vlan100
C        172.16.110.0/24 is directly connected, Vlan110
L        172.16.110.11/32 is directly connected, Vlan110

Thanks in advance for your help,
UserTM

Hello,

 

judging from the configs you posted, the inter-Vlan routing occurs on NYR1 and NYR2 ? Can you post the configuration of those two routers ?

Thanks for your reply,

I'm afraid the routers haven't been configured yet. The inter-vlan routing is supposed to take place on the Layer 3 switches (using SVIs). I wanted to get the internal VLAN connectivity working before worrying about Network Address Translation and external communication to the ISPs on the routers.
All the ports on the Core-switches are routed ports, and the ports in link-aggregation on the Distribution switches are routed ports as well, while the ports going to the access switches are all switchports in trunking mode.

 

I also added some more information about my problem in my reply to Mohammed, so if you're able to, you might want to read that reply as well.

Thanks in advance,
UserTM

Hello,

 

I don't seem to see 'ip routing' enabled on any of the switches (or maybe I am overlooking something) ?

That's because show run doesn't show all the default configuration commands. When I issue show run all the ip routing command does appear in the running config. My routing table also isn't empty, so there's that.

Hello,

 

something fundamental must be missing. What does your VTP look like, do you have a domain configured ?

Post the output of 'show ip route' from one of the distribution switches...

Hi!

If you want to see routing tabell on one of the NYDist, he or she posted before: see the previous post. Can post show ip arp on VLAN 20 and 70?

Can you shutdown the Links from NYSw5 to NYDist4, because of you are not configurated routing yet. When you shutdown those links i think you will see a diffrence. Please post show ip arp those vlans you do have a problem before you shutdown those links and arter!

How do you created vlans? I don't see any VLAN id and Names om the configuration you send yesterday

 

HTH

 

/Mohammed

My bad...got the routing table. 

 

The problem might be with the GLBP...what is the output of 'show glbp 30' ?


@Georg Pauwen wrote:

My bad...got the routing table. 

 

The problem might be with the GLBP...what is the output of 'show glbp 30' ?


Here is the output when only NYDist1 is turned on (I temporarily turned off the other Layer 3 switches to isolate the problem. Inter-vlan routing should be possible with just this one Layer 3 switch since both access switches have a link to Dist1)

NYDist1#show glbp vlan 30
Vlan30 - Group 30
  State is Active
    1 state change, last state change 00:52:30
  Virtual IP address is 172.16.30.15
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.992 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption disabled
  Active is local
  Standby is unknown
  Priority 100 (default)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    aabb.cc80.7100 (172.16.30.11) local
  There is 1 forwarder (1 active)
  Forwarder 1
    State is Active
      1 state change, last state change 00:52:18
    MAC address is 0007.b400.1e01 (default)
    Owner ID is aabb.cc80.7100
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 100

NYDist1#show glbp brief
Interface Grp Fwd Pri State Address Active router Standby router
Vl1 1 - 100 Active 172.16.1.45 local unknown
Vl1 1 1 - Active 0007.b400.0101 local -
Vl10 10 - 100 Active 172.16.10.15 local unknown
Vl10 10 1 - Active 0007.b400.0a01 local -
Vl20 20 - 100 Active 172.16.20.15 local unknown
Vl20 20 1 - Active 0007.b400.1401 local -
Vl30 30 - 100 Active 172.16.30.15 local unknown
Vl30 30 1 - Active 0007.b400.1e01 local -
Vl40 40 - 100 Active 172.16.40.15 local unknown
Vl40 40 1 - Active 0007.b400.2801 local -
Vl50 50 - 100 Active 172.16.50.15 local unknown
Vl50 50 1 - Active 0007.b400.3201 local -
Vl60 60 - 100 Active 172.16.60.15 local unknown
Vl60 60 1 - Active 0007.b400.3c01 local -
Vl70 70 - 100 Active 172.16.70.15 local unknown
Vl70 70 1 - Active 0007.b400.4601 local -
Vl80 80 - 100 Active 172.16.80.15 local unknown
Vl80 80 1 - Active 0007.b400.5001 local -
Vl90 90 - 100 Active 172.16.90.15 local unknown
Vl90 90 1 - Active 0007.b400.5a01 local -
Vl99 99 - 100 Active 172.16.99.15 local unknown
Vl99 99 1 - Active 0007.b400.6301 local -
Vl100 100 - 100 Active 172.16.100.15 local unknown
Vl100 100 1 - Active 0007.b400.6401 local -
Vl110 110 - 100 Active 172.16.110.15 local unknown
Vl110 110 1 - Active 0007.b400.6e01 local -

 


@mohammed01701 wrote:

Hi!

If you want to see routing tabell on one of the NYDist, he or she posted before: see the previous post. Can post show ip arp on VLAN 20 and 70?

Can you shutdown the Links from NYSw5 to NYDist4, because of you are not configurated routing yet. When you shutdown those links i think you will see a diffrence. Please post show ip arp those vlans you do have a problem before you shutdown those links and arter!

How do you created vlans? I don't see any VLAN id and Names om the configuration you send yesterday

 

HTH

 

/Mohammed


I have already turned off all layer 3 switches except NYDist1, I do use VTP to propagate my VLANS, NYDist1 is the VTP-server of domain NYVTP (password is also NYVTP [Since this is just a simulation, I don't mind to share it, I probably change it later anyway]). 

 

VLANs on NYDist1

Spoiler
NYDist1#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : NYVTP
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : aabb.cc80.7100
Configuration last modified by 172.16.1.41 at 5-12-18 06:18:08
Local updater ID is 172.16.1.41 on interface Vl1 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 17
Configuration Revision            : 5
MD5 digest                        : 0x84 0x2D 0xC1 0x32 0x11 0x20 0xB6 0x76
                                    0xB1 0x63 0x23 0x10 0xF2 0x40 0xD0 0x86
NYDist1#show vtp pass
NYDist1#show vtp password
VTP Password: NYVTP
NYDist1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
10   GUEST                            active
20   SALES                            active
30   DEVELOPMENT                      active
40   CODING                           active
50   TESTING                          active
60   SUPPORT                          active
70   FINANCIAL                        active
80   SHIPPING                         active
90   MARKETING                        active
99   MANAGEMENT                       active
100  SERVER                           active
110  EXTERNAL                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLANs on NYASW1

Spoiler
NYASW1#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : NYVTP
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : aabb.cc01.3100
Configuration last modified by 172.16.1.41 at 5-12-18 06:18:08

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 17
Configuration Revision            : 5
MD5 digest                        : 0x84 0x2D 0xC1 0x32 0x11 0x20 0xB6 0x76
                                    0xB1 0x63 0x23 0x10 0xF2 0x40 0xD0 0x86
NYASW1#show vtp password
VTP Password: NYVTP
NYASW1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
10   GUEST                            active    Et5/2, Et5/3, Et6/0, Et6/1
                                                Et6/2, Et6/3
20   SALES                            active
30   DEVELOPMENT                      active    Et0/2, Et0/3, Et1/0, Et1/1
                                                Et1/2, Et1/3, Et2/0, Et2/1
                                                Et2/2, Et2/3, Et3/0, Et3/1
                                                Et3/2, Et3/3, Et4/0, Et4/1
                                                Et4/2, Et4/3, Et5/0, Et5/1
40   CODING                           active
50   TESTING                          active
60   SUPPORT                          active
70   FINANCIAL                        active
80   SHIPPING                         active
90   MARKETING                        active
99   MANAGEMENT                       active
100  SERVER                           active
110  EXTERNAL                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLANs on NYASW5

Spoiler
NYASW5#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : NYVTP
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : aabb.cc01.7100
Configuration last modified by 172.16.1.41 at 5-12-18 06:18:08

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 17
Configuration Revision            : 5
MD5 digest                        : 0x84 0x2D 0xC1 0x32 0x11 0x20 0xB6 0x76
                                    0xB1 0x63 0x23 0x10 0xF2 0x40 0xD0 0x86
NYASW5#show vtp password
VTP Password: NYVTP
NYASW5#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et6/2, Et6/3
10   GUEST                            active    Et5/2, Et5/3, Et6/0, Et6/1
20   SALES                            active    Et4/1, Et4/2, Et4/3, Et5/0
                                                Et5/1
30   DEVELOPMENT                      active
40   CODING                           active
50   TESTING                          active
60   SUPPORT                          active
70   FINANCIAL                        active    Et0/2, Et0/3, Et1/0, Et1/1
                                                Et1/2, Et1/3, Et2/0, Et2/1
                                                Et2/2, Et2/3, Et3/0, Et3/1
                                                Et3/2, Et3/3, Et4/0
80   SHIPPING                         active
90   MARKETING                        active
99   MANAGEMENT                       active
100  SERVER                           active
110  EXTERNAL                         active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup

 

 

Hi!

 

As long every thing looks like fine:) But something has to bee wrong, i could not see any thing yet,  but please post those show commands, to figure out if there is any arps on PC on the difference vlans:

Can you post "show ip arp those vlans" you have a problem? 

Can you post show spanning tree on those interfaces between Dist and Switchs?

Do you know which switch is root for spanning tree?

 

HTH

/Mohammed


@mohammed01701 wrote:

Hi!

 

As long every thing looks like fine:) But something has to bee wrong, i could not see any thing yet,  but please post those show commands, to figure out if there is any arps on PC on the difference vlans:

Can you post "show ip arp those vlans" you have a problem? 

Can you post show spanning tree on those interfaces between Dist and Switchs?

Do you know which switch is root for spanning tree?

 

HTH

/Mohammed


Here you go,

 topology.PNG

NYDist1: show ip arp vlan 30 and 70

Spoiler
NYDist1#show ip arp vlan 30
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.30.11            -   aabb.cc80.7100  ARPA   Vlan30
Internet  172.16.30.15            -   0007.b400.1e01  ARPA   Vlan30
Internet  172.16.30.20           56   0050.7966.6825  ARPA   Vlan30
Internet  172.16.30.19           56   aabb.cc81.3100  ARPA   Vlan30
NYDist1#show ip arp vlan 70
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.70.11            -   aabb.cc80.7100  ARPA   Vlan70
Internet  172.16.70.15            -   0007.b400.4601  ARPA   Vlan70
Internet  172.16.70.20            0   0050.7966.6829  ARPA   Vlan70

On my access switches (Layer 2) I only have a vlan interface with an ip for my MANAGEMENT vlan 99, so I can't use the show ip arp vlan 30 or show ip arp vlan 70 command

NYASW1: show ip arp 

Spoiler
NYASW1#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.99.11           61   aabb.cc80.7100  ARPA   Vlan99
Internet  172.16.99.15           61   0007.b400.6301  ARPA   Vlan99
Internet  172.16.99.21            -   aabb.cc81.3100  ARPA   Vlan99

NYASW5: show ip arp

Spoiler
NYASW5#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.99.11            0   aabb.cc80.7100  ARPA   Vlan99
Internet  172.16.99.15            0   0007.b400.6301  ARPA   Vlan99
Internet  172.16.99.25            -   aabb.cc81.7100  ARPA   Vlan99

Spanning tree (Im using pvst)

NYDist1 (link to NYASW1)

Spoiler
NYDist1#show spanning-tree interface ethernet 3/0

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg FWD 100       128.13   Shr
VLAN0010            Desg FWD 100       128.13   Shr
VLAN0020            Desg FWD 100       128.13   Shr
VLAN0030            Desg FWD 100       128.13   Shr
VLAN0040            Desg FWD 100       128.13   Shr
VLAN0050            Desg FWD 100       128.13   Shr
VLAN0060            Desg FWD 100       128.13   Shr
VLAN0070            Desg FWD 100       128.13   Shr
VLAN0080            Desg FWD 100       128.13   Shr
VLAN0090            Desg FWD 100       128.13   Shr
VLAN0099            Desg FWD 100       128.13   Shr
VLAN0100            Desg FWD 100       128.13   Shr
VLAN0110            Desg FWD 100       128.13   Shr

NYDist1 (link to NYASW5)

Spoiler
NYDist1#show spanning-tree interface ethernet 5/0

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg FWD 100       128.21   Shr
VLAN0010            Desg FWD 100       128.21   Shr
VLAN0020            Desg FWD 100       128.21   Shr
VLAN0030            Desg FWD 100       128.21   Shr
VLAN0040            Desg FWD 100       128.21   Shr
VLAN0050            Desg FWD 100       128.21   Shr
VLAN0060            Desg FWD 100       128.21   Shr
VLAN0070            Desg FWD 100       128.21   Shr
VLAN0080            Desg FWD 100       128.21   Shr
VLAN0090            Desg FWD 100       128.21   Shr
VLAN0099            Desg FWD 100       128.21   Shr
VLAN0100            Desg FWD 100       128.21   Shr
VLAN0110            Desg FWD 100       128.21   Shr

NYASW1 (link to NYDist1)

Spoiler
NYASW1#show spanning-tree interface ethernet 0/0

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Root FWD 100       128.1    Shr
VLAN0010            Root FWD 100       128.1    Shr
VLAN0020            Root FWD 100       128.1    Shr
VLAN0030            Root FWD 100       128.1    Shr
VLAN0040            Root FWD 100       128.1    Shr
VLAN0050            Root FWD 100       128.1    Shr
VLAN0060            Root FWD 100       128.1    Shr
VLAN0070            Root FWD 100       128.1    Shr
VLAN0080            Root FWD 100       128.1    Shr
VLAN0090            Root FWD 100       128.1    Shr
VLAN0099            Root FWD 100       128.1    Shr
VLAN0100            Root FWD 100       128.1    Shr
VLAN0110            Root FWD 100       128.1    Shr

NYASW5 (link to NYDist1)

Spoiler
NYASW5#show spanning-tree interface ethernet 0/0

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Root FWD 100       128.1    Shr
VLAN0010            Root FWD 100       128.1    Shr
VLAN0020            Root FWD 100       128.1    Shr
VLAN0030            Root FWD 100       128.1    Shr
VLAN0040            Root FWD 100       128.1    Shr
VLAN0050            Root FWD 100       128.1    Shr
VLAN0060            Root FWD 100       128.1    Shr
VLAN0070            Root FWD 100       128.1    Shr
VLAN0080            Root FWD 100       128.1    Shr
VLAN0090            Root FWD 100       128.1    Shr
VLAN0099            Root FWD 100       128.1    Shr
VLAN0100            Root FWD 100       128.1    Shr
VLAN0110            Root FWD 100       128.1    Shr

 

Hello,

 

I just labbed this in GNS3, I agree with Mohammed, the configs look fine. Which switches are you using ? And which hosts/PCs ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card