cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1380
Views
0
Helpful
15
Replies
fred.appelman
Beginner

Need some basic help configuring a CISCO892W-AGN-E-K9

My knowledge is very basic so please bear me with me.

I just bought a CISCO892W-AGN-E-K9. This device has two indepent wireless antenna's, an 8 port internal switch plus two WAN links, 1 Gigabit Ethernet and a fast ethernet port and finally a backup ISDN line. I am not going to use the ISDN.

I am trying to get start with some very basic activity which is enabling the Gigabit Ethernet (or the FE, I don't care). My plan was to either give it a static IP address or a DHCP address. A DHCP server is present.

The first issue is that the WAN ports don't seem to be accessible. If I connect either of the WAN ports and power up the device they don't seem to be enabled, sending out DHCP or the like etc.

So I changed strategy and connected one of the internal switch ports. That works. It apparently does an DHCP over the 8 port switch and it does get an IP and so I can use telnet to login to the device. I am missing some converter so I haven't been able to use the console port.

So when I log in into the device I do find the GE but I can't find the FE or the switch port.

cisco-ap#show interfaces summary

*: interface is up

IHQ: pkts in input hold queue     IQD: pkts dropped from input queue

OHQ: pkts in output hold queue    OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)

TRTL: throttle count

  Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

------------------------------------------------------------------------

* BVI1                     0     0    0     0  2000    2     0    0    0

  Dot11Radio0              0     0    0     0     0    0     0    0    0

  Dot11Radio1              0     0    0     0     0    0     0    0    0

* GigabitEthernet0         0     0    0     0  3000    3     0    0    0

So it seems that the GE interface is connected to the internal switch. Where are my wlan ports?

Any help is appreciated. Just to be sure I'll append the show interfaces output and the running config (which is the default config).

     Fred

If I ask for the a list of interfaces using the ? I get:

cisco-ap#show interfaces ?

  Async               Async interface

  BVI                 Bridge-Group Virtual Interface

  CDMA-Ix             CDMA Ix interface

  CTunnel             CTunnel interface

  Dialer              Dialer interface

  Dot11Radio          IEEE 802.11 WLAN

  GigabitEthernet     GigabitEthernet IEEE 802.3z

  Loopback            Loopback interface

  Multilink           Multilink-group interface

  Null                Null interface

  Tunnel              Tunnel interface

  Vif                 PGM Multicast Host interface

  Virtual-Dot11Radio  Virtual Dot11 Interface

  Virtual-PPP         Virtual PPP interface

  Virtual-Template    Virtual Template interface

  Virtual-TokenRing   Virtual TokenRing

  accounting          Show interface accounting

  counters            Show interface counters

  crb                 Show interface routing/bridging info

  dampening           Show interface dampening info

  description         Show interface description

  irb                 Show interface routing/bridging info

  mac-accounting      Show interface MAC accounting info

  mpls-exp            Show interface MPLS experimental accounting info

  precedence          Show interface precedence accounting info

  rate-limit          Show interface rate-limit info

  stats               Show interface packets & octets, in & out, by switching path

  summary             Show interface summary

  switching           Show interface switching

  |                   Output modifiers

  <cr>

The running config:

Current configuration : 2997 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco-ap

!

logging rate-limit console 9

enable secret 5 $1$cKpt$CwBHMRNrOKECVze4A5o66.

!

no aaa new-model

!

!

dot11 syslog

!

!

username cisco privilege 15 secret 5 $1$SGEn$qSAJ1dmxlz/GhYKMLjG4T.

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

banner exec ^CC

% Password change notice.

-----------------------------------------------------------------------

Default username/password setup on AP is cisco/cisco with privilege level 15.

It is strongly suggested that you create a new username with privilege level

15 using the following command for console security.

username <myuser> privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want to

use. After you change your username/password you can turn off this message

by configuring  "no banner login" and "no banner exec" in privileged mode.

-----------------------------------------------------------------------

^C

banner login ^CC

% Password change notice.

-----------------------------------------------------------------------

Default username/password setup on AP is cisco/cisco with privilege level 15.

It is strongly suggested that you create a new username with privilege level

15 using the following command for console security.

username <myuser> privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want to

use. After you change your username/password you can turn off this message

by configuring  "no banner login" and "no banner exec" in privileged mode.

-----------------------------------------------------------------------

^C

!

line con 0

privilege level 15

login local

no activation-character

line vty 0 4

login local

!

cns dhcp

end

15 REPLIES 15
Reza Sharifi
Hall of Fame Expert

I have never used this device before, but apparently the APs are embedded and don't have external interfaces.

Have a look at this config guide on how to configure them:

http://www.cisco.com/en/US/docs/routers/access/1900/software/configuration/guide/wlan.html

HTH

First of all thank you for your help. As I said in my introduction I am an absolute beginner, nevertheless I try to follow the guido you referenced.

I run into a couple of issues:

  • There is no wlan-ap0 interface. So I assume it has to be the Gigabit interface.
  • I assign an IP to that interface (Not pingable though)
  • Then while in config-if I cannot issue an interface command. It is not there.

I did notice I can create an interface named GigabitEthernet 0.1 if that helps.

If someone can spoonfeed me this, that would be highly appreciated.

   Fred

Can you post the output of

"sh version" and

"sh ip int brief"

cisco-ap#sh version

Cisco IOS Software, AP801 Software (AP801-K9W7-M), Version 12.4(25d)JA1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 11-Aug-11 02:29 by prod_rel_team

ROM: Bootstrap program is AP801 boot loader

BOOTLDR: AP801 Boot Loader (AP801-BOOT-M) Version 12.4(23c)JX, RELEASE SOFTWARE (fc1)

cisco-ap uptime is 11 hours, 10 minutes

System returned to ROM by power-on

System image file is "flash:/ap801-k9w7-mx.124-25d.JA1/ap801-k9w7-mx.124-25d.JA1"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco AP801AGN-E-K9        (PowerPC 8343) processor (revision B0) with 49142K/16384K bytes of memory.

Processor board ID FCZ1707C6Q0

PowerPC 8343 CPU at 400Mhz, revision number 0x0031

Last reset from power-on

1 Gigabit Ethernet interface

2 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 2C:54:2D:B9:D2:4C

Part Number                          : 73-11027-11

PCA Assembly Number                  : 800-28808-11

PCA Revision Number                  : C0

PCB Serial Number                    : FOC17016CTP

Top Assembly Part Number             : 800-29577-05

Top Assembly Serial Number           : FCZ1707C6Q0

Top Revision Number                   : C0

Product/Model Number                 : AP801AGN-E-K9

Configuration register is 0xF

cisco-ap#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       10.0.83.99      YES DHCP   up                    up

Dot11Radio0                unassigned      YES NVRAM  administratively down down

Dot11Radio1                unassigned      YES NVRAM  administratively down down

GigabitEthernet0           10.10.10.10     YES manual up                    up

Hi Fred,

You may try to configure 892 initially through CCP which is GUI oriented and get it working and then move to CLI if you are not comfortable with it yet.

More about CCP:

http://www.cisco.com/en/US/products/ps9422/index.html

http://www.cisco.com/en/US/prod/collateral/routers/ps9422/data_sheet_c78_462210.html

HTH,

Alex

Unfortunately I can't find it through the GUI either. I started with the GUI and then decided to move the CLI.

I even tried to install Install Express Pro (If I remember the name correctly). Once I tried to unpack the tar file from flash I got an error that a filename could not be longer than 40 chars. So halfway through the unpack failed.

So, you do have a Gig interface and it is in up and up mode.  In your previous post, you said you could not access the Gig interface, if so, how did you configure the IP address than (10.10.10.10)?

Sorry for the confusion. I added the IP address manually as part of the experimenting.

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

ip address 10.10.10.10 255.255.255.0

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

The issue is that although it says it is up, it can not be reached. Not from the inside or the outside.

Just to add to my own reply. So I don't know if this the somehow the inside (LAN switch) or the outside (GE). I ping it from both sides just to be sure.

Ok, so what is connected to this Gig interface right now?

I am *assuming* that the Gig interface is the Wan interface. I have connected the WAN inteface will a small switch (Am SG200). On the switch the Gig interface is *NOT* up.

Is the SG200 port also Gig?

If yes, on the 892 Gig interface can you delete this command and see if the interface comes up

no bridge-group 1

then

sh ip int bri

Yes the SG200 is 10/100/1000. I inserted it for that reason.

I cannot remove the bridge group:

cisco-ap(config-if)#no bridge-group 1

%command not allowed, cannot remove bridge-group 1

Thank you for the help so far. It will have to wait until tomorrow for futher updates.

In the config there is a section:

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

Does this mean that this logical interface takes the IP address from the GE interface? That IP (10.0.83.99) is on internal (LAN) side and not on the external (WAN) side. This is so confusing.

cisco-ap#sh ip in brief

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       10.0.83.99      YES DHCP   up                    up

Dot11Radio0                unassigned      YES NVRAM  administratively down down

Dot11Radio1                unassigned      YES NVRAM  administratively down down

GigabitEthernet0           10.10.10.10     YES manual up                    up

So where are the interfaces for the WAN GE or WAN FE interface?

    Fred