cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

4094
Views
0
Helpful
3
Replies
Highlighted

netflow and ip flow top talker in cisco 3560 switch-ios 15

hi ,

                 i am faiz ,i want to netflow in my cisco 3560 switch and ip flow top talker but i did configure netflow and ip flow top talker but its not working.

plz how to configre netflow to give inforation to my netflow manager and ip flow top talker .

                                                                                                                                                                             thank you

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 30    WS-C3560X-24       15.0(2)SE1            C3560E-UNIVERSALK9-M

3 REPLIES 3

netflow and ip flow top talker in cisco 3560 switch-ios 15

thanks for reply,

   i have heard that netflow support on latest ios version on 3560-x

Cisco Employee

netflow and ip flow top talker in cisco 3560 switch-ios 15

Agree,

I mis-read your post - did not notice you pointed HW version to be 3560-X.

This is detail config guide for it:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/15.0_2_se/configuration/guide/swmnetflow.html

Can you elaborate on  what are your current configs and what exactly not working ?

Nik

HTH,
Niko

netflow and ip flow top talker in cisco 3560 switch-ios 15

this is my configuration but no result,

MY REQUIRMENT IS I HAVE A TWO CISCO 3560 SWITCH WHICH IS RUNNING HSRP AND EIGRP

I need a all vlan 1 devices and users ,if they go to anyware out of lan to interface g1/4 ,they should have a record.

i can able to ping my netflow server and all units getting but except it

Current configuration : 5693 bytes

!

! Last configuration change at 12:15:59 UTC Thu Jun 13 2013

! NVRAM config last updated at 12:16:00 UTC Thu Jun 13 2013

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3560-X-TATA

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$noPD$12H1OP44QVk6Aj9E7jxbB0

!

username cisco privilege 15 password 0 cisc

no aaa new-model

clock timezone UTC 5 30

system mtu routing 1500

flow record lab1

match datalink dot1q priority

match datalink mac source-address

match datalink mac destination-address

match ipv4 tos

match ipv4 protocol

match ipv4 destination address

match transport source-port

match transport destination-port

collect interface input snmp

collect interface output snmp

collect counter flows

collect counter bytes

collect counter packets

collect timestamp sys-uptime first

collect timestamp sys-uptime last

!

!

!

flow exporter netflowserver

description corpor@teserver

destination 10.10.17.166

source Vlan1

dscp 3

transport udp 9996

!

!

flow monitor FLOW-MONITOR-1

record lab1

exporter netflowserver

cache timeout active 300

!

ip routing

!

interface GigabitEthernet1/4

description COPD_TATA_100MPBS

no switchport

ip flow ingress

ip flow egress

ip flow monitor FLOW-MONITOR-1 input

ip address 192.168.2.14 255.255.255.252

!

interface Vlan1

ip flow ingress

ip flow egress

ip flow monitor FLOW-MONITOR-1 input

ip address 10.10.50.53 255.255.252.0

standby 10 ip 10.10.50.51

standby 10 priority 200

standby 10 preempt

standby 10 track 1 decrement 150

!

router eigrp 500

network 10.10.48.0 0.0.3.255

network 192.168.2.12 0.0.0.3

eigrp stub connected summary

!

ip default-gateway 10.10.50.52

ip http server

ip http secure-server

ip flow-export source Vlan1

ip flow-export destination 10.10.17.166 9996

!

ip route 0.0.0.0 0.0.0.0 192.168.2.13

snmp-server community public RO

snmp-server community netflow RW

snmp ifmib ifindex persist

end

3560-X-TATA#show flow record

flow record lab1:

  Description:        User defined

  No. of users:       1

  Total field space:  51 bytes

  Fields:

    match datalink dot1q priority

    match datalink mac source-address

    match datalink mac destination-addre

    match ipv4 tos

    match ipv4 protocol

    match ipv4 destination address

    match transport source-port

    match transport destination-port

    collect interface input snmp

    collect interface output snmp

    collect counter flows

    collect counter bytes

    collect counter packets

    collect timestamp sys-uptime first

    collect timestamp sys-uptime last

3560-X-TATA#show flow monitor FLOW-MONITOR-1

Flow Monitor FLOW-MONITOR-1:

  Description:       User defined

  Flow Record:       lab1

  Flow Exporter:     netflowserver

  Cache:

    Type:              normal

    Status:            allocated

    Size:              128 entries / 9732 bytes

  Cache:

    Type:              normal (Platform cache)

    Status:            allocated

    Size:              Unknown

  Timers:

                       Local        Global

    Inactive Timeout:  15 secs

    Active Timeout:    300 secs     1800 secs

    Update Timeout:    1800 secs

CreatePlease to create content
Content for Community-Ad