cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
630
Views
0
Helpful
3
Replies
Henry_H15966
Beginner

Network disasbled because of bpduguard error detececd

We have an identical problem with 6 new servers. The first network card of the server (connected to the Cisco WS-C2960X-48LPS-L) will be disabled with the message: 

SPANTREE-2-BLOCK_BPDUGUARD: Received BPDU on port GigabitEthernet1/0/9 with BPDU Guard enabled. Disabling port.

 

Attached is the logfile. Is there maybe a configuration problem of the Intel Network card from the server?

The server is running Linux CentOS.

Any help is welcome.

 

3 REPLIES 3
Jaderson Pessoa
Engager

Helo my friend,

 

The problem seems to be simple:  Does it servers running virtual machines or virtualizing any swtich? Because your switch is protected with BPDUGUARD then if an interface in ACCESS MODE receive a bpdu, it will be put in ERRDISABLE.

 

You can add the command under interface or in global mode

 

interface

no spanning-tree portfast bpduguad enable (will remove from only interface that you choice)

 

Global Mode

no spanning-tree portfast bpduguard   << will rmeove bpdu guard from all interface ( not recommended)

 

Second alternative is to swtich from ACCESS MODE to TRUNK MODE the interface that encounter the problem.

 

 

Jaderson Pessoa
*** Rate All Helpful Responses ***
Deepak Kumar
Advocate

Hi,

I think, there is a vSwitch in the host os such as VMware or HyperV. This vSwitch is sending BPDU and it is normal.

 

Here are two solutions for you:

1. Disable BPDU guard on the interface level and it is recommended way.

2. Disable STP on the Server's vSwitch.

 

There are third options and it is not recommended anyway so I am not going to mention here.

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!
Vishnu Vardhan S
Beginner

As you are getting the BPDU on port 1/0/9 its obvious that BPDU guard has been enabled and this port is receiving the BPDU's from the vSwitch running inside the server. 

 

If you are ok to disable the BPDU guard in the port then use below command : 

 

S1(config-if)#no spanning-tree guard

 

OR

 

If its ok to disable STP in your vSwitch then you can do that. 

 

https://kb.vmware.com/s/article/2047822

Please do not hesitate to click the STAR button if you are satisfied with my answer.