cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1679
Views
5
Helpful
5
Replies
Beginner

Network QoS MTU on Nexus 93180YC-EX

Hello, Community! Back in the early days of Nexus 5k and vPC, we had to create a custom network-qos policy to enable jumbo frame support. Times change (often for the better) and the Nx93180 has the system jumbomtu set to 9216 by default, and the vPC Peer-link MTU is automatically set to 9216... very nice. However, here is my question... When I run the "show vpc consistancy-parameters global", I see the following:

Name                            Local Value                    Peer Value

Network QoS (MTU)       (1500,1500,1500,         (1500,1500,1500,

                                       1500,1500,1500)          1500,1500,1500)

(full output attached)

So... is this a problem?? Documentation seems to only address MTU on the physical ports (I likely need to bump it up on selected ports), but nothing about the Network QoS setting I see here.

Thanks in advance for any advise you may have.

Mike

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Expert

Re: Network QoS MTU on Nexus 93180YC-EX

Hi,

You still need a policy to change that.

here is one that should do it for you:

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

HTH

5 REPLIES 5
VIP Mentor

Re: Network QoS MTU on Nexus 93180YC-EX

Hello,

 

I have looked all over the place but could not find anything either on the default Network QoS MTU setting having changed, so I think you still need to set it manually.

VIP Expert

Re: Network QoS MTU on Nexus 93180YC-EX

Hi,

You still need a policy to change that.

here is one that should do it for you:

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

HTH

Beginner

Re: Network QoS MTU on Nexus 93180YC-EX

Reza Sharifi

Thank you very much... I applied the suggested policy (which is essentially what we would do on a Nx5k) and I'm seeing the expected results.

 

Many thanks to all who responded!

Mike

VIP Expert

Re: Network QoS MTU on Nexus 93180YC-EX

Glad to help Mike.

Good Luck!

Reza

Highlighted
Beginner

Re: Network QoS MTU on Nexus 93180YC-EX

I have the commands you mentioned in place and all is good for all non FEX ports.

The FEX trunk itself shows Jumbo frames are enabled BUT I can't 

version 7.0(3)I7(2) 

policy-map type network-qos jumbo
  class type network-qos class-default
  mtu 9216

system qos
  service-policy type network-qos jumbo
policy-map type control-plane copp-system-policy-customized
copp profile strict

 

We are running NX-OS with a pair of 93180LC at our core and 2 pair of 93180YC at our Access layer.  The YC's connect to 2248 FEX pairs with MTU set to 9216 on the FEX port-channels.

 

When I try to create a Jumbo enable port-channels on FEX port connected devices I get no love. Is there a limitation to enabling Jumbo frames on FEX connected devices?

The PO interface shows 9216 but the vpc consistency-parameters interface port-channel121 command is still showing MTU 1500.

 

Seems similar to this 7k bug

https://quickview.cloudapps.cisco.com/quickview/bug/CSCvf03156

 

interface port-channel121
description SUNVM2-NAS
switchport
switchport mode trunk
switchport trunk native vlan 4
switchport trunk allowed vlan 4
flowcontrol send on
mtu 9216
vpc 121

DF-RW1-C93180Y-DSwc-A1(config-if)# channel-group 121 force mode passive
command failed: port not compatible:[MTU]
** You can use force option to override the port's parameters
** (e.g. "channel-group X force")
** Use "show port-channel compatibility-parameters" to get more information on failure

DF-RW1-C93180Y-DSwc-A1(config-if)# 2018 Apr 3 21:33:55 DF-RW1-C93180Y-DSwc-A1 last message repeated 1 time

DF-RW1-C93180Y-DSwc-A1(config-if)# sh run interface Ethernet113/1/30

!Command: show running-config interface Ethernet113/1/30
!Time: Tue Apr 3 21:34:08 2018

version 7.0(3)I7(2)

interface Ethernet113/1/30
description SUNVM2-NAS
switchport mode trunk
switchport trunk native vlan 4
switchport trunk allowed vlan 4

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards