cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

354
Views
5
Helpful
15
Replies
Beginner

Newbie setting up 3650

Hi all

 

Sorry if this is a really simple question, but i will have limited time with my new equipment to test before i must deploy.

 

I will be setting up 2 x WS-C3650-24TD-S switches with a very basic configuration. A single VLAN needs to span across the two switches (using a fiber trunk link), but i am not certain how to set this up...

 

After digging around i have seen mention that by default VLAN info is shared over the trunk link, but I assume some setup will be required on the 'slave' switch? I have read a bit about VTP, but not certain this is required for my basic setup?

 

The only other things i will need to configure to run on my VLAN (not sure if this is relevant) are:

  1. Local igmp v2, Local igmp snooping, Local igmp snooping querier,
  2. Local DHCP address pool
  3. Range of static addresses

 

Thank you for any help, and sorry if i sound a little naive - I am!

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: Newbie setting up 3650

Jimbob,

 

Yes, you do need to exclude the addresses that you want to use as static ones. This is done by the command I included in the DHCP bit

ip dhcp excluded-address 192.168.100.1 192.168.100.10

 

This command excludes first 10 IP addresses from your DHCP pool. You can specify a wider range if you need more room for statics.

 

15 REPLIES 15
Highlighted
Contributor

Re: Newbie setting up 3650

It sounds like you are not going to stack these using the stack module and cables plugged into the back of the 3650, correct? 

For basic connectivity, you can plug port 24 into port 24 and it should link up and form at least an access port on VLAN 1.  MDIX auto allows a straight through cable to be used and you shouldn't have any issue.  If you plug a device into a port without configuring it, it should become an access port on vlan 1. Switches are pretty nice when you are not adding a lot of additional configuration.

You can change the default settings such as below.

conf t

vtp mode transparent

int gi1/0/24

switchport mode trunk

int range gi1/0 - 23

switchport mode access

 

 

 

 

 

Rising star

Re: Newbie setting up 3650

Jumbo1986,

to keep your life simple, just configure the trunk ports statically. Here are the commands you need:
interface X/X
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

Then you need to configure your VLAN (I presume that you are not doing it with a default VLAN 1).

on both switches:
VLAN xxx
name SOMENAME

where xxx is the VLAN number other than 1.

That is enough to configure VLAN and trunking between two switches. Then you can start adding your access ports into the newly created VLAN

interface x/x
switchport mode access
switchport nonegotiate
switchport access vlan xxx

that's' it.

Beginner

Re: Newbie setting up 3650

Great that appears to have done the trick.

I am however having problems setting up my DHCP range.

 

Here are the details of my DHCP setup:

 

Pool Nodes :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Excluded addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased/Excluded/Total
192.168.100.1 192.168.100.1 - 192.168.100.254 0 / 0 / 254

Pool nodes :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 0
Leased addresses : 0
Excluded addresses : 0
Pending event : none

 

When I connect my laptop to the switch:

 

*Feb 22 17:06:53.680: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/9, changed state to up

 

BUT, my pc (set to DHCP) fails to get and IP address....

 

tearing my hair out with this one.

Rising star

Re: Newbie setting up 3650

If you are trying to configure it on your switch, then you need to have an interface that belong to that network.

So, if you add on the switch

interface vlan x

ip address 192.168.100.1 255.255.255.0

ip dhcp excluded-address 192.168.100.1 192.168.100.10

 

it should work. 

Beginner

Re: Newbie setting up 3650

Great, thankyou another I can tick off.

 

However, my trunk looks fine, should I be seeing the other 24 ports when I show VLAN? I can only see 24 ports, from sw, as shown below.

 

And ports on sw2 don't provide any DHCP addresses.

I mirrored the setup of the trunk link on sw2, should a DHCP with the same info be added on sw2 also? I assumed it would take this info form sw1.

 

 

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/1/1, Gi1/1/2, Te1/1/4
100 phoenix active Gi1/0/1, Gi1/0/2, Gi1/0/3
Gi1/0/4, Gi1/0/5, Gi1/0/6
Gi1/0/7, Gi1/0/8, Gi1/0/9
Gi1/0/10, Gi1/0/11, Gi1/0/12
Gi1/0/13, Gi1/0/14, Gi1/0/15
Gi1/0/16, Gi1/0/17, Gi1/0/18
Gi1/0/19, Gi1/0/20, Gi1/0/21
Gi1/0/22, Gi1/0/23, Gi1/0/24
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

 

-----------------------------------

 

Switch1#show run int te1/1/3
Building configuration...

Current configuration : 116 bytes
!
interface TenGigabitEthernet1/1/3
switchport access vlan 100
switchport mode trunk
switchport nonegotiate
end

Switch1#

 

 

 

Rising star

Re: Newbie setting up 3650

You only need a DHCP scope on one switch. But your trunk doesn't seem to be trunking. Can you show the output of "show interface trunk" command and also "show span vlan 100"
Beginner

Re: Newbie setting up 3650


Switch1#show interface trunk

Port Mode Encapsulation Status Native vlan
Te1/1/3 on 802.1q trunking 100

Port Vlans allowed on trunk
Te1/1/3 100

Port Vlans allowed and active in management domain
Te1/1/3 100

Port Vlans in spanning tree forwarding state and not pruned

 

--------------------------------------------------------------

 

VLAN0100
Spanning tree enabled protocol rstp
Root ID Priority 32868
Address 706d.15ec.9900
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address 706d.15ec.9900
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/3 Desg FWD 2 128.27 P2p


Switch1#


Te1/1/3 100

Beginner

Re: Newbie setting up 3650

And this is how Switch2 looks:

Switch2#show interface trunk
Port Mode Encapsulation Status Native vlan
Te1/1/3 on 802.1q trunking 100
Port Vlans allowed on trunk
Te1/1/3 100
Port Vlans allowed and active in management domain
Te1/1/3 100
Port Vlans in spanning tree forwarding state and not pruned
Te1/1/3 100
Switch2#

-----------------------------------------------------------

Switch2#show span vlan 100

VLAN0100
Spanning tree enabled protocol rstp
Root ID Priority 32868
Address 706d.15ec.9900
Cost 2
Port 27 (TenGigabitEthernet1/1/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address f80f.6f7a.8d00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/3 Root FWD 2 128.27 P2p



Rising star

Re: Newbie setting up 3650

Yes, all looks good, so should work as expected. As long as your access port on the other switch is in the correct VLAN. Just check the MAC address table for VLAN 100 on both switches.
Rising star

Re: Newbie setting up 3650

OK, looks like the trunk is healthy on switch1. What about switch2?
Beginner

Re: Newbie setting up 3650

SW2 above...

Also seeing this on Switch1

*Feb 22 21:12:00.070: %IP-4-DUPADDR: Duplicate address 192.168.100.1 on Vlan100, sourced by f80f.6f7a.8d51
Rising star

Re: Newbie setting up 3650

Have you configured the same address on VLAN 100 interface on both switches? If so, then you need to change one. Make the other one 192.168.100.2
Beginner

Re: Newbie setting up 3650

ok, done.

No IP conflicts being flagged. But still doesn't seem to work...
Cannot ping devices on either switch.


Switch1#show mac address-table
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- -----
All 0100.0ccc.cccc STATIC CPU
All 0100.0ccc.cccd STATIC CPU
All 0180.c200.0000 STATIC CPU
All 0180.c200.0001 STATIC CPU
All 0180.c200.0002 STATIC CPU
All 0180.c200.0003 STATIC CPU
All 0180.c200.0004 STATIC CPU
All 0180.c200.0005 STATIC CPU
All 0180.c200.0006 STATIC CPU
All 0180.c200.0007 STATIC CPU
All 0180.c200.0008 STATIC CPU
All 0180.c200.0009 STATIC CPU
All 0180.c200.000a STATIC CPU
All 0180.c200.000b STATIC CPU
All 0180.c200.000c STATIC CPU
All 0180.c200.000d STATIC CPU
All 0180.c200.000e STATIC CPU
All 0180.c200.000f STATIC CPU
All 0180.c200.0010 STATIC CPU
All 0180.c200.0021 STATIC CPU
All ffff.ffff.ffff STATIC CPU
1 706d.15ec.9947 STATIC Vl1
100 6cf0.490a.d85b DYNAMIC Gi1/0/14
100 706d.15ec.9951 STATIC Vl100
100 e4b9.7a09.10cb DYNAMIC Gi1/0/10
100 f80f.6f7a.8d1b DYNAMIC Te1/1/3
100 f80f.6f7a.8d51 DYNAMIC Te1/1/3
Total Mac Addresses for this criterion: 27

--------------------------------------------------------------------


Switch2#show mac address-table
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- -----
All 0100.0ccc.cccc STATIC CPU
All 0100.0ccc.cccd STATIC CPU
All 0180.c200.0000 STATIC CPU
All 0180.c200.0001 STATIC CPU
All 0180.c200.0002 STATIC CPU
All 0180.c200.0003 STATIC CPU
All 0180.c200.0004 STATIC CPU
All 0180.c200.0005 STATIC CPU
All 0180.c200.0006 STATIC CPU
All 0180.c200.0007 STATIC CPU
All 0180.c200.0008 STATIC CPU
All 0180.c200.0009 STATIC CPU
All 0180.c200.000a STATIC CPU
All 0180.c200.000b STATIC CPU
All 0180.c200.000c STATIC CPU
All 0180.c200.000d STATIC CPU
All 0180.c200.000e STATIC CPU
All 0180.c200.000f STATIC CPU
All 0180.c200.0010 STATIC CPU
All 0180.c200.0021 STATIC CPU
All ffff.ffff.ffff STATIC CPU
1 f80f.6f7a.8d47 STATIC Vl1
100 6cf0.490a.d85b DYNAMIC Te1/1/3
100 706d.15ec.991b DYNAMIC Te1/1/3
100 706d.15ec.9951 DYNAMIC Te1/1/3
100 e4b9.7a09.10cb DYNAMIC Gi1/0/8
100 f80f.6f7a.8d51 STATIC Vl100
Total Mac Addresses for this criterion: 27


Beginner

Re: Newbie setting up 3650

Massive thank you for your help Sergey, I owe you a beer

 

Ok, I have since checked and a firewall was blocking a Ping command. Sw1 now working fine. 

 

I then allowed switchport mode access on Sw2 and it appears it is supplying IP addresses and I can reach hosts over the trunk!

 

Probably went round and round on this so sorry, and thank you so far for your help.

 

One last question:

Do I need to remove a range from my DHCP pool that I will be using for Hosts that I want as part of my VLAN 100, but I want to specify static addresses on these hosts?

 

I did a test and the switch seems fine providing static IPs requested by the Host that are within my DHCP pool range. I want to get this right!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards