cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
764
Views
0
Helpful
12
Replies

newby DNS problem

ministryofchaoz
Level 1
Level 1

I can ping everything from the router, but the machines in 172.16.x.x can only ping as far as 192.168.1.1; nothing on the internet.Help!

version 12.2

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable password xxx

!

ip subnet-zero

!

!

ip name-server 192.168.1.1

!

ip dhcp pool 1

network 172.16.1.0 255.255.255.0

default-router 172.16.1.200

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description connected to EthernetLAN

ip address dhcp

ip helper-address 192.168.1.1

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

interface FastEthernet0/1

description connected to FastHub412

ip address 172.16.1.200 255.255.255.0

ip nat inside

duplex auto

speed auto

!

router rip

version 2

network 172.16.0.0

network 192.168.1.0

no auto-summary

!

ip classless

no ip http server

!

snmp-server community public RO

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

banner motd ^CWelcome to cisco 2621^C

!

line con 0

exec-timeout 0 0

password 7 <omited>

login

line aux 0

line vty 0 4

password 7 <omited>

login

!

end

12 Replies 12

brianj
Level 1
Level 1

I don't see a default gateway or gateway of last resort set. When you do a 'show ip route' do you have a default route listed in the routing table?

RIP is routing for the 172.16.0.0 and 192.168.1.0 networks.

Brian

this is all I get but still I dont know how to configure a default gateway or gateway of last resort. is this ok RIP is routing for the 172.16.0.0 and 192.168.1.0 networks. I think I need a good tutorial can you point one out. I'm not very familiar with cisco.

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.1.0 is directly connected, FastEthernet0/1

C 192.168.1.0/24 is directly connected, FastEthernet0/0

S* 0.0.0.0/0 [254/0] via 192.168.1.1

Router#

What device has the 192.168.1.1 address assigned to it? The routing table has a default route S* 0.0.0.0/0 via 192.168.1.1

It should point to the next hop routers interface. This is the router which belongs to your ISP.

The command is ip route 0.0.0.0 0.0.0.0 [interface] or ip-of-next-hop-router

Brian

ok check the mess out; I got a terayon 715t from the cable company which usually asigns ip<24.51.205.x> subnet 255.255.255.192 and default gateway 24.51.204.1.; this goes to a linksys etherfast cable/dsl router which has the ip<192.168.1.1>subnet 255.255.255.0 and the WAN conection is set to receive it's ip through DHCP from the terayon. Now, from the lynksys I got a line that goes to fastethernet 0/1 which has 192.168.1.200 and the one that goes to a hub 172.16.1.200-------->machines. what a mess! I know there are easier ways on doing it but I just wanted to try this out and I know it has to work...somehow. What I dont get is that if the linksys is doing all the work ( and from the router I can ping everything in the local lan form 192.168.x.x to 172.16.1.x ) why in the hell cant I ping DNS's, yesterday I noticed that I can ping anything on the net as long as it is an ip. I know I'm missing a dns-server or a gateway I just dont know how to configure it or what commands to use in the router. It also has a T1 wic but I dont even want to mess with that; at least not for now.

OK... the picture is getting more clear. Have you connected to the linksys device (usually through a web browser) to ensure it is getting dns server settings correctly through DHCP? Usually you can send a ping from the linksys device. After you verify the dns on the linksys, try pinging a fqdn from the linksys.

Brian

I got it working, but now I want to try it with the T1 dsu wic. The only thing missing was the dns-server in the dhcp pool 1. If you can help with the T1 card I'll appreciate it. I'll understand if you dont; but thank you very, very, very much for the help anyway. I still think theres got to be an easier way. this is the config:

! ******************************************************************

! Router.cfg - Cisco router configuration file

! created by Amalfy Vargas

! Friday, December 31, 2004, 04:53:42 PM

!

! Hostname: Router

! Model: 2621

! ******************************************************************

!

version 12.2

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable password xxx

!

ip subnet-zero

!

!

ip name-server 192.168.1.1

!

ip dhcp pool 1

network 172.16.1.0 255.255.255.0

default-router 172.16.1.200

dns-server 68.168.0.2

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description connected to EthernetLAN

ip address dhcp

ip helper-address 192.168.1.1

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

interface FastEthernet0/1

description connected to FastHub412

ip address 172.16.1.200 255.255.255.0

ip nat inside

duplex auto

speed auto

!

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

snmp-server community public RO

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

banner motd ^CWelcome to cisco 2621^C

!

line con 0

exec-timeout 0 0

password xxx

login

line aux 0

line vty 0 4

password xxx

login

!

end

Sorry... I don't know why I didn't pick up on the fact that you are using the 2621 for DHCP and the clients didn't have a dns server configured. I guess I just assumed (wrong thing to do) that the clients were pointing to a valid dns server.

Anyway, on to the T1 WIC. You should have gotten information from your service provider that you will need to configure the DSU. If this is simply a point to point T1 the configuration on the serial interface is fairly straight forward. The default encapsulation on the serial interface is HDLC. Assuming both ends are cisco, you should simply need to assign an IP and perform a no shut on the interface at each end.

The DSU configuration will need the following at a minimum:

service-module t1 clock source line

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 timeslots all speed 64

service-module t1 data-coding normal

The framing and linecode information should have been provided by the service provider. The "timeslots all" command says use all 24 timeslots (T1 1.544megs). If it is not a full T you will need to supply the correct number of timeslots.

There are several other optional commands that can be issued to assist with troubleshooting.

Check out these links:

This one is very good!

http://www.cisco.com/en/US/products/hw/routers/ps233/products_tech_note09186a0080093c56.shtml

http://www.cisco.com/en/US/products/sw/iosswrel/ps5012/products_feature_guide09186a0080194a32.html#wp1025039

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/hw_inst/wic_inst/wic_doc/conntwan.htm#xtocid260022

Example:

Interface serial 0/0

service-module t1 clock source internal

service-module t1 timeslots 1-24 speed 64

service-module t1 framing esf

service-module t1 linecode b8zs

ip address 10.1.1.1 255.255.255.0

encapsulation ppp

no shut

(Notice he has configured ppp as the encapsulation rather than using the default HDLC)

what if I wanted to connect the ethernet cable that comes from the terayon to the T1 card?. Can it be done?.

No, you would need an ethernet interface rather than a serial interface. The T1 WIC can only be used with another serial interface.

Brian

why?. Its a line with a IP, subnet and default gateway. I dont see why it wouldn't work. Sorry for being so stubborn. but if there can't be a way I would appreciate knowing why?. :)

check this:

version 12.2

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable password xxxx

!

ip subnet-zero

!

!

no ip name-server

!

ip dhcp pool 1

network 172.16.1.0 255.255.255.0

default-router 172.16.1.200

dns-server 68.168.0.2

ip dhcp pool 2

network 192.168.1.0 255.255.255.0

default-router 192.168.1.100

dns-server 68.168.0.2

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description connected to FastHub412(1)

ip address 192.168.1.100 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

description connected to FastHub412(2)

ip address 172.16.1.200 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial 0/0

no shutdown

description connected to Internet

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 remote-loopback full

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 lbo none

service-module t1 remote-alarm-enable

ip address negotiated

ip nat outside

encapsulation ppp

!

! Dynamic NAT

ip nat translation timeout 86400

ip nat translation tcp-timeout 86400

ip nat translation udp-timeout 300

ip nat translation dns-timeout 60

ip nat translation finrst-timeout 60

ip nat inside source list 1 interface Serial 0/0 overload

!

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

!

ip classless

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Serial 0/0

no ip http server

!

snmp-server community public RO

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

banner motd ^CWelcome to cisco 2621^C

!

line con 0

exec-timeout 0 0

password xxxx

login

line aux 0

line vty 0 4

password xxxx

login

!

end

Ethernet uses different protocols than does serial communication, and unlike serial devices Ethernet devices are used to move data not acquire it. Serial devices need a clocking source. The list goes on and on.

Brian

Review Cisco Networking products for a $25 gift card