cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
3430
Views
0
Helpful
8
Replies
Highlighted
Beginner

Nexus 4000

We have Hardware:

  cisco Nexus 4000 Chassis ("20x10GE/supervisor")

  Motorola, e500v2  with 2076512 kB of memory.

  Processor Board ID JAF1513AGCA

From the Cisco Nexus 4001I and 4005I Switch Module for IBM BladeCenter NX-OS Configuration Guide I entered:

conf t

class-map type network-qos class1

  match cos 4

exit

policy-map type network-qos jumbo

  class type network-qos class1

    mtu 9000

exit

exit

system qos

  service-policy type network-qos jumbo

ERROR: network-qos Policy-map jumbo has no match on CoS 0

I did a write erase to take it back to factory defaults and get the same error. In the end I am trying to get all of the Interfaces set to 9000 mtu. Any assistance is appreciated. Thank you for your time.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Nexus 4000

Okay, I see the problem. In your current configuration, there is a network qos policy attached to the system qos config:

system qos

  service-policy type queuing output default-out-policy

  service-policy type network-qos p-nq-8e

In order to configure jumbo frame, you need to change the MTU value in the current policy-map p-nq-8e, or if you want to use a customize network qos policy, you can remove p-nq-8e first and attach a new network qos policy. To simplify it here, use the following commands to change the current network (p-nq-8e) qos's MTU value:

policy-map type network-qos p-nq-8e

  class type network-qos c-nq-8e

     mtu 9000

HTH,

jerry

View solution in original post

8 REPLIES 8
Highlighted
Cisco Employee

Nexus 4000

Can you post all the configuration of class-map, policy-map and system qos?

Regards,

jerry

Highlighted
Beginner

Re: Nexus 4000

I have attached the sho class-map and policy-map, sho system qos is not option, so I am not sure how to get that information. This is factory default as far as I know, with exception of the attempt to get interface to 9000 MTU and the IP address. Thank you very much for your time.

Highlighted
Beginner

Nexus 4000

Tried class-default as well, not luck.

policy-map type network-qos jumbo

hchassis(config-pmap-nq)# class type network-qos class-default

ERROR: Class-map class-default of type network-qos not configured

Highlighted
Cisco Employee

Re: Nexus 4000

Can you get me the output of show running all?

Highlighted
Beginner

Re: Nexus 4000

Thank you

hchassis# sho running all

version 4.1(2)E1(1f)

license grace-period

feature telnet

feature ssh

username admin password 5 !  role network-admin

username USERID password 5 $1$T9bjZYiV$uO5C8x9brdZBp6W0wPCvb1  role network-admin

password strength-check

banner motd # Nexus 4000 Switch #

ssh key rsa 1024

no ssh key dsa

ip domain-lookup

ip host hchassis 192.168.1.29

radius-server timeout 5

radius-server retransmit 1

radius-server deadtime 0

no ip radius source-interface

aaa group server radius radius

    deadtime 0

    use-vrf default

    no source-interface

switchname hchassis

no vlan dot1Q tag native

no system default switchport

system default switchport shutdown

system jumbomtu 9216

no logging event link-status default

no logging event trunk-status default

logging event link-status enable

logging event trunk-status enable

errdisable recovery interval 300

errdisable detect cause link-flap

no errdisable recovery cause link-flap

no errdisable recovery cause udld

no errdisable recovery cause bpduguard

errdisable detect cause loopback

no errdisable recovery cause storm-control

no errdisable recovery cause security-violation

no errdisable recovery cause psecure-violation

no errdisable recovery cause vpc-peerlink

no errdisable recovery cause failed-port-state

system jumbomtu 9216

class-map type qos match-all class-default

class-map type queuing match-any 1p7q4t-out-pq1

  match cos 1

class-map type queuing match-any 1p7q4t-out-q2

  match cos 2

class-map type queuing match-any 1p7q4t-out-q3

  match cos 0

class-map type queuing match-any 1p7q4t-out-q4

  match cos 4

class-map type queuing match-any 1p7q4t-out-q5

  match cos 5

class-map type queuing match-any 1p7q4t-out-q6

  match cos 6

class-map type queuing match-any 1p7q4t-out-q7

  match cos 7

class-map type queuing match-any 1p7q4t-out-q-default

  match cos 3

class-map type network-qos class1

  match cos 4

class-map type network-qos c-nq-8e

  match cos 0-7

class-map type network-qos c-nq-5e-drop

  match cos 0,4-7

class-map type network-qos c-nq-6e-drop

  match cos 0,2,4-7

class-map type network-qos c-nq-5e-ndrop

  match cos 1-3

class-map type network-qos c-nq-6e-ndrop

  match cos 1,3

policy-map type network-qos jumbo

  class type network-qos class1

    mtu 9216

policy-map type network-qos p-nq-5e

  class type network-qos c-nq-5e-drop

  class type network-qos c-nq-5e-ndrop

    pause no-drop

    mtu 2240

policy-map type network-qos p-nq-6e

  class type network-qos c-nq-6e-drop

  class type network-qos c-nq-6e-ndrop

    pause no-drop

    mtu 2240

policy-map type network-qos p-nq-8e

  class type network-qos c-nq-8e

system qos

  service-policy type queuing output default-out-policy

  service-policy type network-qos p-nq-8e

snmp-server aaa-user cache-timeout 3600

snmp-server protocol enable

no snmp-server globalEnforcePriv

snmp-server tcp-session auth

snmp-server user USERID network-admin auth md5 0x8459c266c6277f13a63c22a1d1787018 priv 0x8459c266c6277f13a63c22a1d1787018 loc

alizedkey

no snmp-server enable traps link

snmp-server enable traps license

no snmp-server enable traps aaa server-state-change

no snmp-server enable traps snmp authentication

snmp-server enable traps link standard-extended

callhome

  switch-priority 7

  destination-profile CiscoTAC-1

  destination-profile CiscoTAC-1 format XML

  destination-profile CiscoTAC-1 message-size 5000000

  destination-profile CiscoTAC-1 message-level 0

  destination-profile full_txt

  destination-profile full_txt format full-txt

  destination-profile full_txt message-size 2500000

  destination-profile full_txt message-level 0

  destination-profile short_txt

  destination-profile short_txt format short-txt

  destination-profile short_txt message-size 4000

  destination-profile short_txt message-level 0

  destination-profile CiscoTAC-1 alert-group cisco-tac

  destination-profile full_txt alert-group all

  destination-profile short_txt alert-group all

  no enable

  duplicate-message throttle

  periodic-inventory notification

  periodic-inventory notification interval  7

  periodic-inventory notification timeofday 08:00

aaa authentication login default local

aaa accounting default local

aaa user default-role

no aaa authentication login error-enable

no aaa authentication login mschap enable

no aaa authentication login ascii-authentication

no radius-server directed-request

vrf context management

vlan 1

  no cin

cdp advertise v2

cdp enable

cdp holdtime 180

cdp timer 60

cdp format device-id system-name

spanning-tree mode rapid-pvst

spanning-tree pathcost method short

no spanning-tree port type edge default

no spanning-tree port type network default

spanning-tree bridge assurance

no spanning-tree loopguard default

spanning-tree vlan 1

spanning-tree vlan 1 priority 32768

spanning-tree vlan 1 hello-time 2

spanning-tree vlan 1 forward-time 15

spanning-tree vlan 1 max-age 20

platform access-list update atomic

no platform access-list update default-result permit

platform rate-limit layer-3 mtu 500

platform rate-limit layer-3 ttl 500

platform rate-limit layer-3 control 10000

platform rate-limit layer-3 glean 100

platform rate-limit layer-3 multicast directly-connected 10000

platform rate-limit layer-3 multicast local-groups 10000

platform rate-limit layer-3 multicast rpf-leak 500

platform rate-limit layer-2 storm-control 0

platform rate-limit access-list-log 100

platform rate-limit copy 30000

platform rate-limit receive 30000

platform ip verify address source broadcast

platform ip verify address source multicast

platform ip verify address destination zero

platform ip verify address identical

platform ip verify address source reserved

platform ip verify checksum

platform ip verify protocol

platform ip verify fragment

platform ip verify length minimum

platform ip verify length consistent

platform ip verify length maximum max-frag

platform ip verify length maximum udp

platform ip verify length maximum max-tcp

platform ip verify tcp tiny-frag

platform ip verify version

platform ipv6 verify length consistent

platform ipv6 verify length maximum max-frag

platform ipv6 verify length maximum udp

platform ipv6 verify length maximum max-tcp

platform ipv6 verify tcp tiny-frag

platform ipv6 verify version

port-channel load-balance ethernet source-dest-ip

port-channel load-balance ethernet source-dest-ip module 1

interface Ethernet1/1

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/2

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/3

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/4

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/5

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/6

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/7

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/8

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/9

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/10

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/11

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/12

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/13

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/14

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/15

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/16

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/17

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/18

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/19

  no description

switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/20

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface mgmt0

  description

  speed auto

  duplex auto

  no shutdown

  cdp enable

  ip address 172.16.1.29/24

  ip redirects

  ip port-unreachable

  ip arp gratuitous update

  ip arp gratuitous request

interface mgmt1

  description

  speed auto

  duplex auto

  no shutdown

  cdp enable

line console

  no exec-timeout

  terminal length 24

  terminal width 80

line vty

  session-limit 16

  no exec-timeout

boot kickstart bootflash:/n4000-bk9-kickstart.4.1.2.E1.1f.bin

boot system bootflash:/n4000-bk9.4.1.2.E1.1f.bin

system health loopback frequency 60

system clis event-history ha size medium

ip igmp snooping

ip igmp snooping report-suppression

ip igmp snooping link-local-groups-suppression

ip igmp snooping event-history vlan size medium

ip igmp snooping event-history vlan-events size medium

ip igmp snooping event-history igmp-snoop-internal size small

ip igmp snooping event-history mfdm size small

ip igmp snooping event-history mfdm-sum size small

ip igmp snooping event-history vpc size small

ip domain-lookup

ip arp timeout 1500

xml server max-session 8

hchassis#


version 4.1(2)E1(1f)

license grace-period

feature telnet

feature ssh

username admin password 5 !  role network-admin

username USERID password 5 $1$T9bjZYiV$uO5C8x9brdZBp6W0wPCvb1  role network-admin

password strength-check

banner motd # Nexus 4000 Switch #

ssh key rsa 1024

no ssh key dsa

ip domain-lookup

ip host hchassis 192.168.1.29

radius-server timeout 5

radius-server retransmit 1

radius-server deadtime 0

no ip radius source-interface

aaa group server radius radius

    deadtime 0

    use-vrf default

    no source-interface

switchname hchassis

no vlan dot1Q tag native

no system default switchport

system default switchport shutdown

system jumbomtu 9216

no logging event link-status default

no logging event trunk-status default

logging event link-status enable

logging event trunk-status enable

errdisable recovery interval 300

errdisable detect cause link-flap

no errdisable recovery cause link-flap

no errdisable recovery cause udld

no errdisable recovery cause bpduguard

errdisable detect cause loopback

no errdisable recovery cause storm-control

no errdisable recovery cause security-violation

no errdisable recovery cause psecure-violation

no errdisable recovery cause vpc-peerlink

no errdisable recovery cause failed-port-state

system jumbomtu 9216

class-map type qos match-all class-default

class-map type queuing match-any 1p7q4t-out-pq1

  match cos 1

class-map type queuing match-any 1p7q4t-out-q2

  match cos 2

class-map type queuing match-any 1p7q4t-out-q3

  match cos 0

class-map type queuing match-any 1p7q4t-out-q4

  match cos 4

class-map type queuing match-any 1p7q4t-out-q5

  match cos 5

class-map type queuing match-any 1p7q4t-out-q6

  match cos 6

class-map type queuing match-any 1p7q4t-out-q7

  match cos 7

class-map type queuing match-any 1p7q4t-out-q-default

  match cos 3

class-map type network-qos class1

  match cos 4

class-map type network-qos c-nq-8e

  match cos 0-7

class-map type network-qos c-nq-5e-drop

  match cos 0,4-7

class-map type network-qos c-nq-6e-drop

  match cos 0,2,4-7

class-map type network-qos c-nq-5e-ndrop

  match cos 1-3

class-map type network-qos c-nq-6e-ndrop

  match cos 1,3

policy-map type network-qos jumbo

  class type network-qos class1

    mtu 9216

policy-map type network-qos p-nq-5e

  class type network-qos c-nq-5e-drop

  class type network-qos c-nq-5e-ndrop

    pause no-drop

    mtu 2240

policy-map type network-qos p-nq-6e

  class type network-qos c-nq-6e-drop

  class type network-qos c-nq-6e-ndrop

    pause no-drop

    mtu 2240

policy-map type network-qos p-nq-8e

  class type network-qos c-nq-8e

system qos

  service-policy type queuing output default-out-policy

  service-policy type network-qos p-nq-8e

snmp-server aaa-user cache-timeout 3600

snmp-server protocol enable

no snmp-server globalEnforcePriv

snmp-server tcp-session auth

snmp-server user USERID network-admin auth md5 0x8459c266c6277f13a63c22a1d1787018 priv 0x8459c266c6277f13a63c22a1d1787018 loc

alizedkey

no snmp-server enable traps link

snmp-server enable traps license

no snmp-server enable traps aaa server-state-change

no snmp-server enable traps snmp authentication

snmp-server enable traps link standard-extended

callhome

  switch-priority 7

  destination-profile CiscoTAC-1

  destination-profile CiscoTAC-1 format XML

  destination-profile CiscoTAC-1 message-size 5000000

  destination-profile CiscoTAC-1 message-level 0

  destination-profile full_txt

  destination-profile full_txt format full-txt

  destination-profile full_txt message-size 2500000

  destination-profile full_txt message-level 0

  destination-profile short_txt

  destination-profile short_txt format short-txt

  destination-profile short_txt message-size 4000

  destination-profile short_txt message-level 0

  destination-profile CiscoTAC-1 alert-group cisco-tac

  destination-profile full_txt alert-group all

  destination-profile short_txt alert-group all

  no enable

  duplicate-message throttle

  periodic-inventory notification

  periodic-inventory notification interval  7

  periodic-inventory notification timeofday 08:00

aaa authentication login default local

aaa accounting default local

aaa user default-role

no aaa authentication login error-enable

no aaa authentication login mschap enable

no aaa authentication login ascii-authentication

no radius-server directed-request

vrf context management

vlan 1

  no cin

cdp advertise v2

cdp enable

cdp holdtime 180

cdp timer 60

cdp format device-id system-name

spanning-tree mode rapid-pvst

spanning-tree pathcost method short

no spanning-tree port type edge default

no spanning-tree port type network default

spanning-tree bridge assurance

no spanning-tree loopguard default

spanning-tree vlan 1

spanning-tree vlan 1 priority 32768

spanning-tree vlan 1 hello-time 2

spanning-tree vlan 1 forward-time 15

spanning-tree vlan 1 max-age 20

platform access-list update atomic

no platform access-list update default-result permit

platform rate-limit layer-3 mtu 500

platform rate-limit layer-3 ttl 500

platform rate-limit layer-3 control 10000

platform rate-limit layer-3 glean 100

platform rate-limit layer-3 multicast directly-connected 10000

platform rate-limit layer-3 multicast local-groups 10000

platform rate-limit layer-3 multicast rpf-leak 500

platform rate-limit layer-2 storm-control 0

platform rate-limit access-list-log 100

platform rate-limit copy 30000

platform rate-limit receive 30000

platform ip verify address source broadcast

platform ip verify address source multicast

platform ip verify address destination zero

platform ip verify address identical

platform ip verify address source reserved

platform ip verify checksum

platform ip verify protocol

platform ip verify fragment

platform ip verify length minimum

platform ip verify length consistent

platform ip verify length maximum max-frag

platform ip verify length maximum udp

platform ip verify length maximum max-tcp

platform ip verify tcp tiny-frag

platform ip verify version

platform ipv6 verify length consistent

platform ipv6 verify length maximum max-frag

platform ipv6 verify length maximum udp

platform ipv6 verify length maximum max-tcp

platform ipv6 verify tcp tiny-frag

platform ipv6 verify version

port-channel load-balance ethernet source-dest-ip

port-channel load-balance ethernet source-dest-ip module 1

interface Ethernet1/1

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/2

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/3

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/4

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/5

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/6

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/7

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/8

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/9

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/10

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/11

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/12

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/13

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/14

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed auto

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 1000000

no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/15

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/16

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/17

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/18

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/19

  no description

switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

  link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface Ethernet1/20

  no description

  switchport

  switchport mode access

  no switchport monitor

  priority-flow-control mode auto

  cdp enable

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  no spanning-tree bpduguard

  no spanning-tree bpdufilter

  speed 10000

  duplex full

  flowcontrol receive off

  flowcontrol send off

link debounce

  no beacon

  mtu 1500

  delay 1

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  bandwidth 10000000

  no bandwidth inherit

  mdix auto

  storm-control broadcast level 100

  storm-control multicast level 100

  storm-control unicast level 100

  medium broadcast

  no shutdown

interface mgmt0

  description

  speed auto

  duplex auto

  no shutdown

  cdp enable

  ip address 172.16.1.29/24

  ip redirects

  ip port-unreachable

  ip arp gratuitous update

  ip arp gratuitous request

interface mgmt1

  description

  speed auto

  duplex auto

  no shutdown

  cdp enable

line console

  no exec-timeout

  terminal length 24

  terminal width 80

line vty

  session-limit 16

  no exec-timeout

boot kickstart bootflash:/n4000-bk9-kickstart.4.1.2.E1.1f.bin

boot system bootflash:/n4000-bk9.4.1.2.E1.1f.bin

system health loopback frequency 60

system clis event-history ha size medium

ip igmp snooping

ip igmp snooping report-suppression

ip igmp snooping link-local-groups-suppression

ip igmp snooping event-history vlan size medium

ip igmp snooping event-history vlan-events size medium

ip igmp snooping event-history igmp-snoop-internal size small

ip igmp snooping event-history mfdm size small

ip igmp snooping event-history mfdm-sum size small

ip igmp snooping event-history vpc size small

ip domain-lookup

ip arp timeout 1500

xml server max-session 8

hchassis#


Highlighted
Cisco Employee

Re: Nexus 4000

Okay, I see the problem. In your current configuration, there is a network qos policy attached to the system qos config:

system qos

  service-policy type queuing output default-out-policy

  service-policy type network-qos p-nq-8e

In order to configure jumbo frame, you need to change the MTU value in the current policy-map p-nq-8e, or if you want to use a customize network qos policy, you can remove p-nq-8e first and attach a new network qos policy. To simplify it here, use the following commands to change the current network (p-nq-8e) qos's MTU value:

policy-map type network-qos p-nq-8e

  class type network-qos c-nq-8e

     mtu 9000

HTH,

jerry

View solution in original post

Highlighted
Beginner

Nexus 4000

Thank you for your time. I am pinging through with 8950 bytes now.

Highlighted
Cisco Employee

Re: Nexus 4000

Glad that it solved your problem.

Regards,

jerry

CreatePlease to create content
Content for Community-Ad