cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1035
Views
0
Helpful
5
Replies
Highlighted
Beginner

Nexus 5010 and Qlogic 8240 CNA

Greetings-

I am trying to configure get the QLogic 8240 card to work properly in ESXi 5.0.  I want to be able to send the iSCSI traffic down the iSCSI portion of the card and use the ethernet portion of the card to do NFS. 

Here are my vlans I am working with..

vlan 420 = fcoe

vlan 500 = NFS

vlan 1000 = iSCSI

I have my interface currenly set as the following on the Nexus 5000.

interface Ethernet1/17

  description SEIESX-05

  switchport access vlan 1001

This interface works just fine if I am doing iSCSi only.  I can see the initiators on my storage just fine.  If I switch the config from what I think it needs to be..

interface Ethernet1/17

  description SEIESX-05

  switchport trunk native vlan 999

  switchport mode trunk

  switchport trunk allowed vlan 420,500-502,999,1000

  spanning-tree port type edge trunk

I can not see the storage array via iSCSI any more.

My question is is the interface properyl configured on the Nexus to do what I am trying to do?

Frank

Everyone's tags (3)
5 REPLIES 5
Highlighted
Hall of Fame Expert

Nexus 5010 and Qlogic 8240 CNA

Frank,

You Nexus trunk config is correct, but I see a typo or error in the vlans defined.

switchport access vlan 1001

switchport trunk allowed vlan 420,500-502,999,1000

Vlan 1001 has not been added to the trunk or access vlan 1001 should be 1000?

HTH

Highlighted
Beginner

Re: Nexus 5010 and Qlogic 8240 CNA

yeah sorry its a typo..  I was grabbing part of the config from one of my nexus 5010 and then grabbed from another.

So when I take the trunking off and just put the port as "switchport access vlan 1000" then I can see my storage/iqn's.  But if I try to use it with the new config

interface Ethernet1/17

description SEIESX-05

switchport trunk native vlan 999

switchport mode trunk

switchport trunk allowed vlan 420,500-502,999,1000

spanning-tree port type edge trunk

I get nothing.

Everything I try to search for is for configuring fcoe with ethernet not iSCSI and ethernet.  I can post my config if necessary.

Frank

Highlighted
Hall of Fame Expert

Nexus 5010 and Qlogic 8240 CNA

Not familiar with storage that much, except what I can remember from my Netapp class, but I assume the Qlogic card is installed in the IBM chassis or something like it right?

if so, is the other side of the connection configured as trunk too?

Reza

Highlighted
Beginner

Nexus 5010 and Qlogic 8240 CNA

The Qlogic CNA card is in a VmWare ESXi 5.0 server/Host.  I dont think the issue is on the NetApp side, but I think its on the VmWare side.  Not sure where to enable trunking at because its a CNA card not a regualr ethernet adapter.

Frank

Highlighted
Hall of Fame Expert

Nexus 5010 and Qlogic 8240 CNA

There has to some where you can enable dot.1q on the CNA card.  According to the data sheet is is supported:

••IEEE : 802.3ae (10Gb E thernet), 802.1q (VLAN),

http://www.qlogic.com/Resources/Documents/DataSheets/Adapters/Datasheet_8200_Series_Adapters.pdf

CreatePlease to create content
Content for Community-Ad