cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
14126
Views
0
Helpful
27
Replies
Edgar.Delgado
Beginner

Nexus 5020 upgrade iOS

Everyone need some help with Nexus 5020

I'm trying to upgrade the iOS software

Here is the problem, I can't seem to copy over the file to the Switch

I have tried these steps please let me know if its incorrect!

copy bootflash:

no go

Copy bootflash tftp:

no go

copy bootflash: filename

no go

I tried WINSCP

no

I have tried cisco device manager " busy network no route or snmpd is unresponsive "

no go

I'm not a networking person but trying to learn and can't seem to get the new bin file copyed over to the switch

Any help would be great

Thanks,

Ed

27 REPLIES 27

You can try to put this in first. If the switch takes the commands, do copy tftp://x.x.x.x bootflash: afterward.

conf t

vrf context management

0.0.0.0/0 y.y.y.y <- y.y.y.y is your default gateway/router IP address

HTH,

jerry

View solution in original post

Will the command make any changes only to the vrf context management?

I don't want to scerw up the producation network with the change

It will only do the change in the management VRF.

Simplest thing to do would be to run #: setup

It will run you through the basic setup again, you can put the IP address in, and the GATEWAY in which will fill out the vfc context managment stuff for you.

Then once that is in, you do a copy tftp:10.x.x.x/n5000-uk9.kickstart.5.x.x.x.bin bootflash:n5000-uk9.kickstart.5.x.x.x.bin .

It will ask you what VRF to use, type management

It should then attempt to connect to your TFTP server.

If VRF MANAGEMENT is empty, it has no route out of the box. Are you connecting to this via SSH or on Console?

View solution in original post

I'm using a laptop connecting via console cable.

Yah, just run the setup again, it will configure the base system for you if you skip items such as IP or System name it wont change them.

Once you have done that, try and run a cmd like ping... so #: ping xxx.xxx.xxx.xxx vrf management

If you can then ping try running the copy command again #: copy tftp:xxx.xxx.xxx.xxx/tftp_root/file.bin booflash:file.bin

View solution in original post

Everyone Thanks for the help and for the quick reply's

conf t

vrf context management

0.0.0.0/0 y.y.y.y <- y.y.y.y is your default gateway/router IP address.

This worked !!

THANKS !!!

 

I have the same problem, Trying to upload the licence file .lic to nx 9300 switch. Tried all ftp/scp/tftp, but no joy... pc/switch can ping each other but no file transfer. e.g TFTP error says,

Trying to connect to tftp server......

connection to server established.  (wait for few seconds)

TFTP get operation failed: Connection timeout.

 

If someone can advise on the above issue ?

 

Thanks

Resolved by ourself!

How do you resolve this? I'm currently facing this issue

probem here it ask for tftp interface wont alow u connect to managemt port  so how do u up load u force to got port 1/1 well ciso wont even alow u use l1 port  so u have map 1/1 to eathernet port dosent work. cant give it ip address,  

so back to routeing all routeing in place fack is u have no way to link 1/1 to eathenet with ip  iptables should depend on startup information probem is no iptables,  throw them done this for years can do this them just few years expeace cant make it work

so why dont ciso just dont automate this with scrips  hay i see this ip address and hay i see that i need map it  is cisco so out of it that such small things cant be automated i say this is progameing probem  throw might be away around it is not forcomeing 

cisco wont tell us how do it, may be do fack all there ios now comeing how chana and they may not know how it works, 

u know i never went school for this have add why cant spell but i can see probems in software, but i got bigger quistion if them that make cars can be force recall them do to defects why cant these people who make software hardware be held to same leagle standers, yes never try in law this way,  and user agreement dose not proteck them agest hole os has probems and u have pay to get fix, if i had car be fix at no cost what diffrence in two, 

this software i found over 100 probems with it, and i got 60 page config. and still much of it the ios is damage, ask cisco would they like law sute on a) that they responsable for software to be right out box, or responsable for fixing regadless the age 2) there ileagle colletion of information and they dont tell u what they do collet but much i bet has do how u config the unit  i dont have money for such task but i can prove ios is badly made and damage right out the box, so am i responsable to get fix or them who made it,  time and time over i ask one qustion, cisco could make 100s of millions of dollers for limted support charge people 100,00 to up date or get out dated lic that for item no longer used, but even cisco refuses to even look at this possably throw will state this idea is copy writed and is own by me,  cisco wants it they come to me as they said u pay person, something else

i make these system hack proof my home computers uses a 256 bit password, it is not possable to hack and not possable to rembemer but they is a way to intergrate this into all there systems again copy writed by me,  u cant hack a encripted 256 password and to key username it can be just as inported as password, it should be something no one could guss, my user names are 156 bit,  so first u have hack user name then hack password by then i have all logs whos doing what, 

cisco know far to well they be made hack proof so why dont they nsa wont alow them but if i was cisco i tell nsa f off and i would go after the people not goverment agenety it is people who makeing the choice they ones need sue, as they working out side of there office by demainding that system must have back doors, should give people lot ideas to condiser 

Is the last post a hack attempt ? Clearly Google Translate was used...I have no idea what it says, though...

simle to load to the server must be done this way

management port must have routes

copy tftp: bootflash:

file name 

vrf do not leave blank wont work must say management 

ip of tftp server,    

read file sh file file name 

throw no where in cisco do they even tell u how this is done, nor do the experts why they dont know they got software

to up load software