cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1988
Views
0
Helpful
19
Replies
Highlighted
Beginner

Nexus 5548 connected to a WS-C3750-24FS-S

we are having trouble with the VPC, and etherchannel ? looked at many forums not to clear on wich one to use, this is are config, we have been getting alot of loops and kills are entire network, please help

nexus switch config,

this is on both nexus we have 2 of them at this site, that talk back to 2 other ones back to another site

pd554801

interface port-channel9

  description *PD3750_Fiber01 network rack*

  switchport mode trunk

  speed 1000

  duplex full

  vpc 9

interface Ethernet1/4

  description *PD3750_Fiber01 network rack*

  switchport mode trunk

  speed 1000

  duplex full

  channel-group 9

pd554802

interface port-channel9

  description *PD3750_Fiber01 network rack*

  switchport mode trunk

  speed 1000

  duplex full

  vpc 9

interface Ethernet1/4

  description *PD3750_Fiber01 network rack*

  switchport mode trunk

  speed 1000

  duplex full

  channel-group 9

***************************************************************************

3750 switch config

interface Port-channel9

description *port channel to pd3750_Fiber_01*

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

interface GigabitEthernet1/0/1

description *PD554801/p4 TRK*

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 9 mode on

!

interface GigabitEthernet1/0/2

description *PD554802/P4 trunk port*

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 9 mode on

19 REPLIES 19
Highlighted
Enthusiast

I believe you need to use "channel-group 9 mode on" on the NX-OS side as well instead of the "channel-group 9" command you have.

Highlighted

i do have that , and have made sure, it will not show up on the nexus, if i go and put mode active it will show up, like this

interface Ethernet1/4

  description *PD3750_Fiber01 network rack*

  switchport mode trunk

  speed 1000

  channel-group 9 mode active

Highlighted

That's odd, I am using LACP on all my nexus port channels so they look the same as the IOS. I was not aware that the forced ones showed differently in the running config.

Could you provide the output of a "show port-channel summary" and a "show interface port-channel 9' for these devices. Also have you considered trying to change over to LACP on this? I find LACP port channels to be much more reliable and less finicky personally.

Highlighted

Also, could you provide the configuration of your VPC peer link and a "show VPC brief"?

Highlighted

port channel summary

1     Po1(SU)     Eth      NONE      Eth1/1(P)

6     Po6(SU)     Eth      NONE      Eth1/18(P)

8     Po8(SU)     Eth      NONE      Eth1/5(P)    Eth1/6(D)

9     Po9(SD)     Eth      LACP      Eth1/4(D)

20    Po20(SU)    Eth      NONE      Eth1/15(P)   Eth1/17(P)

101   Po101(SU)   Eth      NONE      Eth1/31(P)

102   Po102(SU)   Eth      NONE      Eth1/32(P)

sh int port chann 9  ( this will show down because i shut it down for know unitl i figure out how to configure it right )

PD554801# show interface port-channel 9

port-channel9 is down (Administratively down)

vPC Status: Down, vPC number: 9 [packets forwarded via vPC peer-link]

  Hardware: Port-Channel, address: 0000.0000.0000 (bia 0000.0000.0000)

  Description: *PD3750_Fiber01 network rack*

  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec

  reliability 9946/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  auto-duplex, 1000 Mb/s

  Input flow-control is off, output flow-control is off

  Switchport monitor is off

  EtherType is 0x8100

  Members in this channel: Eth1/4

  Last clearing of "show interface" counters never

  30 seconds input rate 0 bits/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    165854 unicast packets  8645 multicast packets  4636 broadcast packets

    179135 input packets  97802516 bytes

    40900 jumbo packets  0 storm suppression bytes

    663 runts  0 giants  0 CRC  0 no buffer

    5332543433783378253 input error  0 short frame  0 overrun   0 underrun  0 ignored

    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop

    0 input with dribble  0 input discard

    0 Rx pause

  TX

    3576984 unicast packets  1107538 multicast packets  509810 broadcast packets

    5194332 output packets  3770989418 bytes

    659386 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble 0 output discard

    0 Tx pause

  1 interface resets

and as for LACP, if it will fix it, the problem i have is there is noe clear documentation on wich is better ot the correct way to do them?  how would you do LACP correctly. this is the forst time i have ever worked on nexus switches with so many different commands, i have a basic concept but no way an expert, thank you

Highlighted

sh vpc brief

PD554801# sh vpc brief

Legend:

                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 20

Peer status                     : peer adjacency formed ok

vPC keep-alive status           : peer is alive

Configuration consistency status: success

Per-vlan consistency status     : success

Type-2 consistency status       : failed

Type-2 consistency reason       : SVI type-2 configuration incompatible

vPC role                        : primary

Number of vPCs configured       : 102

Peer Gateway                    : Disabled

Dual-active excluded VLANs      : -

Graceful Consistency Check      : Enabled

vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans

--   ----   ------ --------------------------------------------------

1    Po20   up     1,3-4,9-12,16-18,20-22,30,64,68-69,100,113,150-154

                   ,156-167,173,180-184,187-192,197-200,218,226-227,2

                   49-250,260,295-297,301,320-326,351,600-601

vPC status

----------------------------------------------------------------------------

id     Port        Status Consistency Reason                     Active vlans

------ ----------- ------ ----------- -------------------------- -----------

1      Po1         up     success     success                    1,3-4,9-12,

                                                                 16-18,20-22

                                                                 ,30,64,68-6

                                                                 9,100,113,1

                                                                 50-154,1....

6      Po6         up     success     success                    1,3-4,9-12,

                                                                 16-18,20-22

                                                                 ,30,64,68-6

                                                                 9,100,113,1

                                                                 50-154,1....

8      Po8         up     success     success                    1,3-4,9-12,

                                                                 16-18,20-22

                                                                 ,30,64,68-6

                                                                 9,100,113,1

                                                                 50-154,1....

9      Po9         down*  success     success                    -

101    Po101       up     success     success                    -

102    Po102       up     success     success                    -

102400 Eth101/1/1  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102401 Eth101/1/2  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102402 Eth101/1/3  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102403 Eth101/1/4  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102404 Eth101/1/5  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102405 Eth101/1/6  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102406 Eth101/1/7  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102407 Eth101/1/8  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102408 Eth101/1/9  down*  Not         Consistency Check Not      -

                          Applicable  Performed

102409 Eth101/1/10 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102410 Eth101/1/11 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102411 Eth101/1/12 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102412 Eth101/1/13 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102413 Eth101/1/14 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102414 Eth101/1/15 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102415 Eth101/1/16 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102416 Eth101/1/17 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102417 Eth101/1/18 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102418 Eth101/1/19 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102419 Eth101/1/20 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102420 Eth101/1/21 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102421 Eth101/1/22 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102422 Eth101/1/23 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102423 Eth101/1/24 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102424 Eth101/1/25 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102425 Eth101/1/26 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102426 Eth101/1/27 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102427 Eth101/1/28 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102428 Eth101/1/29 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102429 Eth101/1/30 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102430 Eth101/1/31 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102431 Eth101/1/32 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102432 Eth101/1/33 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102433 Eth101/1/34 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102434 Eth101/1/35 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102435 Eth101/1/36 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102436 Eth101/1/37 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102437 Eth101/1/38 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102438 Eth101/1/39 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102439 Eth101/1/40 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102440 Eth101/1/41 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102441 Eth101/1/42 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102442 Eth101/1/43 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102443 Eth101/1/44 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102444 Eth101/1/45 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102445 Eth101/1/46 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102446 Eth101/1/47 down*  Not         Consistency Check Not      -

                          Applicable  Performed

102447 Eth101/1/48 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103424 Eth102/1/1  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103425 Eth102/1/2  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103426 Eth102/1/3  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103427 Eth102/1/4  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103428 Eth102/1/5  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103429 Eth102/1/6  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103430 Eth102/1/7  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103431 Eth102/1/8  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103432 Eth102/1/9  down*  Not         Consistency Check Not      -

                          Applicable  Performed

103433 Eth102/1/10 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103434 Eth102/1/11 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103435 Eth102/1/12 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103436 Eth102/1/13 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103437 Eth102/1/14 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103438 Eth102/1/15 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103439 Eth102/1/16 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103440 Eth102/1/17 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103441 Eth102/1/18 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103442 Eth102/1/19 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103443 Eth102/1/20 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103444 Eth102/1/21 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103445 Eth102/1/22 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103446 Eth102/1/23 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103447 Eth102/1/24 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103448 Eth102/1/25 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103449 Eth102/1/26 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103450 Eth102/1/27 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103451 Eth102/1/28 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103452 Eth102/1/29 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103453 Eth102/1/30 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103454 Eth102/1/31 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103455 Eth102/1/32 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103456 Eth102/1/33 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103457 Eth102/1/34 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103458 Eth102/1/35 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103459 Eth102/1/36 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103460 Eth102/1/37 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103461 Eth102/1/38 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103462 Eth102/1/39 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103463 Eth102/1/40 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103464 Eth102/1/41 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103465 Eth102/1/42 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103466 Eth102/1/43 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103467 Eth102/1/44 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103468 Eth102/1/45 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103469 Eth102/1/46 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103470 Eth102/1/47 down*  Not         Consistency Check Not      -

                          Applicable  Performed

103471 Eth102/1/48 down*  Not         Consistency Check Not      -

                          Applicable  Performed

Highlighted

I cannot glean a whole lot of info about why it is not working as configured with it in the shutdown state. If you are open to the idea I would definitely recommend trying LACP.

LACPs main advantage over static port channeling is intelligence, LACP will communicate with the other side and make the best connection possible. With a static ether channel, if everything is not perfect you are pretty much hosed.

Highlighted

great thanks, i will put LCAP witch is active, do i need to also put that on the 3750 side as well?

Highlighted

Yes, both side will need to be set to LACP. I always like to set one side to active and one side to passive when I configure them, but you could also set both sides to active.

Highlighted

do you gain anything by putting one side active and the other passive?

Highlighted

I just like to know where the initiation is originating, no scientific reason for it or anything.

Highlighted

ahhh great thanks, i will try this and let you know the out come, next monday is when i can try it again, i will let you know, so if i were to put active and passive, the passive would be on the 3750 side correct?

Highlighted

Doesn't matter which one is the active side, do whatever makes sense to you.

Highlighted

ok, thanks, i will let you know how things go when i turn on the switch again, thank you

Content for Community-Ad