cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

115
Views
0
Helpful
3
Replies
Explorer

Nexus 5596T Software Recomendation

We purchased a couple Nexus 5596T Switches that came with older firmware on them:

n5000-uk9.5.2.1.N1.4.bin

and

n5000-uk9-kickstart.5.2.1.N1.4.bin

I would like to update the firmware before putting them into production.  I notice there is version 5, 6, and 7 software versions available for these switches.  Does anyone have a recommendation as to which version is best (and most stable) for production use?  I will be connecting various EMC and Cisco Storage and Server devices to these switches at 10 Gbit speeds either 10GigBaseT, 10GigLR SFP+, or 10Gig SFP+ Direct Attach Cables? 

What would you recommend?

Also, do I need to load the kickstart or main software first?  I do have Cisco Prime Infrastructure and am planning to push the software updates from there. 

3 REPLIES 3
VIP Expert

Hi,

Hi,

It is hard to tell what version is stable as almost every version has its own bugs. It also depend on the feature set you will be using.  I recommend you pick a version in 7 series, read the release notes carefully, load and test it before putting it in production. Yes, you need both kickstart and the system image.

HTH

Explorer

Thanks for the advice, I'll

Thanks for the advice, I'll take a look at the version 7 images.  We are just using the basic layer 2 features, so nothing fancy as far as feature sets. 

Highlighted
Enthusiast

It appears to be that Cisco

It appears to be that Cisco doesn't recommend a certain code version for Nexus 5596T. As Reza stated it's a critical point to carefully consider the right code for your environment. As always, test before deploying to production.

Please see:


Table 6 Cisco NX-OS Release 7.0(8)N1(1) Supported Upgrade and Downgrade Paths

Current Cisco NX-OS Release
Upgrade to NX-OS Release 7.0(8)N1(1)
Downgrade from NX-OS Release 7.0(8)N1(1)

7.0(0)N1(1)—7.0(7)N1(1)23 24

6.0(2)N2(4)—6.0(2)N2(7)
6.0(2)N2(2)
5.2(1)N1(6)—5.2(1)N1(9a)25

Non-disruptive upgrade (ISSU)

Disruptive downgrade

23.Possibility of ISSU failure if you are upgrading to Cisco NX-OS release 7.0(6)N1(1) or earlier when multi-step ISSU is performed. For multi-step ISSU, it is recommended to upgrade directly to Cisco NX-OS Release 7.0(7)N1(1) or 7.0(8)N1(1). See CSCuw78727 for details.

24.Performing a multi-step ISSU from Cisco NX-OS release 5.1(3)Nx(x) to 5.2(1)N1(x) to 7.0(5)N1(1) could result in fabric logout of FCoE hosts and vFCs to remain in an initializing state.

25.Non-disruptive upgrade is not supported for Cisco NX-OS Release 5.2(1)N1(8a).


Note When you upgrade (ISSU upgrade or non-ISSU upgrade) from Cisco NX-OS Release 6.0(2)N2(7) to Cisco NX-OS Release 7.0(6)N1(1) or later releases, Dynamic Host Configuration Protocol (DHCP) OFFER packets get dropped. We recommend you disable the ip dhcp relay command and reconfigure it after the upgrade.

and its limitation section. 

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5500/sw/release/notes/7x/Nexus5500_Release_Notes_7x.html

Good luck!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards