cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3211
Views
0
Helpful
3
Replies
Highlighted

Nexus 5672 to Cisco 3850 port-channel status in noOperMem

I've got multiple port-channels configured between 2 Nexus 5672's to 9 different closets containing either 1 or upto 3 Cisco 3850 switches.  Each closet has 2 fiber 10G SFP's uplinking it to each of the Nexus 5672 switches in the core.  All uplink's and port-channels are working correctly except for one of my IDF's.  The port configurations of all three of the devices (2 Nexus 5672's and 1 Cisco 3850) along with log entries and interface status are shown below. I can't seem to figure out why the port-channel for this IDF isn't working.  In addition to the output provided below, I've also replaced the SFP on both sides of the link along with fiber cabling being used between the Nexus 5672 and the Cisco 3850.

My configuration –

Nexus 5672-1 10G SFP (eth1/18) connected via fiber to Cisco 3850-idf4 10G SFP (te1/1/3)

Nexus 5672-2 10G SFP (eth1/18) connected via fiber to Cisco 3850-idf4 10G SFP (te1/1/4)

 

Nexus 5672-1 config –

interface port-channel18

  description tx502-sw3850-idf4

  switchport mode trunk

  speed 10000

  vpc 18

 

interface Ethernet1/18

  description tx502-sw3850-idf4 Te1/1/3

  switchport mode trunk

  channel-group 18 mode active

  no shutdown

 

Nexus 5672-2 config –

interface port-channel18

  description tx502-sw3850-idf4

  switchport mode trunk

  speed 10000

  vpc 18

 

interface Ethernet1/18

  description tx502-sw3850-idf4 Te1/1/4

  switchport mode trunk

  channel-group 18 mode active

  no shutdown

 

Cisco 3850 config –

interface Port-channel1

 switchport mode trunk

 

interface TenGigabitEthernet1/1/3

 switchport mode trunk

 channel-group 1 mode active

!

interface TenGigabitEthernet1/1/4

 switchport mode trunk

 channel-group 1 mode active

 

Output from “show interface status” on Cisco 3850 –

Te1/1/3                      suspended    trunk        full    10G SFP-10GBase-SR

Te1/1/4                      connected    trunk        full    10G SFP-10GBase-SR

Po1                          connected    trunk      a-full    10G

 

Log entries from Cisco 3850 -

Sep  2 13:46:58.328: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/3, changed state to down

Sep  2 13:48:18.217: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/3, changed state to up

Sep  2 13:48:27.427: %EC-5-L3DONTBNDL2: Te1/1/3 suspended: LACP currently not enabled on the remote port.

 

 

Output from “show interface status” on Nexus 5672-1 –

Eth1/18       tx502-sw3850-idf4  htStdbyIn trunk     full    10G     10Gbase-SR

Po18          tx502-sw3850-idf4  noOperMem trunk     full    10G     --

 

Log entries from Nexus 5672-1 –

2016 Sep  5 09:08:59 tx502-nx5672-dc1-1 %ETHPORT-5-SPEED: Interface port-channel18, operational speed changed to 10 Gbps

2016 Sep  5 09:08:59 tx502-nx5672-dc1-1 %ETHPORT-5-IF_DUPLEX: Interface port-channel18, operational duplex mode changed to Full

2016 Sep  5 09:08:59 tx502-nx5672-dc1-1 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface port-channel18, operational Receive Flow Control state changed to off

2016 Sep  5 09:08:59 tx502-nx5672-dc1-1 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface port-channel18, operational Transmit Flow Control state changed to off

2016 Sep  5 09:09:24 tx502-nx5672-dc1-1 %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY: port-channel18: Ethernet1/18 goes to hot-standby

 

Output from “show interface status” on Nexus 5672-2 –

Eth1/18       tx502-sw3850-idf4  connected trunk     full    10G     10Gbase-SR

Po18          tx502-sw3850-idf4  connected trunk     full    10G     --

Everyone's tags (3)
3 REPLIES 3
Highlighted
Enthusiast

Hi;

Hi;

It seems to be 2 issue:

1) Either port is not connected to right interface on Nexus 5672-1 side, instead of E1/18 its connected to E1/X port.

2) Either its E1/18 port issue (Hardware issue). Reconfigure some other free port of Nexus 5672-1 and connect the idf4 cable and verify the port-channel and vpc status.

Thanks & Best regards;

Highlighted

Okay,  I've tried both your

Okay,  I've tried both your suggestions and neither one had any change on the final status of the interfaces.

1) I verified that the fiber is connected into Eth1/18 on Nexus 5672-1.

2) I setup Eth1/1 on Nexus 5672-1 the same as Eth1/18 was setup.  I used a different SFP in Eth1/1 than what was in Eth1/18 and I also changed the fiber patch cord between the fiber distribution panel and Eth1/1 on Nexus 5672-1.

The interface on the Cisco 3850, Te1/1/3 is still reporting as being suspended.

[Te1/1/3                      suspended    trunk        full    10G SFP-10GBase-SR]

The interface on the Nexus 5672-1, Eth1/1 is reporting as being in htStdbyIn.

[Eth1/1                      htStdbyIn trunk full 10G 10Gbase-SR]

The port channel on the Nexus 5672-1, Po18 is reporting noOperMem.

[Po18                              noOperMem trunk     full    10G     --]

The log entries from the Nexus 5672-1 are as follows...

2016 Sep 10 14:28:51 tx502-nx5672-dc1-1 %ETHPORT-5-IF_ADMIN_UP: Interface Ethernet1/1 is admin up .
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-SPEED: Interface Ethernet1/1, operational speed changed to 10 Gbps
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_DUPLEX: Interface Ethernet1/1, operational duplex mode changed to Full
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/1, operational Receive Flow Control state changed to off
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/1, operational Transmit Flow Control state changed to off
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-SPEED: Interface port-channel18, operational speed changed to 10 Gbps
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_DUPLEX: Interface port-channel18, operational duplex mode changed to Full
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface port-channel18, operational Receive Flow Control state changed to off
2016 Sep 10 14:28:55 tx502-nx5672-dc1-1 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface port-channel18, operational Transmit Flow Control state changed to off
2016 Sep 10 14:29:00 tx502-nx5672-dc1-1 %VSHD-5-VSHD_SYSLOG_CONFIG_I: Configured from vty by admin on 10.15.2.110@pts/0
2016 Sep 10 14:29:20 tx502-nx5672-dc1-1 %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY: port-channel18: Ethernet1/1 goes to hot-standby
2016 Sep 10 14:29:38 tx502-nx5672-dc1-1 %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY_DOWN: port-channel18: hot-standby port Ethernet1/1 is down

Highlighted
Beginner

Re: Okay,  I've tried both your

i  have the same exact issue

i have 2 nexus 5672 in vpc and a port channel to a stack of 3850

all was working fine till we upgraded the os

we went to fuji 16.9.1 on 3850 and 7.3.4(N1)1 on nexus

 

i converted the uplink to mode on and is working fine.

but when i make it lacp i get hot standby in the port on nexus and suspended on the catalyst

 

Content for Community-Ad